×

INDI Library v2.0.7 is Released (01 Apr 2024)

Bi-monthly release with minor bug fixes and improvements

How do I change the language for Kstars in v 3.6.0? (Help menu doesn't work)

  • Posts: 126
  • Thank you received: 16
Hi,
I installed Astroberry 2.0,4 on a new SD card and created a new profile for my gear. I also set the locale to Swedish, with a Swedish layout keyboard. In Kstars (before upgrade: 3.5.5) I set the language from Swedish to British English with alternative language US English. Restarted Kstars and the changes took effect. So far, so good.
I then upgraded the system (sudo apt update, sudo apt upgrade), and got the newest Kstars (3.6.0). But with the upgrade, the language defaulted back to Swedish, even though in the Kstars Help menu it still says British English with alternative language US English. Just to be sure, I first switched back to Swedish, restarted Kstars and then chose English again, but to no effect.

So, how do I set the Kstars language?
The reason I'm asking is that the Swedish translation of Kstars just doesn't work. Part of even the basic labels are in English (like "Close"), while concepts that lack a counterpart in Swedish seem to be translated using Google translate.
1 year 7 months ago #86236

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 6
Hi Wim,

I experience the same problem.
The "Switch Application Language" menu doesn't work. Kstars stays locked to French whatever the language I choose.
I would prefer US English but it seems the application set automatically the language according to the registered location.

I already reported this bug few weeks ago on KDE - bugs.kde.org/show_bug.cgi?id=458412
I have had a question from Jasem that I answered but that's all.

This problem is not new and several similar bug reports were already issued.

PYB
The following user(s) said Thank You: Wim van Berlo
1 year 7 months ago #86241

Please Log in or Create an account to join the conversation.

  • Posts: 126
  • Thank you received: 16
Thanks for the reply. It seems that kstars takes the language from the Locale settings, as you wrote. Do you by any chance know where the localization files are stored. Maybe it's possible to improve the translations locally.
Last edit: 1 year 7 months ago by Wim van Berlo.
1 year 7 months ago #86249

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 6
No sorry Wim, I do not have any clue to circumvent this bug.
I hope that it will be fixed soon with a future release.
PYB
The following user(s) said Thank You: Wim van Berlo
1 year 7 months ago #86263

Please Log in or Create an account to join the conversation.

  • Posts: 62
  • Thank you received: 12
Hi. Any progress? I have everything in Czech (environment settings in Linux) and I can't switch to English :-(

Thanks.
1 year 6 months ago #87030

Please Log in or Create an account to join the conversation.

  • Posts: 126
  • Thank you received: 16
Unfortunately not. The most annoying part is that filter names are in english, but show in swedish. At first I was afraid they would be in swedish in the fits header also, but it turns out that swedish is limited to the gui. In the drivers panels in Ekos, some fields allow non-english characters, while others don't. It's all very frustrating.
1 year 6 months ago #87033

Please Log in or Create an account to join the conversation.

Time to create page: 0.738 seconds