×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Ekos aborting after re-alignment

  • Posts: 8
  • Thank you received: 0
Hi Folks,I'm running Kstars 3.6.1 and I'm having trouble with the "Verify image position" feature. I currently have Ekos set to verify the image alignment after each frame with a tolerance of 1 arcminute. On the few occasions when this happens, Ekos appears to detect the misalignment and goes through a re-alignment process ... but then just stops rather than resuming the imaging session. Not sure if this is a known issue or if I have some thing set up wrong. Attached is a screenshot from Ekos Analyze window and the end of the log file where Ekos detects the misalignment, re-aligns, and then seems to do nothing after realignment is complete. Happy to send the full long file if anyone is interested.Thanks for taking a look.-Bret

File Attachment:

File Name: log.txt
File Size:14 KB

File Attachment:

File Name: log.txt
File Size:14 KB
3 months 7 hours ago #87700
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 60
  • Thank you received: 13
Yep, I just saw this too. Under aborted job management I have Immediate retry selected, and errors rescheduled after 30s... which clearly didn't happen.

...
2022-11-03T22:09:35 NGC2244 Rosette Nebula 11/05 00:10 --> 03:41 job completion
2022-11-03T22:09:34 Scheduler started.
2022-11-03T22:09:34 Scheduler is awake.
2022-11-03T21:34:59 Job 'NGC2244 Rosette Nebula' has not been processed upon scheduler stop, marking aborted.
2022-11-03T21:34:59 Job 'M33 Triangulum LPro' has not been processed upon scheduler stop, marking aborted.
2022-11-03T21:34:59 Job 'M45 Pleiades LPro' has not been processed upon scheduler stop, marking aborted.
2022-11-03T21:34:59 Warning: job 'M31 Andromeda LPro' captureAndSolve request failed.
2022-11-03T21:34:59 Captured frame is 2.0 arcminutes away from target, re-aligning...
2022-11-03T20:15:40 Job 'M31 Andromeda LPro' capture is in progress...
...
2 months 4 weeks ago #87798

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0
Thanks for chiming in ... I was beginning to think this forum wasn't the right place. Last night, I tried an experiment where I deliberately gave the scope a little bump while an imaging session was running to force a realignment while I was present. The result was interesting ... Ekos detected the misalignment and started a re-alignment, but while the re-alignment was underway, I checked the status in the scheduler and found that the job had already been errored out and was stopped! As such, when the re-alignment completed, there was no job to resume ... the scope just sat there. :/
2 months 3 weeks ago #87818

Please Log in or Create an account to join the conversation.

  • Posts: 930
  • Thank you received: 432
Thanks for the error reports. Appreciate it.

I believe I found the bug in Bret's log and just fixed it in the latest code.
If you recompile from source, you can test that now, or try out a nightly 3.6.2beta compile in the next day or two.
Otherwise, it will be in the next release.

Hy
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
2 months 3 weeks ago #87888

Please Log in or Create an account to join the conversation.

  • Posts: 225
  • Thank you received: 16
Hy,

I wonder if this will fix my occasional failure to restart capture after realigning?

Also, I notice that most of my alignment aborts are caused by a blurry image when aligning (usually the second image)... like the mount was still moving from the last position. It's like the program is ignoring the "settling" time and just immediately takes an image. Is that something you could check?

Thanks,

Ron
Mounts: Sky-Watcher EQ6-R Pro, Meade LX85
OTAs: Celestron 8" Edge HD w/HyperStar, Meade 80mm APO Triplet Refractor
Cameras: ASI533MC Pro, ASI183MC Pro, ASI224MC, ASI120MC-S, ZWO ASI290MM
Computing: Raspberry Pi 4 with Stellarmate OS, ASIAir Plus, MacBook Pro
2 months 3 weeks ago #87890

Please Log in or Create an account to join the conversation.

  • Posts: 930
  • Thank you received: 432
Ron,

The code looks ok for settling. I too have seen star trails occasionally in align images. I assume they have to do with the mount driver reporting it is done slewing long before it really is done. Most of the time this works out ok as align retries.

Can you make sure your settle time is greater than 3.0 seconds, and keep logging align, and send me a log the next time you see this?
(The way the code is written, it only logs settling if the settling time is > 3.0 seconds--it should still wait, it just doesn't log it, but to debug it would be good to see the message.)
Then we could see if it is indeed waiting the 3+ seconds to settle, or if there is some bug there.

The bug I found, based on Bret's log, relates to an aborted capture followed quickly by an align. This happens when the scheduler's alignment check finds a large misalignment, cancels the current capture, and requests realignment. In Bret's case the align failed because it thought capture was still running (and so couldn't access the camera). Align, though, was happy to wait and retry 10s later, and probably would have succeeded, but the scheduler saw the align failure and quit. My fix, of course, was to NOT have the scheduler quit when align fails but is going to retry.

Hy
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
2 months 3 weeks ago #87891

Please Log in or Create an account to join the conversation.

  • Posts: 225
  • Thank you received: 16
Hy,

Thanks! That issue may have been what I also experienced.

I will set the settling to 3.0 seconds (currently using 2.0). I'll update the nightly tomorrow so I'm running the latest version.

It looks like I have a bit of testing to do next outing! Looks like there may be some decent skies on Tuesday.

Ron
Mounts: Sky-Watcher EQ6-R Pro, Meade LX85
OTAs: Celestron 8" Edge HD w/HyperStar, Meade 80mm APO Triplet Refractor
Cameras: ASI533MC Pro, ASI183MC Pro, ASI224MC, ASI120MC-S, ZWO ASI290MM
Computing: Raspberry Pi 4 with Stellarmate OS, ASIAir Plus, MacBook Pro
2 months 3 weeks ago #87892

Please Log in or Create an account to join the conversation.

  • Posts: 60
  • Thank you received: 13


Got a small window in the clouds tonight, and was able to test... it works
2022-11-08T18:56:58 Job 'M 31' is capturing and plate solving.
2022-11-08T18:56:57 Job 'M 31' slew is complete.
2022-11-08T18:56:18 Job 'M 31' is slewing to target.
2022-11-08T18:56:16 Scheduler is awake. Jobs shall be started when ready...
2022-11-08T18:56:16 Waiting 0 seconds to restart job 'M 31'.
2022-11-08T18:56:16 Job 'M 31' is terminated due to errors.
2022-11-08T18:56:16 Warning: job 'M 31' slew failed, marking terminated due to errors.
2022-11-08T18:56:07 Job 'M 31' is slewing to target.
2022-11-08T18:56:04 Mount already unparked.
2022-11-08T18:56:02 Ekos is already started, skipping startup script...
Last edit: 2 months 3 weeks ago by Chris Kuethe. Reason: updated log
2 months 3 weeks ago #87899
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0
Thanks a bunch for finding and fixing the issue, Hy! Glad my log file was able to help.

Very excited to try the fix! What is the easiest way to install/update the fix on a Mac?

-Bret
2 months 3 weeks ago #87908

Please Log in or Create an account to join the conversation.

  • Posts: 930
  • Thank you received: 432
I'm not familiar with Mac releases, however a web search shows indilib.org/get-indi/download-mac.html
The fix would be in the nightly release (or you can wait a month or so for the next stable release).
My change went in on Nov 6, so if you want to test, click on "Nightly" and look for a completed nightly build started on or after Nov 7.
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
2 months 3 weeks ago #87916

Please Log in or Create an account to join the conversation.

Nightly MacOS is here:

binary-factory.kde.org/job/KStars_Nightly_macos/

However, there is an issue with the build now, but I'll talk to KDE folks who are responsible for this and hopefully it's fixed.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 months 3 weeks ago #87929

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0
Thanks Jasem, Hy! I’ll keep an eye out for when the MacOS build is fixed and give it a try!

-Bret
2 months 3 weeks ago #87937

Please Log in or Create an account to join the conversation.

Time to create page: 0.698 seconds