×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Find function crashes Kstars

  • Posts: 42
  • Thank you received: 1
Hey Folks,
I have found that since I updated my Kstars to the most recent stable release yesterday. When I launch the find tool or crash’s Kstars.

Has anyone else experienced this ?

Thanks.
Lenny

Linux box on Ubuntu 22.04


Sent from my iPhone using Tapatalk
2 months 2 weeks ago #88065

Please Log in or Create an account to join the conversation.

  • Posts: 379
  • Thank you received: 57
It crashes for me too, either 3.6.1 stable or the latest 3.6.2 beta Build: 2022-11-12T19:43:35Z. on Ubuntu 22.04.1 LTS

I'll see if I can produce a debug output.
120 MM Skywatcher Esprit + Celestron CGX, ZWO ASI 224MC guiding, Pegasus FocusCube+PPBA
Nikon Z7 8256 x 5504 4.34 um. Triad Ultra Quad NB Filter
1) MeLE Quieter3C 8G Ubuntu-mate 22.04.1 2) Odroid-N2. 3) StellarMate RPI4 8G
The good, the bad, the ugly at sciencedowneast.no-ip.ca/zenphoto/
2 months 2 weeks ago #88069

Please Log in or Create an account to join the conversation.

  • Posts: 284
  • Thank you received: 54
It happened to me with earlier releases of KStars but has not happened yet on the 3.6.2 beta I'm running now. From what I remember, "find tool" KStars crashes did not always happen but was a kind of hit-and-miss thing, it could crash Kstars if I used the find button but not the ctrl-f keyboard shortcut and vice-versa. It was then crashing more often than not though. IIRC I think someone looked at the problem a few months ago but I don't remember about the details.
2 months 2 weeks ago #88071

Please Log in or Create an account to join the conversation.

  • Posts: 379
  • Thank you received: 57
So I just did a
sudo apt-get -y install ekos-debugger
sudo apt-get -y install gdb
ekosdebugger

and chose the stable release and then my latest compile from source (as in my previous post) to launch in ekosdebugger. Both launched without a problem and the Find function worked.
After that, launching them without using the debugger also worked (i.e. the find Function worked).

Not sure what the installs tweaked, but something was kicked into working.

Cheers
Jerry
120 MM Skywatcher Esprit + Celestron CGX, ZWO ASI 224MC guiding, Pegasus FocusCube+PPBA
Nikon Z7 8256 x 5504 4.34 um. Triad Ultra Quad NB Filter
1) MeLE Quieter3C 8G Ubuntu-mate 22.04.1 2) Odroid-N2. 3) StellarMate RPI4 8G
The good, the bad, the ugly at sciencedowneast.no-ip.ca/zenphoto/
The following user(s) said Thank You: Gilles Gagnon
Last edit: 2 months 2 weeks ago by Jerry Black.
2 months 2 weeks ago #88076

Please Log in or Create an account to join the conversation.

Time to create page: 0.527 seconds