×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Weird GoTo Problem

  • Posts: 15
  • Thank you received: 0
Polar align using QHY PoleMaster

Plate solve with EKOS and scope shows correct location in KStars

Tell scope to go to another target and scope crosshairs in KStars look correct but after plate solving
the scope has actually moved more or less in the opposite position.

If I let EKOS iterate the scope crosshairs in KStars always seem to do the correct thing
but after plate solving the actual position keeps moving further and further away from intended target.

The mount is CGX-L with most recent firmware.
OTA is SkyWatcher Quattro 300p
Camera is QHY 5III-178m

When I look in the INDI control panel there are a few things that seem odd to me.

Under the Motion Control tab the green light is on next to Reverse. Can't seem to change this.
Don't know what it does. Neither the North/South West/East check boxes are checked.

Under Site Management tab is show longitude as 275:30:15.0. I thought longitude was 0 to 180 and 0 to -180.
Can't change this either. When I try I get a message that... "Updating location is not necessary since mount is already aligned."

With my other mount and same software everything works fine. My other mount is Celestron AVX.

One experiment I have not tried is plate solve with EKOS and then use hand controller to slew to a target.
I feel pretty confident that HC will work correctly.

The location and time are correct in the HC.

Computer running KStars / EKOS gets location and time from network.

This problem is super frustrating. Basically can't use scopes GoTo capability.
Have to manually find targets. After manually finding a target the tracking works as expected.

Thanks for the help. Hope we can resolve this soon.

Jim
1 week 6 days ago #88264

Please Log in or Create an account to join the conversation.

  • Posts: 376
  • Thank you received: 55

Replied by Jerry Black on topic Weird GoTo Problem

I think I can only help on one issue. The positions are reported to be east of the Greenwich Mean Time (GMT), UTC +0 meridian, so you can convert that value to deg W by 360 - 275 = 85
120 MM Skywatcher Esprit + Celestron CGX, ZWO ASI 224MC guiding, Pegasus FocusCube+PPBA
Nikon Z7 8256 x 5504 4.34 um. Triad Ultra Quad NB Filter
1) MeLE Quieter3C 8G Ubuntu-mate 22.04.1 2) Odroid-N2. 3) StellarMate RPI4 8G
The good, the bad, the ugly at sciencedowneast.no-ip.ca/zenphoto/
1 week 6 days ago #88269

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 0

Replied by James Wheeler on topic Weird GoTo Problem

So through a lot of experiments and trying things here is what I know.

Motion in RA axis is correct. Meaning where it shows the scope moved in KStars is where it actually is after plate solving.

Motion in DEC axis is opposite. Meaning where it shows the scope moved in KStars initially looks correct but after plate solving it has moved in the opposite direction.

I can manually move the scope onto a target keeping in mind that DEC axis is doing opposite of what KStars shows and then once on target scope tracks correctly.

I have tried doing a factory reset on the scope. Deleting the profile from KStars and building a new one. Messing with the check boxes that reverse North/South West/East.

Nothing seems to make any difference.

I am fairly confident that the bug is in KStars / Indi. My other mount (Celestron AVX) works fine with the same computer.

I haven't tried this but after using plate solving to let the scope know where it is pointing I am fairly confident that doing a GoTo with the hand controller will work correctly.

The scope used to work just fine so I don't think it could be something like wires got reversed. There have also not been any firmware updates since the last time the scope worked correctly.

Really need some help on this one.
1 week 3 days ago #88358

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 7

Replied by Jacqui Greenland on topic Weird GoTo Problem

This is super Interesting because exactly the same thing has been happening to me this week.

AZGti Mount using EQMOD all running on an RPi 4, Kstars 3.5.4 stable, Nikon DSLR, time and position provided by GPS dongle, literally zero changes to the software side of the setup since it was used at the end of September.

However first night out this week I had exactly the same problem as you occurring, tried to troubleshoot for hours but it was the middle of the night and I was still quite jetlagged. Tried clearing mount data, parking position, checking GPS data, timezone etc etc - all the same as you, but it didn't matter - I'd plate solve at the NCP then as I started to slew away and take new solves to get the goto accuracy it just went the opposite direction constantly.

2nd night, setup, same software, kit etc, same workflow, works first time, slewing the right direction and everything, bring the kit in due to wind and then go back out later, problem is back with literally no changes from earlier.

3rd night, same problem, used guide camera instead of main camera to sync mount, works perfectly ... At one point it also told me that it would cross the meridian during polar alignment which seemed odd.

So random question - what latitude are you at ? The only difference for us between the last time we used the rig, without any of these issues, and now is latitude. Normally we live at approx 51.5 and the last trip was to Nevada at 36 degrees, but this time we're in Hawaii at 19 degrees and I'm wondering if being that close to the equator starts to cause issues as really it's the only variable in the whole rig that has changes beyond the miniscule tolerance differences in alignment and mounting points!

Sorry I couldn't be more help to correct it, I haven't found a good solution but flipping between which camera I use to sync positions seems to help.
Last edit: 1 week 5 hours ago by Jacqui Greenland. Reason: fixed typos
1 week 11 hours ago #88494

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 0

Replied by James Wheeler on topic Weird GoTo Problem

I am at 38 degrees.

My problem went away. Sadly I don't know why. I deleted the profile and recreated it and then it started working. I had tried that before and it did not help. One thing I did differently this time was to NOT include SkySafari in the profile. I can't see how that would make a difference but when I get a chance I am going to delete the profile again and make a new one that includes SkySafari and see if the problem comes back. For reference SkySafari is an external planetarium program that has scope control. When you include it in your EKOS profile EKOS exposes a server that SkySafari uses to control the scope. One other thing I discovered, but I don't think it has any bearing, is that on the CGX-L if your slew speed is 5 or less then the DEC axis runs in reverse. This is by design according to Celestron. When I found that in the manual for the CGX-L I thought for sure I had solved it because the default setting for slew speed is 5. I changed it to 9 thinking that would fix it but it had no effect on the problem.

One thing you might try is making a brand new profile and don't include anything other than the mount and the imaging camera.
1 week 6 hours ago #88497

Please Log in or Create an account to join the conversation.

Time to create page: 0.643 seconds