×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

[SOLVED] indi_asi_ccd crashed for ASI ZWO 183MM Pro

1 year 11 months ago 1 year 10 months ago by sywong2000.
sywong2000
Senior Boarder
Senior Boarder
Posts: 53
More
Topic Author
[SOLVED] indi_asi_ccd crashed for ASI ZWO 183MM Pro #22248
*** Turns out the problem was on the usb buffer settings missing in the rules file.
After I edited the asi rules file and restart, the problem is gone.

EKOS was able to connect to the ASI ZWO 183MM Pro.
But crashed on Preview or Capturing... anybody help? Here's the log, see below in RED



org.kde.kstars.indi: INDI: Starting local drivers...
org.kde.kstars.indi: Starting INDI Server: ("-v", "-p", "7624", "-m", "100", "-f", "/tmp/indififo332d64f8") -f "/tmp/indififo332d64f8"
org.kde.kstars.indi: INDI Server Started? true
org.kde.kstars.indi: INDI: INDI Server started locally on port 7624
org.kde.kstars.indi: Starting INDI Driver "indi_asi_ccd"
org.kde.kstars.indi: Adding managed driver "ZWO CCD"
org.kde.kstars.indi: INDIListener: Adding a new client manager to INDI listener..
org.kde.kstars.indi: INDI: Connecting to local INDI server on port 7624 ...
org.kde.kstars.indi: INDI server connected.
org.kde.kstars.indi: Connection to INDI server is successful
org.kde.kstars.indi: INDI Server: "2018-01-07T13:09:51: startup: /usr/bin/indiserver -v -p 7624 -m 100 -f /tmp/indififo332d64f8 "
org.kde.kstars.indi: INDI Server: "2018-01-07T13:09:51: listening to port 7624 on fd 3"
org.kde.kstars.indi: INDI Server: "FIFO: start indi_asi_ccd"
org.kde.kstars.indi: INDI Server: "FIFO: Starting driver indi_asi_ccd"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:09:51: Driver indi_asi_ccd: pid=4146 rfd=4 wfd=7 efd=8"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:09:51: Client 5: new arrival from 127.0.0.1:47212 - welcome!"
org.kde.kstars.indi: INDI Server: ""
org.kde.kstars.indi: Received new device ZWO CCD ASI183MM Pro
org.kde.kstars.indi: INDI Server: "2018-01-07T13:09:51: Driver indi_asi_ccd: snooping on Telescope Simulator.EQUATORIAL_EOD_COORD"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:09:51: Driver indi_asi_ccd: snooping on Telescope Simulator.TELESCOPE_INFO"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:09:51: Driver indi_asi_ccd: snooping on Telescope Simulator.GEOGRAPHIC_COORD"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:09:51: Driver indi_asi_ccd: snooping on Focuser Simulator.ABS_ROTATOR_ANGLE"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:09:51: Driver indi_asi_ccd: snooping on CCD Simulator.FILTER_SLOT"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:09:51: Driver indi_asi_ccd: snooping on CCD Simulator.FILTER_NAME"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:09:51: Driver indi_asi_ccd: snooping on SQM.SKY_QUALITY"
org.kde.kstars.indi: INDI Server: ""
org.kde.kstars.indi: INDIListener: New device ZWO CCD ASI183MM Pro
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CONNECTION >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < DRIVER_INFO >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < DEBUG >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < SIMULATION >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CONFIG_PROCESS >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < ACTIVE_DEVICES >
org.kde.kstars.ekos: 1 devices connected out of 1
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_EXPOSURE >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_ABORT_EXPOSURE >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_FRAME >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_BINNING >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < FITS_HEADER >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_TEMPERATURE >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_INFO >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_COMPRESSION >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD1 >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_FRAME_TYPE >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_FRAME_RESET >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_RAPID_GUIDE >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < TELESCOPE_TYPE >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < WCS_CONTROL >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < UPLOAD_MODE >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < UPLOAD_SETTINGS >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_VIDEO_STREAM >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < STREAM_OPTIONS >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < FPS >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < RECORD_STREAM >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < RECORD_FILE >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < RECORD_OPTIONS >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_STREAM_FRAME >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_STREAM_ENCODER >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_STREAM_RECORDER >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_COOLER_POWER >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_COOLER >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_CONTROLS >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_CONTROLS_MODE >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < CCD_VIDEO_FORMAT >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < DEBUG_LEVEL >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < LOGGING_LEVEL >
org.kde.kstars.indi: < ZWO CCD ASI183MM Pro >: < LOG_OUTPUT >
org.kde.kstars.indi: ZWO CCD ASI183MM Pro : "[DEBUG] Toggle Debug Level -- Driver Debug "
org.kde.kstars.indi: ZWO CCD ASI183MM Pro : "[DEBUG] Toggle Logging Level -- Driver Debug "
org.kde.kstars.ekos.capture: Preparing capture job "Light" for execution.
org.kde.kstars.indi: ZWO CCD ASI183MM Pro : "[DEBUG] StartExposure->setexp : 1.000s "
org.kde.kstars.indi: ZWO CCD ASI183MM Pro : "[DEBUG] ASIGetExpStatus failed (0). Restarting exposure... "
org.kde.kstars.indi: ZWO CCD ASI183MM Pro : "[DEBUG] StartExposure->setexp : 1.000s "
org.kde.kstars.indi: ZWO CCD ASI183MM Pro : "[DEBUG] ASIGetExpStatus failed (0). Restarting exposure... "
org.kde.kstars.indi: ZWO CCD ASI183MM Pro : "[DEBUG] StartExposure->setexp : 1.000s "
*** stack smashing detected ***: terminated
org.kde.kstars.indi: INDI Server: "2018-01-07T13:10:16: Driver indi_asi_ccd: stderr EOF"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:10:16: Driver indi_asi_ccd: restart #1"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:10:16: Driver indi_asi_ccd: pid=4165 rfd=4 wfd=8 efd=9"
org.kde.kstars.indi: INDI Server: "Child process 4146 died"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:10:16: Driver indi_asi_ccd: snooping on Telescope Simulator.EQUATORIAL_EOD_COORD"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:10:16: Driver indi_asi_ccd: snooping on Telescope Simulator.TELESCOPE_INFO"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:10:16: Driver indi_asi_ccd: snooping on Telescope Simulator.GEOGRAPHIC_COORD"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:10:16: Driver indi_asi_ccd: snooping on Focuser Simulator.ABS_ROTATOR_ANGLE"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:10:16: Driver indi_asi_ccd: snooping on CCD Simulator.FILTER_SLOT"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:10:16: Driver indi_asi_ccd: snooping on CCD Simulator.FILTER_NAME"
org.kde.kstars.indi: INDI Server: "2018-01-07T13:10:16: Driver indi_asi_ccd: snooping on SQM.SKY_QUALITY"
org.kde.kstars.indi: INDI Server: ""
org.kde.kstars.indi: INDI driver "indi_asi_ccd" crashed!

Please Log in or Create an account to join the conversation.

1 year 11 months ago
wulfblat
Fresh Boarder
Fresh Boarder
Posts: 9
More
[SOLVED] indi_asi_ccd crashed for ASI ZWO 183MM Pro #22254
What were the control settings for the camera, especially the format?

Which OS are you using (and is it 32 bit or 64)?

I have been working on the asi module in a local repo and have found and corrected a handful of issues, but I do not recall seeing anything in the exposure code that would cause a crash.

If you are using 64 bit Linux I could make a debug version of the asi module available so we can pinpoint exactly where in the code the crash occurs.

Please Log in or Create an account to join the conversation.

1 year 11 months ago
sywong2000
Senior Boarder
Senior Boarder
Posts: 53
More
Topic Author
[SOLVED] indi_asi_ccd crashed for ASI ZWO 183MM Pro #22258
I'm capturing RAW with max resolution. The OS is a ubuntu 16.04 in RPi 3. I think it's 64bit and I'll have to recheck later tonight to make sure. I did switched on the Debug in the EKOS but all it captures was just a few lines.

If you can get me a debug version of 64Bit I can certainly put this and run the test and send you back the Debug info. Thank you.

Please Log in or Create an account to join the conversation.

1 year 11 months ago
sywong2000
Senior Boarder
Senior Boarder
Posts: 53
More
Topic Author
[SOLVED] indi_asi_ccd crashed for ASI ZWO 183MM Pro #22260
unfortunately it's a 32-bit. if there's anything I can do to get the debug info please let me know

uname -m
armv7l

Please Log in or Create an account to join the conversation.

4 months 3 days ago
ajh499
Junior Boarder
Junior Boarder
Posts: 26
More
[SOLVED] indi_asi_ccd crashed for ASI ZWO 183MM Pro #41889
Sorry for posting to an old thread, but I'm having the same problem with an ASI 183MM Pro running on a NanoPi M4.
After capturing a few images I get the same error as in this post and I can't capture any more until I unplug the camera.

The asi udev rules file has the USB buffer size set to 256. My asi120mm works fine, but the 183 always stops after fewer than 5 images.

This is with kstars 3.3.3 from the ppa.

Please Log in or Create an account to join the conversation.

Time to create page: 0.772 seconds