Slow RPI3 Offline Platesolving

  • Posts: 39
  • Thank you received: 2

Slow RPI3 Offline Platesolving was created by sywong2000

Hi
I was trying to use the offline platesolving (astrometry 0.67) with my Raspberry Pi 3 on ubuntu 16.04. I've found the offline platesolver is very very slow and run into timeout. I used a FITS file captured with my Atik 490EX (with Tak 85ED with 0.67 reducer) and I've set the FOV as 2.37' x 1.89', and load the image with "Load & Slew" to test.

If I use the online platesolver that's no problem. I saw from other posts saying a RPI3 usually takes 30-60 secs to solve, if it's offline. But you can see from the log it takes a lot of time on certain steps. With downsample it's even worse. Is it normal?

2018-10-31T22:52:40 Solver aborted after 360 seconds
2018-10-31T22:49:05 Field 1 did not solve (index index-4209.fits, field objects 1-10).
2018-10-31T22:49:04 Field 1 did not solve (index index-4210.fits, field objects 1-10).
2018-10-31T22:49:04 Field 1 did not solve (index index-4211.fits, field objects 1-10).
2018-10-31T22:48:09 Reading file "/home/ubuntu/Light_005.axy"...
2018-10-31T22:48:09 Solving...
2018-10-31T22:48:04 Reading sort column "FLUX"
Sorting sort column
mmapping input file
Copying table header.
Writing row 0
Done
2018-10-31T22:48:00 simplexy: found 2131 sources.
2018-10-31T22:46:48 Extracting sources...
2018-10-31T22:46:41 Reading input file 1 of 1: "/home/ubuntu/Light_005.fits"...
2018-10-31T22:46:41 /usr/bin/solve-field -O --no-plots --no-verify --resort --no-fits2fits --config /etc/astrometry.cfg -W /tmp/solution.wcs /home/ubuntu/Light_005.fits
2018-10-31T22:46:41 Starting solver...
2018-10-31T22:46:41 Solver iteration #1
Last edit: 3 months 2 weeks ago by sywong2000.
3 months 2 weeks ago #31056
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 553
  • Karma: 6
  • Thank you received: 154

Replied by wvreeven on topic Slow RPI3 Offline Platesolving

Hi,

Are you sure the FOV is set correctly? Shouldn't it be 2.37 DEGREES by 1.89 DEGREES rather than ARC MINUTES? Also try to downsample 4 or 8 times so you get less sources. This will speed up plate solving.

HTH, Wouter
Modded Canon EOS 700D with a WO ZS 71 ED on a SW HEQ5-Pro /
ASI1600MM-C CCD and filter wheel with an 8" RC on a SW EQ6-R
The following user(s) said Thank You: sywong2000
3 months 2 weeks ago #31058

Please Log in or Create an account to join the conversation.

  • Posts: 434
  • Karma: 1
  • Thank you received: 69

Replied by Ihoujin on topic Slow RPI3 Offline Platesolving

Try increasing the exposure time. I have found going a bit longer can really help. I also have a swap partition and ZRAM on my Pi. It seems to improve performance when there is high memory use, also probably saves me from some crash scenarios.
Higher binning can help when there are a lot of stars in the image. otherwise stick to 2x.
INDI/KStars on Raspberry Pi 3B+
Lubuntu 16.04
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG @280mm Guide Scope
PHD2
Adafruit Motor Hat shield
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
The following user(s) said Thank You: sywong2000
3 months 2 weeks ago #31070

Please Log in or Create an account to join the conversation.

  • Posts: 148
  • Thank you received: 7

Replied by phomer60 on topic Slow RPI3 Offline Platesolving

Anon,
I am going to suggest a few things to assist, I would first ensure you use a fast SD card.
First of all I would bin 2x2 or more and reduce the exposure time ( I use 1 second). The binning produces a significantly smaller file to work on.
Secondly, I would use the Luminance rather than Red filter as this will be much brighter.
Thirdly, have you tried selecting the darks option as this should remove any hot pixels that could be slowing things down.
Fourthly, check the focal length is set correctly. After a successful solve the software will return the actual focal length, which should then be used.
and finally, and the most important for me is that you need to have the telescope pointing close to where INDI thinks it is so the search is starting in the right region, otherwise it takes an excessive time and times out.
Paul
The following user(s) said Thank You: sywong2000, TallFurryMan
Last edit: 3 months 2 weeks ago by phomer60. Reason: spelling and new suggestion
3 months 2 weeks ago #31071

Please Log in or Create an account to join the conversation.

  • Posts: 39
  • Thank you received: 2

Replied by sywong2000 on topic Slow RPI3 Offline Platesolving

OK. I've located the problem:

1. I did messed up the FOV - Thanks wvreeven
2. EKOS is not passing parameters to solve-field command (at least at "Load & Slew"). I did point the telescope simulator close to the targets, specifies the FOV. And then I've found from the log that the -3, -4, -5 params are not passed to the commandline - this caused the solver to do a blind solve. In the options text I did find the params are correct. Somehow it's not being sent to the solve-field command. See screen cap. If I run the same command myself at the shell, by adding the -3, -4, -5, the solver is able to get the result in 90 seconds.

Ubuntu 16.04 on RPI 3
Kstar version 2.9.6
KDE framework 5.18.0

P.S. I checked the "Capture & Solve" and seemed the params are being passed okay.

What I was trying to do is to use some past images to try the offline platesolve function. When I was on the field doing capturing, I've spent a lot of time finding out where the telescope points to. The offline platesolve should have helped me to saves a lot of time to find out where the scope was pointing to, and help me to slew to the target. So I use the "Load & Slew" to test the platesolve. But as long as the "capture & solve" works fine (I'll have to find out later) - it should be okay.
Last edit: 3 months 2 weeks ago by sywong2000.
3 months 2 weeks ago #31094
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.523 seconds