×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Kstars crashes

1 year 5 months ago
okhoydal
Junior Boarder
Junior Boarder
Posts: 24
More
Topic Author
Kstars crashes #32526
Kstars (and Ekos) crashes at least 2 times every observation evening.
There is nothing in the logs directory.
I run Kstars Version 2.9.8 Build 2018-08-17T17:48:27Z under Windows 10.
Indi runs on Stellarmate version 1.3.1 and is connected via my home wifi network.
The following eguipment is connected to Stellarmate:
- Skywatcher Az-Eq6 via EQDir cable
- ZWO ASI1600MM-Pro Camera
- ZWO EFW 8 pos filterwheel
- ZWO ASI120MM Guide-camera
- Microtouch focuser

Sometimes things works for hours, other times it crashes only after 1 or 2 images captured. It mostly occurs when I am away from the PC, so it is not easy to point out any likely reason.

Regards, Odd

Please Log in or Create an account to join the conversation.

1 year 5 months ago
knro
Administrator
Administrator
Posts: 7995
Karma: 51
Kstars crashes #32527
Sorry about it. But as you can imagine, it's very hard to pin point crashes unless there is a way to reproduce them. Have you tried the latest nightlies? binary-factory.kde.org/job/KStars_Nightly_win32/

I think we're also set for KStars 3.0.0 in about a week as we iron out any remaining bugs, so stay tuned!

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 5 months ago
okhoydal
Junior Boarder
Junior Boarder
Posts: 24
More
Topic Author
Kstars crashes #32529
OK, I will try that version tonight.

Regards, Odd

Please Log in or Create an account to join the conversation.

1 year 5 months ago
okhoydal
Junior Boarder
Junior Boarder
Posts: 24
More
Topic Author
Kstars crashes #32530
Well, it crashed again.
Is there no way to make Kstars generate debug logs?

Regards,
Odd

Please Log in or Create an account to join the conversation.

1 year 5 months ago
knro
Administrator
Administrator
Posts: 7995
Karma: 51
Kstars crashes #32531
Check my signature on how to enable logs. Is there a specific way you can make it crash that I can try here? Can you write down the steps to reproduce the crash?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 5 months ago
suvowner
Senior Boarder
Senior Boarder
Posts: 57
More
Kstars crashes #32532
I have had crash issues on mac side as well with the zwo cameras, especially during focusing, when there are a lot of image downloads happening

you may try reducing the usb bandwidth on the zwo cameras to 50 or less

and you should probably be plugging your equipment into a powered usb hub and then that hub to the stellar mate
The following user(s) said Thank You knro, tkottary

Please Log in or Create an account to join the conversation.

1 year 5 months ago
okhoydal
Junior Boarder
Junior Boarder
Posts: 24
More
Topic Author
Kstars crashes #32534
I am using a bandwidth of 40 for my ZWO cameras.
I'm not using a hub. That might be something to consider.
So far I have not been able to see any pattern in when crashes occurs. I have now switched on some logging. Hope that can shed some light on the issue.

/Odd

Please Log in or Create an account to join the conversation.

1 year 5 months ago
okhoydal
Junior Boarder
Junior Boarder
Posts: 24
More
Topic Author
Kstars crashes #32535
Here is a log. The last thing that happened was that the exposure completed and the file was download.

The steps I carried out were:
Starting Kstars
Enable logs for Ekos, since I didn't know what to look for I only chose a few. (Capture, Guide and Mount I think).
Align: Goto and plate solve
Start Guiding
Autofocus
Define capturing sequence
Start Capturing
Leave PC at its task with a minimum number of applications running, not touching anything

Then, after a while I had a crash.

/Odd
Attachments:
The following user(s) said Thank You knro

Please Log in or Create an account to join the conversation.

1 year 5 months ago
knro
Administrator
Administrator
Posts: 7995
Karma: 51
Kstars crashes #32536
THanks, looks like it's crashing while loading the FITS. Will try to reproduce this and try to find out the issue ASAP.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 5 months ago
okhoydal
Junior Boarder
Junior Boarder
Posts: 24
More
Topic Author
Kstars crashes #32537
Another crash.
This time I had the following logging for Ekos: INDI, Capture, Scheduler, Guide, Mount.
Same workflow as for the previos session.
Everything worked fine for quite a long time of narrowband imaging.
Then I defined a sequence for LRGB imaging, and re-focused.
Started the new jobs in the CCD tab. Immidiately after downloading the first image, Kstars crashed.

/Odd
Attachments:

Please Log in or Create an account to join the conversation.

1 year 5 months ago 1 year 5 months ago by maxthebuilder.
maxthebuilder
Platinum Boarder
Platinum Boarder
Posts: 333
More
Kstars crashes #32538
Sorry for the intrusion... I have a very similar situation - was going to report but decided to do some more testing.
Anyway, my last two sessions I had these crashes. The session before it didn't crash (it was actually my first session with Windows KStars client and Stellarmate server).
(Simple setup - Nikon DSLR, AZ-GTI mount, Stellarmate, Windows 7 64 Kstars 2.9.8 August'18 buid)

-- start everything up
-- able to take pictures in Capture module
-- several Capture/Solve
-- try to take a picture in Capture module. The image gets taken, empty preview window appears - crash!
-- between successful and unsuccessful sessions I installed ansvr server.

Couldn't reproduce with simulators - needs a real camera, I guess.
Today it's going to be clear - will try.
BTW, Windows reports that problem module is ucrtbase.dll

When I use internal Stellarmate client - no crash.

Thanks!
Max

okhoydal wrote: Another crash.
This time I had the following logging for Ekos: INDI, Capture, Scheduler, Guide, Mount.
Same workflow as for the previos session.
Everything worked fine for quite a long time of narrowband imaging.
Then I defined a sequence for LRGB imaging, and re-focused.
Started the new jobs in the CCD tab. Immidiately after downloading the first image, Kstars crashed.

/Odd


Max S.
RPI 3 B+ with ABerry and RPI 4 B (4Gb) with SMate.
Nikon D5500 H-a modified. 180 mm f/2.8 antique Nikon. Tamron AF 28-75mm f/2.8. Rokinon 135mm f/2.
AT72EDII.
ZWO ASI294MC Pro
ZWO ASI120MC-S on ZWO 30F4 MiniScope.
SW AZ-GTi.
SW HEQ5.
iOptron SkyTracker Pro.

Please Log in or Create an account to join the conversation.

1 year 5 months ago
maxthebuilder
Platinum Boarder
Platinum Boarder
Posts: 333
More
Kstars crashes #32541
Figured mine out... User error or maybe a bug.
For some reason the Format option in Capture module changed from Native to FITS.
Weird thing is that even with FITS option selected the Capture module works in the beginning but after a few goto's causes a crash.

Oh.. tried to install a newer build of Kstars but wouldn't install saying that Kstars folder is occupied by some other processes, offers to terminate them but doesn't succeed. Reboot doesn't help.
Thanks!

maxthebuilder wrote: Sorry for the intrusion... I have a very similar situation - was going to report but decided to do some more testing.


[/quote]

Max S.
RPI 3 B+ with ABerry and RPI 4 B (4Gb) with SMate.
Nikon D5500 H-a modified. 180 mm f/2.8 antique Nikon. Tamron AF 28-75mm f/2.8. Rokinon 135mm f/2.
AT72EDII.
ZWO ASI294MC Pro
ZWO ASI120MC-S on ZWO 30F4 MiniScope.
SW AZ-GTi.
SW HEQ5.
iOptron SkyTracker Pro.

Please Log in or Create an account to join the conversation.

Time to create page: 0.375 seconds