×

INDI Library v1.8.0 is Released (27 Jul 2019)

INDI Library v1.8.0 is mostly a maintenance release to fix a few bugs in several drivers.

Make FitsView come to the foreground

  • Posts: 396
  • Karma: 2
  • Thank you received: 54

Make FitsView come to the foreground was created by Herrhausen

Hi, maybe this should be posted in the wish list but anyway... I noticed FitsView comes to the foreground when it displays its first image. After clicking at KStars which occupies the full screen, FitsView is pushed to the background and when it displays the next image it stays there. The user has to make it come to the foreground time and time again which can become tiring during a long night. I could make it stay in the foreground permanently but that's not what I want. Just when a new photo arrives it should come to the foreground automatically.
The following user(s) said Thank You: dokeeffe
7 months 2 weeks ago #33241

Please Log in or Create an account to join the conversation.

  • Posts: 360
  • Thank you received: 63

Replied by dokeeffe on topic Make FitsView come to the foreground

For my setup I would actually prefer if it did not come to the foreground. The reason being I let it run unattended while I sleep and have something that takes screenshots of the desktop at regular intervals.
Celestron CPC1100 Atik 383L
HP8300 Elite i5 running Xubuntu, Indi, Kstars & Ekos
Roll off roof observatory
Battling Irish weather
github.com/dokeeffe
twitter.com/BallyhouraStars
7 months 2 weeks ago #33242

Please Log in or Create an account to join the conversation.

  • Posts: 396
  • Karma: 2
  • Thank you received: 54

Replied by Herrhausen on topic Make FitsView come to the foreground

In that case one should be able to deactivate FitsView altogether. I was of the opinion that "Options -> Fits -> Use Fits Viewer" did exactly this but after disabling it, fotos were still displayed in FitsView. Is this a bug or what is the intended effect of this check box?
The following user(s) said Thank You: dokeeffe
7 months 2 weeks ago #33243

Please Log in or Create an account to join the conversation.

  • Posts: 360
  • Thank you received: 63

Replied by dokeeffe on topic Make FitsView come to the foreground

Oh, I didnt know about that option to disable, thanks. I'll try that, but like you say maybe there is a bug there if they still display.
Celestron CPC1100 Atik 383L
HP8300 Elite i5 running Xubuntu, Indi, Kstars & Ekos
Roll off roof observatory
Battling Irish weather
github.com/dokeeffe
twitter.com/BallyhouraStars
7 months 2 weeks ago #33244

Please Log in or Create an account to join the conversation.

  • Posts: 396
  • Karma: 2
  • Thank you received: 54

Replied by Herrhausen on topic Make FitsView come to the foreground

As a quick fix you could assign "always in background" to the FitsView window.
The following user(s) said Thank You: dokeeffe
7 months 2 weeks ago #33246

Please Log in or Create an account to join the conversation.

  • Posts: 422
  • Karma: 3
  • Thank you received: 62

Replied by pentaxian23 on topic Make FitsView come to the foreground

The image viewing behaviour has always been a bit weird to me. Its not consistently displayed - I think because native files dont get displayed in the status tab; and one would think the capture tab would have an image display area. If this were the case, there would be no need for popups except if someone wanted to inspect the image in full view, then it could be opened in fits viewer.
The following user(s) said Thank You: Herrhausen
7 months 1 week ago #33256

Please Log in or Create an account to join the conversation.

  • Posts: 396
  • Karma: 2
  • Thank you received: 54

Replied by Herrhausen on topic Make FitsView come to the foreground

pentaxian23 wrote: and one would think the capture tab would have an image display area. If this were the case, there would be no need for popups except if someone wanted to inspect the image in full view, then it could be opened in fits viewer.


My thought exactly. Guide, Align, and Focus tabs have a display area. CCD tab has not. It would be nice if it had one and it would provide a more consistent look and feel. A double click on the display area could launch FitsView showing the same picture.
The following user(s) said Thank You: pentaxian23
7 months 1 week ago #33260

Please Log in or Create an account to join the conversation.

  • Posts: 163
  • Thank you received: 9

Replied by phomer60 on topic Make FitsView come to the foreground

If this is going to get introduced it needs to be a parameter setting as I rarely want the latest image to come to the foreground.
In my case I am using Raspbian and all I need to do is select the Tab with the FITS viewer to bring it into the foreground.
Paul
7 months 1 week ago #33263

Please Log in or Create an account to join the conversation.

  • Posts: 396
  • Karma: 2
  • Thank you received: 54

Replied by Herrhausen on topic Make FitsView come to the foreground

phomer60 wrote: Im using Raspbian and all I need to do is select the Tab with the FITS viewer to bring it into the foreground.
Paul


Selecting the tab is acceptable at the beginning of the night, becomes tiring in the middle of the night and a nuisance towards the end of the night. This is my experience with clicking at the tab maybe 100x during the night after a new picture has arrived . An option to make FitsView behave like the user wants it to, would be nice in any event, wouldn't it?
7 months 1 week ago #33268

Please Log in or Create an account to join the conversation.

Replied by knro on topic Make FitsView come to the foreground

Ok, I introduced an option in the FITS options and made it enabled by default.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Herrhausen
Last edit: 7 months 1 week ago by knro.
7 months 1 week ago #33488

Please Log in or Create an account to join the conversation.

  • Posts: 396
  • Karma: 2
  • Thank you received: 54

Replied by Herrhausen on topic Make FitsView come to the foreground

Thank you so much, Jasem!
7 months 1 week ago #33507

Please Log in or Create an account to join the conversation.

  • Posts: 236
  • Karma: 8
  • Thank you received: 41

Replied by PK on topic Make FitsView come to the foreground

Another one that bugs me is that when I choose the Options button on the EKOS modules, they open BEHIND the module screen. I have to hide the module I was using to get to the options I wanted to adjust.

iOptron CEM25P
William Optics Star71
ASI 1600Mm Pro
Moonlight motorfocus
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
Last edit: 7 months 5 days ago by PK.
7 months 5 days ago #33592

Please Log in or Create an account to join the conversation.

Time to create page: 0.457 seconds