×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Capture module keeps asking for DSLR settings / ignores upload directory

1 year 6 months ago
tcrass
Fresh Boarder
Fresh Boarder
Posts: 9
More
Topic Author
Capture module keeps asking for DSLR settings / ignores upload directory #36110
Hi there,

just trying to set up an INDI-controlled EQMod mount with a Nikon D5000 DSLR. Mount control used to work fine (until today -- but that's a different story: bugs.kde.org/show_bug.cgi?id=405188 ), but I do have some issues with the capture module.

- Whenever I switch to the capture module, a dialog asking for DSLR camera settings pops up -- although the dialog text says "This is a one-time setup". I wonder whether this is a bug or a feature...? ;)

- The image directory path gets ignored (I'm using "Client" upload mode) -- whatever I enter, the images end up in /tmp.

Im running a Debian Stretch system and compiled both INDI and KStars from the latest git.

So... am I missing something or are these real bugs which I should report?

Cheers --

Torsten

Please Log in or Create an account to join the conversation.

1 year 6 months ago
knro
Administrator
Administrator
Posts: 8370
Karma: 51
Capture module keeps asking for DSLR settings / ignores upload directory #36119
1. Regarding the reported bug, I pushed a possible fix, so git pull and retest.
2. If it keeps asking you, there is problem with ~/.local/share/kstars/userdb.sqlite, you can delete it and it will recreate it next time in launches up. Check permission.
3. Cannot reproduce, everything is captured in the right place.

Make sure everything under ~/.local/share/kstars is owned by your user (not root) and same for ~/.config

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You tcrass

Please Log in or Create an account to join the conversation.

1 year 6 months ago
tcrass
Fresh Boarder
Fresh Boarder
Posts: 9
More
Topic Author
Capture module keeps asking for DSLR settings / ignores upload directory #36153
Jason,

knro wrote: 1. Regarding the reported bug, I pushed a possible fix, so git pull and retest.

thank you for that quick fix -- works fine again, doesn't crash anymore! :)

knro wrote: 2. If it keeps asking you, there is problem with ~/.local/share/kstars/userdb.sqlite, you can delete it and it will recreate it next time in launches up. Check permission.

That also was a valuable hint, the caputure module stopped bugging me about the settings!

knro wrote: 3. Cannot reproduce, everything is captured in the right place.

Oh, that turned out to be just me being stupid -- it's just the images created when hitting the "Preview" button which end up in /tmp; images taken though the sequence queue are stored where they should.

Thank you so much, and have a good night --

Torsten

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago
simondodd
Fresh Boarder
Fresh Boarder
Posts: 18
More
Capture module keeps asking for DSLR settings / ignores upload directory #46193
Sorry to jump on this thread but how are you using your Nikon D5000? I can't get kstars to operate the USB shutter release needed for it... Or aren't you using kstars?

Please Log in or Create an account to join the conversation.

Time to create page: 0.283 seconds