×

INDI Library v1.7.8 Released (11 May 2019)

Mid year release of INDI Library v1.7.8 comes with a few drivers and improvements to to existing drivers.

Ekos Scheduler 'eats' frames from the sequence?

  • Posts: 31
  • Thank you received: 4

Ekos Scheduler 'eats' frames from the sequence? was created by wjdrijfhout

Something strange happened last night when using the scheduler. I had three jobs on the list. First two went well. But from the third job, significantly less frames were taken than specified in the sequence-file. In the sequence file there was a series of 20/6/6/6/10 frames for various filters. However, the scheduler only took 10/3/3/3/10 frames. So most were halved, but not all. Looking at the time-stamps of the files, they were all taken in proper sequential order, no gaps, so I'm not missing files because they've been written wrongly. Seems like there is some logic/intelligence applied to the frame-reduction, but I can't see where or how and how to prevent this.
Usually when something goes wrong with the scheduler it's my own fault, having made a typo in the script or so, but I checked it hundred times, and the scripts all look fine. Any idea what could have gone wrong here and why th scheduler 'ate' some of my frames?
Using KStars 3.0.0 for Mac.
Thank you, Willem Jan.
2 months 1 week ago #37550

Please Log in or Create an account to join the conversation.

  • Posts: 197
  • Karma: 3
  • Thank you received: 51

Replied by sterne-jaeger on topic Ekos Scheduler 'eats' frames from the sequence?

Willem Jan,
please be so kind and post your scheduler job and your capture sequence file(s). And are you using the "remember job progress" option?

There is a known bug with calculation of captured frames we are currently working on.

Cheers
Wolfgang
2 months 1 week ago #37556

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 4

Replied by wjdrijfhout on topic Ekos Scheduler 'eats' frames from the sequence?

Thank you Wolfgang, for looking into this. I have attached the three capture sequence files I used (had to change extension to *.txt, or it would not upload). I'm afraid I did not save the scheduler job as a file (should probably start doing that...).
The three sequence files were executed in order, with selecting target M63, M44 and M63 respectively. In order to make sure they stay in order I typically assign a priority like 1, 10 and 15 or so to them.
Other settings of the scheduler were:
Tracking on, no focus, align or guide ticked. All Job constraint options unchecked. Selected shutdown procedures: warm CCD, Cap and Park Mount.
I just looked at the option 'remember job progress' and indeed that was selected. Can't remember I turned that on, so perhaps this was a default setting?
I've got logging on by default, but that only specifies some startup routines. Nothing in there about the actual imaging processes.

Once again, thank you very much already.

Best regards, Willem Jan.
2 months 1 week ago #37558
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 197
  • Karma: 3
  • Thank you received: 51

Replied by sterne-jaeger on topic Ekos Scheduler 'eats' frames from the sequence?

It seems like you stepped into the bug we are discussing here: phabricator.kde.org/D20029

As a workaround until it is fixed, please do not use the "repeat for x runs" feature of the scheduler.

Wolfgang
2 months 1 week ago #37560

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 4

Replied by wjdrijfhout on topic Ekos Scheduler 'eats' frames from the sequence?

Thank you Wolfgang.
However, I never use the 'repeat for x runs', I always have 'Sequence Completion' selected.
Should I deselect 'Remember Job Progress' in the Preferences?

Willem Jan.
2 months 1 week ago #37561

Please Log in or Create an account to join the conversation.

  • Posts: 197
  • Karma: 3
  • Thank you received: 51

Replied by sterne-jaeger on topic Ekos Scheduler 'eats' frames from the sequence?

Oops, then I think it's not the bug we are discussing. Have you checked wether the target directory of your third job already contained the targeted 6 frames? This is exactly where the option "Remember job progress" is for. If you have some frames from a previous session in the target directory, it takes them into account and stops as soon as enough frames are present.
In your example 3 (and I guess that's the one which "eats" frames), I would expect that the target directory now contains exactly 6 light frames - as specified in the capture sequence. If you use the option "Sequence Completion", the job terminates as soon as 6 light frames with the given prefix are present in the specified directory.
If you want to take 6 frames no matter how many frames have already been taken, please tick off "Remember job progress". In this case the scheduler ignores frames already taken in the past.
2 months 1 week ago #37563

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 4

Replied by wjdrijfhout on topic Ekos Scheduler 'eats' frames from the sequence?

You are absolutely right! There are indeed exactly 6 frames in the directory specified (three from the first sequence and three from the second sequence). This makes all sense now.
Glad nothing is wrong with the software, and just due to user error. I will uncheck the Remember Job Progress option going forward.
Thanks very much for your help solving this.

Willem Jan.
2 months 1 week ago #37566

Please Log in or Create an account to join the conversation.

Time to create page: 0.694 seconds