×

INDI Library v1.9.1 Released (26 Jun 2021)

Bi-monthly INDI Library v1.9.1 is released bringing a few new drivers and improvements to existing drivers.

Ekos on Mac OS X ?

  • Posts: 211
  • Thank you received: 23
4 years 7 months ago #13057
The topic has been locked.
  • Posts: 2499
  • Thank you received: 670

Replied by Rob Lancaster on topic Ekos on Mac OS X ?


This one worked much better on my wife's computer than the last one you sent. I worked just like mine did, I could start the Indi server, but capturing an image crashed the indiserver.
4 years 7 months ago #13058
The topic has been locked.
  • Posts: 211
  • Thank you received: 23

Replied by Jamie Smith on topic Ekos on Mac OS X ?

when you build it does it crash?
4 years 7 months ago #13066
The topic has been locked.
  • Posts: 2499
  • Thank you received: 670

Replied by Rob Lancaster on topic Ekos on Mac OS X ?

So yes, if I use your dmg or mine built on my new MacBook Pro running Sierra, trying to run it on My Wife's (non-development) MacBook Pro running El Capitan, KStars works fine, the INDIServer starts fine with the CCD sim. But then if I try to take a photo in the capture module, it crashes. If you are running a local INDIServer, just the INDIServer crashes, but if you are connected to a remote INDIServer, KStars crashes instead. Now I have done some additional experiments. I found that in fact, the logs do not seem to show any error in either case, but if you run KStars from the Console instead, where you can see the program output, it says "Illegal instruction: 4" when KStars crashes, which is a useful clue! Looking that up online, I found that it is an error associated with commands the processor doesn't understand, and is typically caused by software compiled for the wrong version of the operating system. I also have tried running the embedded indiserver from the console alone, and it doesn't seem to work. So perhaps we need to compile indiserver with flags for a lesser operating system the same way we did KStars?
4 years 7 months ago #13078
The topic has been locked.
  • Posts: 2499
  • Thank you received: 670

Replied by Rob Lancaster on topic Ekos on Mac OS X ?

Hey guys, how's it going? Are you ok now Jamie? I'm sorry I haven't been working on this much lately. Of course this is partially due to the fact that KStars works pretty much perfectly on my computer now. But another part of it is that I have been busy doing some other things. But I think it would be good to get back to this now, so that beginners and those who don't want to go through the whole install process can get KStars easily. We are very close to finishing. We made awesome progress and then stopped just before the finish line.

I might try running Jamie's script on my old computer today to see if compiling on the same version of the OS helps my wife's computer.

Did anybody try the Sierra compiled KStars dmg on a Mac running Sierra (NOT El Capitan) that was not used for development of KStars or the DMG?
www.dropbox.com/s/4hy57ysu76dk7eq/kstars.dmg?dl=0
The following user(s) said Thank You: Anthony Marriott
4 years 7 months ago #13188
The topic has been locked.
  • Posts: 5
  • Thank you received: 0

Replied by Anthony Marriott on topic Ekos on Mac OS X ?

I have been following this thread and have downloaded and installed Kstars on my MBA via this dmg file. I don't have my scope and mount fully functional yet so cannot test all the functionality, but can confirm that the program appears to install and work. Only issue I had was with "setup", which I clicked wrong box and lost, but that s a user/kstars issue.

I'll be watching for any updates and as soon as my scope is up and running will test the other features.

GEAT WORK!PRIV
4 years 7 months ago #13190
The topic has been locked.
  • Posts: 5
  • Thank you received: 0

Replied by Anthony Marriott on topic Ekos on Mac OS X ?

I can't keep up with you!! Just finished installing previous version! Updated and installed this latest version successfully and programming runs ok so far.

I am using a MacbookAir 2012 with 2G i7 and 8G memory running Sierra 10.12.3.Beta (16D12b)
4 years 7 months ago #13192
The topic has been locked.
  • Posts: 2499
  • Thank you received: 670

Replied by Rob Lancaster on topic Ekos on Mac OS X ?

I thought I would first look through the output of the terminal while building the dmg on my new Sierra MacBook first to see if there is any clue why it wouldn't work from the dmg on my wife's computer. I noticed a couple of things. They might be nothing, but I thought they were worth noting. Are these no big deal?

During all the otool checking, copying of dylib's and changing @rpath and @executable paths:
Skipping Copy: libindi.1.dylib already in Frameworks
Skipping libcfitsio.5.dylib, not executable
Skipping libraw.15.dylib, not executable

During dmg build:
ERROR: no file at "/opt/local/lib/mysql55/mysql/libmysqlclient.18.dylib"
ERROR: no file at "/usr/local/lib/libpq.5.dylib"
4 years 7 months ago #13195
The topic has been locked.
  • Posts: 211
  • Thank you received: 23

Replied by Jamie Smith on topic Ekos on Mac OS X ?


I think those are OK
4 years 7 months ago #13207
The topic has been locked.
  • Posts: 2499
  • Thank you received: 670

Replied by Rob Lancaster on topic Ekos on Mac OS X ?

I just got a new guide camera and it works great on Ekos/KStars on Mac OS X. I wanted to get a new camera because my Meade DSI guide camera did not have enough resolution, could not be binned, and the quality of the image seemed inferior. So my wife got me a nice upgrade for Christmas. It is a ZWO ASI 120MM-S. I was serving up the camera from the Cloudmakers INDIServer program and using it in KStars. It was very responsive, with extremely fast download time! I did have to copy the ASI xml file in order to get it to show up in KStars, however. Is ZWO not included in the 3rd Party drivers we are installing in Jamie's script? I will also need to test this camera being served from my Raspberry Pi and of course under the night sky, but for now, this demonstrates that it works! By the way, this image was taken with the included "all sky" lens.


4 years 6 months ago #13336
Attachments:
The topic has been locked.
  • Posts: 2058
  • Thank you received: 193

Replied by Gonzothegreat on topic Ekos on Mac OS X ?

Been away from the thread and forum for a few weeks, first how are you doing Jamie, how's the arm?
I used to be a biker (well, you don't really stop being a biker.. lol) and had my share of accidents but nothing ever got broken (just my bike and pride).

As for the DMG, are we any closer in finding out why it crashes on trying to take a picture?
I did compare Jamie's one and mine the other week and apart from the version of a dlyb, not much else is different.
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO183MM / QHY5L-II-M (OAG) / ZWO mini FW
4 years 6 months ago #13338
The topic has been locked.
  • Posts: 2499
  • Thank you received: 670

Replied by Rob Lancaster on topic Ekos on Mac OS X ?

I too haven't been doing too much KStars/INDI related recently. I said I was going to about a week ago, and then I didn't do much. We really need to figure out exactly what is wrong. The indiserver does appear to start on my wife's computer, but taking an image with the capture module crashes it. However, you can take an image in the guide or focus module as I recall, which is odd! My wife's computer is an El Capitan machine from 2009 with no Xcode, home-brew, or other development stuff installed. I was wondering if the fact that it is an older version of OS X has anything to do with it. I did compare the otool results from the indiserver binary Jamie's script makes to the indiserver binary cloud makers program includes. They are very similar. So that appears to rule out a dylib issue.

Unfortunately since my wife's laptop has no development software on it, it is more difficult to debug difficulties too!
4 years 6 months ago #13339
The topic has been locked.
Time to create page: 1.008 seconds