×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Ekos on Mac OS X ?

3 years 7 months ago
jamiesmithnc
Gold Boarder
Gold Boarder
Posts: 211
Karma: 1
More
Ekos on Mac OS X ? #14394

rlancaste wrote: Hi Jamie, could you also take a look at building the other 3rd party drivers? We are not building many of them and there are more available that we could build. We are already doing gphoto, eqmod, cloudwatcher, spectracyber, maxdomeII and sx. Three that I am particularly interested in are the ZWO/ASI, the SBIG, and the DSI. I started trying to modify the code to make them work, but I was having trouble. You will find my lines of code in the script commented out. Please take a look at your convenience. Thanks!


Sorry, been a while...

I had tried building them before - the only ones that I could get to build I included. There were a variety of failures building them.
The topic has been locked.
3 years 7 months ago
nmac
Gold Boarder
Gold Boarder
Posts: 426
Karma: 2
More
Ekos on Mac OS X ? #14395
Thanks for the info Jasem, I willl apply the last commit and then try again to see if it solves the issues.

(PT) SC@ROS Observatory
TS 6" F4 Newtonian / Canon 550D / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Explore Scientific 80APO - 120ST / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
The topic has been locked.
3 years 7 months ago
rlancaste
Supernova Explorer
Supernova Explorer
Posts: 2269
Karma: 22
More
Ekos on Mac OS X ? #14396

nmac wrote: Thanks for the info Jasem, I willl apply the last commit and then try again to see if it solves the issues.


And I will rebuild the dmg with those updates sometime this weekend. Right now I am in the middle of making an astrometry options editor and I really would like to finish it before building the new dmg. Soon I promise. . .
The topic has been locked.
3 years 7 months ago 3 years 7 months ago by nmac.
nmac
Gold Boarder
Gold Boarder
Posts: 426
Karma: 2
More
Ekos on Mac OS X ? #14397
I have just made another test. This time with the last commits on the server.
It seems all is working except for the Liveview, still the black screen with no data and no FPS.

Forget the black screen that's normal! I totally forgot I had removed the mirror because of the image shadows!!! :oops: :oops: :oops:
I lost the liveview with that procedure. So... It must be working because it's not crashing.

Preview crash is gone and Autofocus is working again with no crash too!!! I already have the fits files being saved.
Tested both linux (directly on the server via RDP) and macos with the DMG.
Thanks Jasem!

I attached the linux server gdb and log and also macos log.
Nevermind the messages about X11, it's because of RDP.

(PT) SC@ROS Observatory
TS 6" F4 Newtonian / Canon 550D / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Explore Scientific 80APO - 120ST / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
Attachments:
The topic has been locked.
3 years 7 months ago
rlancaste
Supernova Explorer
Supernova Explorer
Posts: 2269
Karma: 22
More
Ekos on Mac OS X ? #14400

nmac wrote: I have just made another test. This time with the last commits on the server.
It seems all is working except for the Liveview, still the black screen with no data and no FPS.

Preview crash is gone and Autofocus is working again with no crash too!!! I already have the fits files being saved.
Tested both linux (directly on the server via RDP) and macos with the DMG.
Thanks Jasem!

I attached the linux server gdb and log and also macos log.
Nevermind the messages about X11, it's because of RDP.


Just to make sure that I understand, the primary issue was an out of date version of the indiserver that both the Mac and linux computers were accessing? Is that correct?
The topic has been locked.
3 years 7 months ago 3 years 7 months ago by nmac.
nmac
Gold Boarder
Gold Boarder
Posts: 426
Karma: 2
More
Ekos on Mac OS X ? #14401
Basically yes, but the server was updated 2 times today. I always update before making tests.
The first time it gave those crashes. The second time was when Jasem told about the last commit.
So both server (linux) and client (macos) are now working ok!
No need to rebuild the DMG because of that.

(PT) SC@ROS Observatory
TS 6" F4 Newtonian / Canon 550D / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Explore Scientific 80APO - 120ST / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
The topic has been locked.
3 years 7 months ago
rlancaste
Supernova Explorer
Supernova Explorer
Posts: 2269
Karma: 22
More
Ekos on Mac OS X ? #14402
Wonderful, just making sure it wasn't the KStars DMG! Please continue to test!
The topic has been locked.
3 years 7 months ago 3 years 7 months ago by nmac.
nmac
Gold Boarder
Gold Boarder
Posts: 426
Karma: 2
More
Ekos on Mac OS X ? #14403
Will do :-)

In the next few days I will try the same as you,building kstars but... on a PPC Powerbook.
I have one too and I am trying to get TigerBrew and Fink/Macports to work with the latest KDE5 sources.
Let's see if it's possible. It's revealing a hard task but I would love to do that :-D

(PT) SC@ROS Observatory
TS 6" F4 Newtonian / Canon 550D / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Explore Scientific 80APO - 120ST / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
The topic has been locked.
3 years 7 months ago
nmac
Gold Boarder
Gold Boarder
Posts: 426
Karma: 2
More
Ekos on Mac OS X ? #14412

nmac wrote: I have just made another test. This time with the last commits on the server.
It seems all is working except for the Liveview, still the black screen with no data and no FPS.

Forget the black screen that's normal! I totally forgot I had removed the mirror because of the image shadows!!! :oops: :oops: :oops:
I lost the liveview with that procedure. So... It must be working because it's not crashing.

.


Just tested with daylight, both working with liveview : 550d (but no real image that's normal, no mirror) and ASI120MM.
Thanks Jasem.

(PT) SC@ROS Observatory
TS 6" F4 Newtonian / Canon 550D / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Explore Scientific 80APO - 120ST / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
The topic has been locked.
3 years 7 months ago
rlancaste
Supernova Explorer
Supernova Explorer
Posts: 2269
Karma: 22
More
Ekos on Mac OS X ? #14416

nmac wrote: Will do :-)

In the next few days I will try the same as you,building kstars but... on a PPC Powerbook.
I have one too and I am trying to get TigerBrew and Fink/Macports to work with the latest KDE5 sources.
Let's see if it's possible. It's revealing a hard task but I would love to do that :-D


That sounds good in principle, but as you might already know a large part of our work in this forum has been first trying to get KStars up and running on a mac in a usable format and then trying to get all the other programs it depends upon and uses to a place that kstars will be able to find them. And then we worked to get it all wrapped up and portable in a single app and dmg. It required us to rewrite a significant amount of kstars code and to carefully write a build script to take care of all of that work to get it ready so that all users would need to do is install by dragging and dropping the app. That is not to say that using another build method would not work, just that there are currently a lot of steps to get it working.

Home-brew right now is your best bet of course because kf5 is currently working with it, but yes it would be an excellent goal to get that up and running on finks and macports. In our script, we include two methods for building kstars, one that relies on homebrew and another one that relies heavily on a tool called craft. The craft method is particularly friendly becase it automates the process quite a bit more and installs many of the latest versions of the dependencies in the right order, but we still need home-brew for some things as well, and some file and folder copying are still required.

All of that being said, here is an idea. Could you try ruunning our build script on the powerbook? I would be curious to see if that works. Regardless, if you want to get it working on homebrew, macports, or fink without our build script, you will probably want to reference our script to see what steps we took to get it working. If you dont have the link, it is: github.com/jamiesmith/kstars-on-osx

Thanks and let me know about any progress or problems. Good luck!

Thanks,

Rob
The topic has been locked.
3 years 7 months ago
rlancaste
Supernova Explorer
Supernova Explorer
Posts: 2269
Karma: 22
More
Ekos on Mac OS X ? #14417

nmac wrote:

nmac wrote: I have just made another test. This time with the last commits on the server.
It seems all is working except for the Liveview, still the black screen with no data and no FPS.

Forget the black screen that's normal! I totally forgot I had removed the mirror because of the image shadows!!! :oops: :oops: :oops:
I lost the liveview with that procedure. So... It must be working because it's not crashing.

.


Just tested with daylight, both working with liveview : 550d (but no real image that's normal, no mirror) and ASI120MM.
Thanks Jasem.



Oh, haha! I will have to test with my DSLR then! Its exciting if its working! Dont feel bad, we have all done something like that! ;)
The topic has been locked.
3 years 7 months ago
nmac
Gold Boarder
Gold Boarder
Posts: 426
Karma: 2
More
Ekos on Mac OS X ? #14418
I am trying to follow Jamie script and get all the dependencies installed first and that's the more dificult part. Some of those are not available on the servers and I have to install them by hand. The majority is compiled from source but it's a time consuming routine. When they are ready I will give the script a go to see if it works.This is more a proof of concept but I would be good to have a build on the PPC platform. I know thare are still a lot of people who owns PPC's, If it compiles, I will have to see if that option is viable in terms of performance too. I have dual boot to Ubuntu 16.04 PPC, I already built it from sources and it works fine on my model (1.6Ghz/2GB Ram). So I belive it will also work fine on PPC OSX too.

Thanks!
Nuno

(PT) SC@ROS Observatory
TS 6" F4 Newtonian / Canon 550D / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Explore Scientific 80APO - 120ST / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
The topic has been locked.
Time to create page: 0.571 seconds