×

INDI Library v1.9.4 Released (17 Jan 2022)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

ASTAP astrometry integration

  • Posts: 125
  • Thank you received: 24

Replied by Tarun on topic ASTAP astrometry integration

Go to the mount tab (tripod icon) on ekos and make sure your focal length is correctly set up there. Try saving the config , move back to align tab switch between the camera's and confirm the FOV is correct in Ekos before you hit solve.
Last edit: 2 years 1 month ago by Tarun.
2 years 1 month ago #46487

Please Log in or Create an account to join the conversation.

  • Posts: 324
  • Thank you received: 84

Replied by han on topic ASTAP astrometry integration

If the suggestion of tkottary doesn't work, then you should install the latest nightly build INDI. What I understand is that there was a bug in the pixel scale reporting (keywords CDELT1, 2). Unfortunately there is no way to add an additional command line command in EKOS to override the FOV
2 years 1 month ago #46494

Please Log in or Create an account to join the conversation.

  • Posts: 324
  • Thank you received: 84

Replied by han on topic ASTAP astrometry integration

There is a simple way to override the FOV setting (my previous remark was incorrect) . You can just enter it in the command line as show below. Just add something like :

-fov 1.6

This will override and other FOV (focal length, sensor size) setting. So once you found out the image height in degrees just add this value in the command line. Note that -fov auto doesn't work. This only works in the viewer. If the solver is more then 2 degrees from the start position the popup notifier will show the FOV used.

Han

2 years 1 month ago #46509
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 6
Thanks Han, I'll try as soon as possible and report back.
If this works though, wouldn't it be possible to automate it when the image loaded doesn't have any info into its header?
2 years 1 month ago #46510

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 6
It doesn't work for me. It seems like any options specified in the field are not actually passed to the solver, which still shows 1 degree in its little window.
Mind, I'm using the "Load & Slew" button, unlike your screencap which shows you're using "Capture & Solve". I don't think Ekos/Kstars is doing the same things when using the two buttons.
2 years 1 month ago #46513

Please Log in or Create an account to join the conversation.

  • Posts: 324
  • Thank you received: 84

Replied by han on topic ASTAP astrometry integration

Something strange is happening. The -fov command works only for the Ekos "Capture & solve " button, not for the Ekos "Load & slew" button. That's why I initially reported it doesn't work. This requires further investigation.

The command line option "-fov auto" works for Windows but not for Linux. I have to investigate why that doesn't happen. Note that this option is not ideal. I created it to because I was fed up with finding the image scale for some images without any data. ASTAP goes through all image scales from 9.5 degrees height down to 0.5 degrees with a stepsize of 33% less height each time. Due to the step size this works only for images of reasonable good quality. The option was intended to analyse images from an unknown source, not as a permanent setting.

Han
The following user(s) said Thank You: Craig
Last edit: 2 years 1 month ago by han.
2 years 1 month ago #46514

Please Log in or Create an account to join the conversation.

  • Posts: 324
  • Thank you received: 84

Replied by han on topic ASTAP astrometry integration

The "-fov auto" work also in Linux. I didn't see that because in my test virtual machine it was using an old ASTAP version. Note that "-fov auto" disappears as soon you go to an other screen. Then you have to type it again. In the popup window you will see the word "auto". If you see height is 0°, the ASTAP version is too old. It doesn't work for "load and slew" only "capture & solve". It's highly inefficient since it has to search maybe ten times before it finds a match. It helps if you reduce the search area to maybe 10 degrees

The fixed 1 degrees is related to an INDI problem. Maybe Jasem/ @knro can clarify from which INDI version this is fixed.

Han

2 years 1 month ago #46517
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 120
  • Thank you received: 11

Replied by Craig on topic ASTAP astrometry integration

How do you get to that settings page in ASTAP.

I’m still having intermittent solving issues with ASTAP
Skywatcher EQ6R / EdgeHD 8" / ZWO 1600MC / 2600MC / ZWO 290mm / 120MM-S / StellarMate
2 years 1 month ago #46619

Please Log in or Create an account to join the conversation.

  • Posts: 324
  • Thank you received: 84

Replied by han on topic ASTAP astrometry integration


Settings:
Start the ASTAP program. It should be in the menu education or execute /opt/astap/astap Click on the stack menu button Σ (ctrl+A), go to tab alignment. See screenshot below . All settings in the blue rectangle are relevant. There is not much you can change. The "field height image" is forced by the FITS header so changing does not help when using the command line. The only thing you could try is to check mark "slow". And if your final image height is close to 1000 pixel you could set "Tetrahedron tolerance" to 0.007." To save these setting go to the viewer, select File, Settings, Save setting. Or exit viewer via File, Exit (and save settings)

If your having a noisy camera with lot of hot pixels you could experiment with option "Calibrate prior solving" This will apply a dark prior to solving . But up to now this option is very rarely required if ever.

Best way to fix solving problems
Almost all solving problems are due to the wrong field height or a too low image resolution. ASTAP solving is very robust if the correct image and data is provided. You better check the image which was used for solving. Ekos writes the "image to solve" at location /tmp Filename will be something like fitsgd5919.fits. Open this image in the viewer and note the image dimensions in pixels and degrees in the status bar of the viewer. The image height should be 1000 pixels or more. If close to 1000 pixels reduce the binning in Ekos to increase the image height in pixels. Then solve this image using the viewer solve button (or the button in the alignment tab) and see if the image dimensions in degrees change significantly after a successful solve. If so the FOV or sensor size is set wrongly in INDI or INDI has still the Cdelt1,2 bug.

- A solve log is written in the bottom of the stack menu. This could indicate why the solver is having problems to solve.
- You can also have a look in the text file /tmp/solution.ini after solving. This will contain warnings and errors. The same you see in the bottom of the stack menu.
- An other indication is try the button "Test button to show tetrahedrons" or use the CCD inspector from the tools menu viewer. If 30 stars or more are detected solving should be easy.

Finally you can also send me the "image to solve" from /tmp and I will have a look.

Han

The following user(s) said Thank You: Craig
Last edit: 2 years 1 month ago by han.
2 years 1 month ago #46631
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 120
  • Thank you received: 11

Replied by Craig on topic ASTAP astrometry integration

Here is a link to a FITS file that wouldn't solve. Its on Canopus. It wouldn't solve from the app either. I'm not running the latest version of ASTAP though and will be upgrading it today.

drive.google.com/open?id=1AreQOU8wKMZLilxqzGYtWG00TRVeQT1F
Skywatcher EQ6R / EdgeHD 8" / ZWO 1600MC / 2600MC / ZWO 290mm / 120MM-S / StellarMate
2 years 1 month ago #46666

Please Log in or Create an account to join the conversation.

  • Posts: 120
  • Thank you received: 11

Replied by Craig on topic ASTAP astrometry integration

Here is the logs from the session as well. Hopefully this upload works.

File Attachment:

File Name: log_10-45-27.txt.zip
File Size:268 KB
Skywatcher EQ6R / EdgeHD 8" / ZWO 1600MC / 2600MC / ZWO 290mm / 120MM-S / StellarMate
2 years 1 month ago #46667
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 120
  • Thank you received: 11

Replied by Craig on topic ASTAP astrometry integration

I just upgraded to v 0.9.305a and its still not solving that image.

Here is a screen shot of that settings page when the solving fail's
Skywatcher EQ6R / EdgeHD 8" / ZWO 1600MC / 2600MC / ZWO 290mm / 120MM-S / StellarMate
2 years 1 month ago #46668
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 13.858 seconds