×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Night Build not installing?

6 months 4 weeks ago
PK
Gold Boarder
Gold Boarder
Posts: 292
Karma: 9
More
Topic Author
Night Build not installing? #47996
Trying to switch over to the n=Nightly Builds. I followed the instructions on the INDI site, and got an error. Ant advice would be appreciated.
(Ubuntu 16.04)

(these two links worked perfectly)
sudo apt-add-repository ppa:mutlaqja/indinightly
sudo apt-get update

But this one did not:.

pi@FriendlyELEC:~$ sudo apt-get install indi-full kstars-bleeding gsc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
indi-full : Depends: indi-aagcloudwatcher-ng but it is not installable
E: Unable to correct problems, you have held broken packages.


iOptron CEM25P
William Optics Star71
ASI 1600Mm Pro
Moonlight motorfocus
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4

Please Log in or Create an account to join the conversation.

6 months 4 weeks ago
knro
Administrator
Administrator
Posts: 8213
Karma: 51
Night Build not installing? #48002
It wasn't built for 16.04. I just added that target to it and re-triggered a build.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

6 months 4 weeks ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1576
Karma: 8
More
Night Build not installing? #48009
Speaking of which, what are your plans concerning supporting older versions of Ubuntu? Will you phase out support for 16.04 as soon as 20.04 has been released or do you plan to keep it up for some time more?

ASI6200 and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

6 months 4 weeks ago
PK
Gold Boarder
Gold Boarder
Posts: 292
Karma: 9
More
Topic Author
Night Build not installing? #48028
Thanks Jasem. I tried again tonight and got the same error: The following packages have unmet dependencies:
indi-full : Depends: indi-aagcloudwatcher-ng but it is not installable
E: Unable to correct problems, you have held broken packages.


iOptron CEM25P
William Optics Star71
ASI 1600Mm Pro
Moonlight motorfocus
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago
Schwarze
Senior Boarder
Senior Boarder
Posts: 43
More
Night Build not installing? #48157
I see that indi-aagcloudwatcher-ng problem as well. There is source code for it in the indi-3rdparty repository in github, it seems like a reference to it already made it into the dependencies of the Indi-full package but a indi-aagcloudwatcher-ng is not yet available...

iOptron CEM25P
Skywatcher Evostar 72 ED DSPro
Explore Scientific ED 102
ASI 1600Mm Pro ASI EFW Mini
QHY 8L
DeepSky Dad AF1 motor focus
ASI 120MM Mini and Bresser (Touptek) 290 Guidecams
Sykwatch EvoGuide 50/242 and NoName 50/175 Guidescopes
Raspberry Pi 3 and 4

Please Log in or Create an account to join the conversation.

6 months 1 week ago 6 months 1 week ago by starman345.
starman345
Expert Boarder
Expert Boarder
Posts: 103
More
Night Build not installing? #48788
I'm seeing the same cloudwatchers error as reported in the OP. I'm trying to install Kstars - Indie on a 20.02 version. Has anyone been able to get this to work?

brian@brian-B450M-DS3H:~$ sudo apt-get install indi-full kstars-bleeding gsc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
indi-full : Depends: indi-aagcloudwatcher-ng but it is not installable
E: Unable to correct problems, you have held broken packages.

-Brian

Kstars-Ekos-INDIE
NanoPC-T4 - Armbian Ubuntu 18.04
iOptron CEM25P mount
Photoline 80mm triplet
ZWO ASI294MC Pro Imaging camera
ZWO ASI290MM mini Guide camera


Please Log in or Create an account to join the conversation.

6 months 1 week ago
knro
Administrator
Administrator
Posts: 8213
Karma: 51
Night Build not installing? #48790
I fixed the recipe for this package and rebuilding now

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

6 months 1 week ago
starman345
Expert Boarder
Expert Boarder
Posts: 103
More
Night Build not installing? #48791
Thanks Jasem, working fine now

-Brian

Kstars-Ekos-INDIE
NanoPC-T4 - Armbian Ubuntu 18.04
iOptron CEM25P mount
Photoline 80mm triplet
ZWO ASI294MC Pro Imaging camera
ZWO ASI290MM mini Guide camera


Please Log in or Create an account to join the conversation.

Time to create page: 0.196 seconds