×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Pentak K30 anyone have any luck getting it working?

3 months 1 week ago
karlrees
Junior Boarder
Junior Boarder
Posts: 39
Karma: 1
More
Pentak K30 anyone have any luck getting it working? #55221
Lenny,

It should install now with the nightlies on Ubuntu Mate 32 bit. If by chance you were on a 64 bit, there was a problem with the 64 bit build, so maybe tomorrow for that.

FYI, as I was afraid of, the driver isn't working with PTP mode the way it was compiled, so stick with MSC mode for now. The main advantage of PTP mode so far appears to be live view, anyway. I'll have to see again if I can figure out what's different in the way it gets compiled on Raspbian versus Ubuntu Mate.

Let me know how it goes.

Karl

Please Log in or Create an account to join the conversation.

3 months 1 week ago
lennyk
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Pentak K30 anyone have any luck getting it working? #55245
Thanks Karl, I will give it a go later on tonight and let you know how it went.

Please Log in or Create an account to join the conversation.

3 months 1 week ago
lennyk
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Pentak K30 anyone have any luck getting it working? #55344
Hey Karl,
I tested the driver but unfortunately it kept crashing, it looks like its missing a file
"Driver indi_pentax: indi_pentax: error while loading shared libraries: libRicohCameraSDKCpp.so: cannot open shared object file: No such file or directory"

I have attached the complete log.
Thanks,
Lenny.

File Attachment:

File Name: Pentax-test.txt
File Size:6 KB
Attachments:

Please Log in or Create an account to join the conversation.

3 months 1 week ago
karlrees
Junior Boarder
Junior Boarder
Posts: 39
Karma: 1
More
Pentak K30 anyone have any luck getting it working? #55357
There is a missing dependency. All you should have to do to get it going is install the libricohcamerasdk library:
sudo apt install libricohcamerasdk

I've updated the package, but I'm not sure how long it will take for the fix to get into the nightlies.

Please Log in or Create an account to join the conversation.

3 months 1 week ago
lennyk
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Pentak K30 anyone have any luck getting it working? #55360
Thanks Karl,
I was able to get the camera to connect successfully once i installed the SDK, however i was not able to take any pictures successfully. I tried 1 second and 31 second images in bulb mode each time the shutter opened and closed immediately, and finished exposure prior to the end of the 31 second limit. When i tried in manual mode the shutter would fire but then would not close and failed to download. I tried a 3rd attempt in Bulb mode at 60 seconds and noticed that the countdown timer did not go above 30. Its like it does not recognize that the camera is in bulb mode.

File Attachment:

File Name: Pentaxtest1.txt
File Size:50 KB

I have attached the log file from the test. For the heck of it i tried to connect in PTP mode but it didnt find any device.

Thanks,
Lenny.
Attachments:

Please Log in or Create an account to join the conversation.

3 months 1 week ago
karlrees
Junior Boarder
Junior Boarder
Posts: 39
Karma: 1
More
Pentak K30 anyone have any luck getting it working? #55364
Thanks for testing it out, Lenny. It looks to me like it never recognized you were in bulb mode. And then the camera looks like it got into a weird state. I think we had a similar problem on K3II. I wish I had something besides the K-70 to test with.

I'm not sure how much additional testing you're up for, but if you have some time, it'd help to know:

1) Can you check to see if it downloaded any images to your device? The log seemed to indicate it did, but of course that doesn't necessarily mean anything.
2) If you start the driver in M mode, and never switch to another mode, what are the results?
3) If you haven't already, could you by chance download pktriggermode by itself and let me know how that works with your camera? The driver is just wrapping the code for pktriggermode, so if you've used pktriggermode before and it worked, then we're having a driver problem. Otherwise, there's a fundamental problem with pktriggermode, and there may not be much I can do.

If you can respond to those questions, I can spend some time this weekend updating the driver a bit so it can spit out more helpful debug information.

Thanks,
Karl

Please Log in or Create an account to join the conversation.

3 months 1 week ago
karlrees
Junior Boarder
Junior Boarder
Posts: 39
Karma: 1
More
Pentak K30 anyone have any luck getting it working? #55366
I should mention that when the camera gets into a weird state, sometimes you have to pull all power (i.e. take out the battery) before it will behave normal again--turning it off is not enough. So for #2, what I'm looking to find out is what happens if you start totally clean with both the driver and the camera in M mode.

Please Log in or Create an account to join the conversation.

3 months 1 week ago 3 months 1 week ago by lennyk.
lennyk
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Pentak K30 anyone have any luck getting it working? #55369
Hi Karl ,
I will test that out later on, I should note I had tried Pktriggercord back in the day but always had trouble with Bulb mode, but let me complete the tests again and see what happens.

I should have also said yes it did download images on some of the tests

Thanks,
Lenny.

Please Log in or Create an account to join the conversation.

3 months 1 week ago
lennyk
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Pentak K30 anyone have any luck getting it working? #55382
Karl,
see updates below :
1) Can you check to see if it downloaded any images to your device? The log seemed to indicate it did, but of course that doesn't necessarily mean anything. - On some of the tests yes it downloaded an image

2) If you start the driver in M mode, and never switch to another mode, what are the results? Inital test at 1.5 seconds shutter opened and closed for 1.5 seconds but it got stuck in waiting to download image. I aborted that attempt and tried 2 seconds, shutter fired what sounded like twice and then opened for 2 seconds and closed, but the downloaded image seems to be from the first shutter snap as the image was perfectly exposed and not over exposed at 2sec and 800iso. Repeated 2 second shot, again shutter sounds like it fired twice. Tried 31 second exposure and counter started at 31 but finished downloading after 2 seconds even do shutter was still open must have read from buffer. tried it at 30 seconds max exposure for manual mode, again it completed after approx 2 seconds and read from buffer, once 30 seconds elapsed shutter closed.

3) If you haven't already, could you by chance download pktriggermode by itself and let me know how that works with your camera? The driver is just wrapping the code for pktriggermode, so if you've used pktriggermode before and it worked, then we're having a driver problem. Otherwise, there's a fundamental problem with pktriggermode, and there may not be much I can do. I cant seem to download pktriggercord for ubuntu says package is not available, i had tried it in windows a year or 2 ago with no success, but if needed i could try it again in windows

log file attached from test

File Attachment:

File Name: Pentaxtest2.txt
File Size:38 KB


Thanks,
Lenny
Attachments:

Please Log in or Create an account to join the conversation.

3 months 1 week ago
karlrees
Junior Boarder
Junior Boarder
Posts: 39
Karma: 1
More
Pentak K30 anyone have any luck getting it working? #55389
Okay, seems like it's not getting that initial image from the buffer correctly (it thinks its a 0 size image), and from that point on the buffer is lagging behind one exposure. That gives me a few ideas to test at least.

It might be helpful to at least see what you can do with pktriggercord on Windows. That will give us a baseline of what we should be shooting for with the K30 here.

Please Log in or Create an account to join the conversation.

3 months 1 week ago
lennyk
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Pentak K30 anyone have any luck getting it working? #55441
So i tried pktriggercord on windows, it dosent recognise the camera model in the json file. So its not able to change mode or set bulb settings. So when camera is in Manual mode It works fine i can take pictures of various lengths up to 30 seconds with out issue. If i knew how to get it to recognize camera model then maybe i could test changing the settings. If i start it up in Bulb mode it gives an error as sen in attached image
Attachments:

Please Log in or Create an account to join the conversation.

3 months 1 week ago
karlrees
Junior Boarder
Junior Boarder
Posts: 39
Karma: 1
More
Pentak K30 anyone have any luck getting it working? #55443
Thanks. That's strange that it's not recognized in bulb mode, as the K-30 is listed as supported (as opposed to partially supported) on the pktriggercord website. I'll work on trying to get M mode to work for now, and then see what I can find out from pktriggercord about the bulb mode problem.

Please Log in or Create an account to join the conversation.

Time to create page: 0.659 seconds