×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Ekos stuck in 'focussing'

  • Posts: 38
  • Thank you received: 1
Hi all

I'm using the 'Autofocus if HFR >' feature in Ekos, or better I used to use in the past, as it's not working for me anymore. I'm positive this worked about 3 month ago, when I had the last CS.
After the capture, it captures an image in the focus module, determines that the focus is still OK, but fails to resume capturing. The capture module is stuck in 'focussing'.
Kstars v3.5.1, Mint Linux 19.3

I did capture a log, the -to me relevant section- is below. Remark, I manually triggered the autofocus at 19:42:56.746, as this is the only way to get out of this state, apart from stopping the capture.
if you need a full log, let me know.
[2021-02-21T19:42:16.078 CET INFO ][   org.kde.kstars.ekos.capture] - "Download Time: 1.43 s, New Download Time Estimate: 1.42 s."
[2021-02-21T19:42:16.283 CET INFO ][   org.kde.kstars.ekos.capture] - "Received image 2 out of 7."
[2021-02-21T19:42:16.290 CET DEBG ][   org.kde.kstars.ekos.capture] - setFocusStatus:  5
[2021-02-21T19:42:16.290 CET DEBG ][     org.kde.kstars.ekos.focus] - Check Focus requested with minimum required HFR 2.311
[2021-02-21T19:42:16.290 CET INFO ][     org.kde.kstars.ekos.focus] - "Capturing to check HFR..."
[2021-02-21T19:42:16.291 CET DEBG ][   org.kde.kstars.ekos.capture] - setFocusStatus:  5
[2021-02-21T19:42:16.291 CET INFO ][     org.kde.kstars.ekos.focus] - "Capturing image..."
[2021-02-21T19:42:16.292 CET DEBG ][   org.kde.kstars.ekos.capture] - In-sequence focusing started...
[2021-02-21T19:42:19.439 CET INFO ][     org.kde.kstars.ekos.focus] - "Image received."
[2021-02-21T19:42:19.442 CET INFO ][     org.kde.kstars.ekos.focus] - "Detecting sources..."
[2021-02-21T19:42:19.476 CET INFO ][     org.kde.kstars.ekos.focus] - "Detection complete."
[2021-02-21T19:42:19.477 CET DEBG ][     org.kde.kstars.ekos.focus] - Focus newFITS # 1 : Current HFR  1.45964  Num stars  1
[2021-02-21T19:42:19.477 CET DEBG ][     org.kde.kstars.ekos.focus] - Current HFR: 1.45964 is below required minimum HFR: 2.311 . Autofocus successful.
[2021-02-21T19:42:19.477 CET INFO ][     org.kde.kstars.ekos.focus] - "Focus procedure completed after 14 iterations."
[2021-02-21T19:42:19.478 CET DEBG ][     org.kde.kstars.ekos.focus] - Stopping Focus
[2021-02-21T19:42:19.482 CET DEBG ][     org.kde.kstars.ekos.focus] - Settled. State: "Idle"
[2021-02-21T19:42:19.482 CET DEBG ][   org.kde.kstars.ekos.capture] - setFocusStatus:  0
[2021-02-21T19:42:56.746 CET DEBG ][     org.kde.kstars.ekos.focus] - Starting focus with box size:  80  Subframe:  yes  Autostar:  yes  Full frame:  no   [ 0 %, 100 %]  Step Size:  500  Threshold:  150  Gaussian Sigma:  1.5  Gaussian Kernel size:  5  Multi row average:  3  Tolerance:  7.5  Frames:  1  Maximum Travel:  10000
[2021-02-21T19:42:56.747 CET INFO ][     org.kde.kstars.ekos.focus] - "Autofocus in progress..."
1 year 11 months ago #67626

Please Log in or Create an account to join the conversation.

  • Posts: 319
  • Thank you received: 24

Replied by Mohamed on topic Ekos stuck in 'focussing'

I suggest upgrading to the latest Kstars 3.5.2 and indi as well. I use this feature and it works for me.
Clear Skies!
Mohamed

Permanent
C9.25 f/10, HEQ5, MyFocuserPro2, OAG, ASI174MC guide, ASI533MC Pro

Portable
WO Z61, iOptron SmartEQ Pro+, MyFocuserPro2, OAG, ASI120MM guide, ASI183MM Pro, EFW
1 year 10 months ago #69256

Please Log in or Create an account to join the conversation.

Time to create page: 0.522 seconds