×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

instability in the newest version?

  • Posts: 2
  • Thank you received: 0
Greetings;

tldr;  I think I see a new instability in the most recent Ekos version, possibly tied to the dynamic image stacking feature; Plausible? Known? Next steps?

I've been using KStars/Ekos/indilib via astroberry on an RPi 4 for the past year or so, to good effect.  While it's been a steep learning curve, I've always been able to identify *my* problem thanks to the documentation or this forum or occasionally blind luck stumbling onto the right setting to change and learning a new term at the same time, at least until now.

Within the past couple of weeks, I was motivated to upgrade to a newer version (to support the Canon Ra, but I think that's a side issue).  I started with the newest stable image (2.0.3), and applied the recommended upgrade commands: "sudo apt update && sudo apt upgrade && sudo apt dist-upgrade". Once I did that, I started seeing a crash in Ekos, or occasionally all of KStars after taking 10 images or so in the photograph sequence tab.  There didn't seem to be any such trouble with e.g. the plate solving tab.  Not seeing any missing patches and also not having support for the Canon Ra in that most recent astroberry version, I picked up stellarmate;  Good news! The Canon Ra is supported!  Bad news!   It's crashing in the same way after 10 images or so (the number isn't entirely consistent, but it's small).

Given that I'm seeing the same behavior in both the astroberry distro and stellarmate OS, I'm inclined to point my finger at one of the recently introduced features.  In each session, as I'm watching the images in the preview pane being stacked, I can see some artifacts in the image (almost like frost on a lens -- made me check my lenses each time -- no frost) that become more pronounced until the crash.  Purely circumstantial evidence.

I have not collected logs yet -- I'll do that on my next session (Friday night, if the weather holds), now that I know how.

As to versions; I've done the update as of today, so the versions are the current stable ones for astroberry, and the stellarmate OS install is equally current, no updates available as of this post.

Thanks in advance.

 
Raspberry Pi 4 running astroberry or stellarmate depending
Sirius EQ-G
Orion 8" Newtonian Astrograph
Canon 80D or Ra
Orion 60mm guide scope + Starshoot
GPSD + external puck
Baldur battery

-- OR --
iOptron skyguider pro
Redcat 51
either the 80D or the Ra
intervalometer
Sirui tripod
1 year 8 months ago #69480

Please Log in or Create an account to join the conversation.

This issue is fixed in 3.5.3 beta, please update to it.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 8 months ago #69488

Please Log in or Create an account to join the conversation.

  • Posts: 58
  • Thank you received: 2
Uh, does this also affect the MacOs version?
 I’ve planned a session for tonight and don’t want to run in trouble...
--
macOS Ventura - 10micron GM1000HPS - ZWO ASI Camera - Baader Steeldrive II
Celestron 11" EdgeHD, TS-Optics Doublet SD-Apo 80 mm, Lunt 80THA/B1800FTPT

www.astrobin.com/users/Poison/?sub=uploaded
1 year 8 months ago #69489

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 0
The 3.5.3 beta addressed that problem.  I had a good imaging session last night.  Thanks!
 
Raspberry Pi 4 running astroberry or stellarmate depending
Sirius EQ-G
Orion 8" Newtonian Astrograph
Canon 80D or Ra
Orion 60mm guide scope + Starshoot
GPSD + external puck
Baldur battery

-- OR --
iOptron skyguider pro
Redcat 51
either the 80D or the Ra
intervalometer
Sirui tripod
1 year 8 months ago #69641

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 1
Hi
How do you upgrade an astroberry to 3.5.3 beta ?
Thanks
Mount : Avalon Fast Linear
FSQ 106 + Lakerside focuser
CCD : QHY290 MM Cool Guider : QHY5L-II
DSRL : Sony A7S Baader Mooded
1 year 8 months ago #69663

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 2
I have been experiencing kstars crashes in the middle of a session that was working fine, this is the first time that happens to me. I tried to switch to the beta version but this one cannot find the INDI Eqmod driver. 
1 year 8 months ago #69668

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 5
 
Good morning i see the posts and i have same problem, shutdown random of Kstars and impossibile to work. Have you resolved?
Regards.
Ettore
P.s Beta 3.5.3 have error of compilation.
 
Good morning i see the posts and i have same problem, shutdown random of Kstars and impossibile to work. Have you resolved?
Regards.
Ettore
P.s Beta 3.5.3 have error of compilation.

  
 
Good morning i see the posts and i have same problem, shutdown random of Kstars and impossibile to work. Have you resolved?
Regards.
Ettore
P.s Beta 3.5.3 have error of compilation.
 
Good morning i see the posts and i have same problem, shutdown random of Kstars and impossibile to work. Have you resolved?
Regards.
Ettore
P.s Beta 3.5.3 have error of compilation.

  
  
 
INDI/KStars on Raspberry Pi 4, 4gb
Raspberry Bull 64bit
Skywatcher 150PDS
CGE-PRO Mount
Nikon D5300 Camera
ZWO183MM
ZWO ASI120mm
Whaveshave focuser
Last edit: 1 year 8 months ago by Ettore.
1 year 8 months ago #69854
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 279
  • Thank you received: 54
If by any chance you tried building KStars using "make -j4" or larger 'j' option, try running "make -j2" or "make" by itself. Smaller machines (Raspberry Pi, ODroid...) can't handle a high number of parallel 'make' jobs and exit with error after some time. I had it happen on me some time ago when I first tried to build KStars.

Mind you, I did not try buiding 3.5.3 but I built 3.5.2 yesterday. Was slow (few hours) but completed.
1 year 8 months ago #69863

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 5
Thank i try.
Ettore
INDI/KStars on Raspberry Pi 4, 4gb
Raspberry Bull 64bit
Skywatcher 150PDS
CGE-PRO Mount
Nikon D5300 Camera
ZWO183MM
ZWO ASI120mm
Whaveshave focuser
1 year 7 months ago #69867

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 5
I compiled with make -J and all ok but i have random crash, is impossibile to work: the Beta 3.5.3 is ok?
Ettore
INDI/KStars on Raspberry Pi 4, 4gb
Raspberry Bull 64bit
Skywatcher 150PDS
CGE-PRO Mount
Nikon D5300 Camera
ZWO183MM
ZWO ASI120mm
Whaveshave focuser
1 year 7 months ago #70187

Please Log in or Create an account to join the conversation.

Time to create page: 0.681 seconds