×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

KStars 3.5.3 Mac Beta --- Please test

  • Posts: 11
  • Thank you received: 0
Terrain works fine with my setup also. I'm missing an action to toggle terrain on/off, but I can live without it.


I have found that the problematic indi driver that also fails in 3.5.2 is libqhyccd.21.dylib; it is the one that has set minos to 10.15 and I'm on 10.13. I recall that this already happened in a past version with the previous version of the QHY indi driver... 

Thanks for your help, and regards.
 
1 year 3 months ago #70546
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 834
  • Thank you received: 405
You can toggle terrain in the view menu, and there's a keyboard shortcut too, I believe control-shift-t.
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
The following user(s) said Thank You: Jordi Sesé
1 year 3 months ago #70549

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
Ups... yes, you are absolutely right... my eyes did not see it when I looked for it, my fault.

Thanks a lot for your help.

Jordi.
1 year 3 months ago #70552

Please Log in or Create an account to join the conversation.

  • Posts: 2738
  • Thank you received: 766
 Jordi Sesé,

I think I remember that issue from before yes.  I don't build the dylib for QHY, that is done upstream.  All I get is the binary file.  So we need to ask Jasem or QHY to build that with the correct settings so it works on 10.13. Then we can rebuild with it.

Rob
The following user(s) said Thank You: Jordi Sesé
1 year 3 months ago #70568

Please Log in or Create an account to join the conversation.

  • Posts: 527
  • Thank you received: 138
I was able to connect all equipment and build a new dark library with the new feature. It all seemed to work well. Have not tried making a horizon, but others have shown it works good.
-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
1 year 3 months ago #70622

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
Hi Again,

I guess there is something wrong at least with the lx200generic INDI driver, the one used to implement LX200_OnStep among others. Version 3.5.2 works fine, but in this beta it does not load properly. I don't know whether it's OSX version related (again, I'm on OSX 10.13).
The fact is that I have executed indiserver (-vvv, FIFO method) in a terminal (and then define remote indi in ekos), and when I start the indi driver, It just shows a few lines, nothing to do with the previous version. It is always the same:

FIFO: start ./indi_lx200_OnStep -v
FIFO: Starting driver ./indi_lx200_OnStep
2021-04-26T22:25:09: Driver ./indi_lx200_OnStep: pid=41080 rfd=4 wfd=7 efd=8
2021-04-26T22:25:09: Driver ./indi_lx200_OnStep: sending msg copy 1 nq 1:
[getProperties version='1.7'/]

That's all it shows. Most other drivers, and the same in 3.5.2 (run in its own folder, of course) output a lot more info, and get immediately recognized.
As I told you, the driver is not recognized (I guess it does not load properly). 


Thanks a lot for your time, and regards,

Jordi.
Last edit: 1 year 3 months ago by Jordi Sesé. Reason: problems to show code...
1 year 3 months ago #70661

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 8
The Dark Library feature looks good and I was able to make one for my ASI290MM mini but the resulting Masters appear not to have a sensible temperature even though the capture windows shows a good 20C reading? 



The FITS file seems to have correct temperature in it.

 
Borg 107FL on RST-135 + QHY268C, Astro-Tech AT130EDT on GM1000HPS + QHY600PH Chroma LRGBHSO; IR Guiding WO Uniguide 50 & QHY5-III-462C ASUS PN51 and Mele Quieter 3 ubuntu, kstars/ekos, & firecapture; Pegasus PPBA; WO Redcat, Skyguider Pro RT90C, Canon 7DmkII, rPi4/stellarmate
Last edit: 1 year 3 months ago by Thomas Mason.
1 year 3 months ago #70673
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 2738
  • Thank you received: 766
Jordi,

While the previous issue you mentioned does appear to be a Mac specific issue that can be easily solved before the release, since it was just that the one driver had been built with the wrong Minos setting, this problem you mention with the lx200 generic driver is different.  I tried it a couple of different ways on my Mac and got the same results that you did.  So then out of curiosity I updated a Linux system that I have and the same thing happened on that computer too.  This is not a Mac specific issue.  It is either a bug, or something we are doing wrong.

Thanks,

Rob
1 year 3 months ago #70674

Please Log in or Create an account to join the conversation.

  • Posts: 2738
  • Thank you received: 766
Thomas Mason,

I don't believe that this issue with the darks is specifically related to the Mac Build?  Currently I'm focused on trying to make sure that everything is good in the Mac build for the release.  You might get a quicker response to this issue by starting a new topic in the forum?

Thanks,

Rob
1 year 3 months ago #70675

Please Log in or Create an account to join the conversation.

That's not a bug in the darks. Temperature is ignored on cameras where you cannot set the temperature. So passive temperatures are ignored. Maybe in the future, it would try to find the temperature closest to current to apply a dark, but for now, if you don't have an active cooler, temperature is not used.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 3 months ago #70698

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 8
How does it decide which dark to use?  Does the T.Threshold have any impact?
Borg 107FL on RST-135 + QHY268C, Astro-Tech AT130EDT on GM1000HPS + QHY600PH Chroma LRGBHSO; IR Guiding WO Uniguide 50 & QHY5-III-462C ASUS PN51 and Mele Quieter 3 ubuntu, kstars/ekos, & firecapture; Pegasus PPBA; WO Redcat, Skyguider Pro RT90C, Canon 7DmkII, rPi4/stellarmate
1 year 3 months ago #70700

Please Log in or Create an account to join the conversation.

Right now, whichever master fits the requirements is used. I think in the next release, I'll make use of the passive temperature, and then select the closest dark to the current camera temperature.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Craig
1 year 3 months ago #70701

Please Log in or Create an account to join the conversation.

Time to create page: 1.564 seconds