×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Kstars 3.5.3 ZWO and SX Camera driver crashes

  • Posts: 312
  • Thank you received: 13
I have two Rpi4's (call them older Rpi4-8 and newer Rpi4-1), both running Ubuntu 64 bit OS.  On the older one (Rpi4-8) I have Kstars 3.5.1 Stable and my ZWO ASI and SX (Lodestar) cameras work fine.  On the newer Rpi4-1 I just installed Kstars 3.5.3 stable (the latest from doing an update and upgrade) and both camera drivers crash in the Indi Control Panel.  I also have PHD2 on the both Rpi4's and both cameras can connect and work as guide cameras on the newer Rpi4-1 if I connect directly to the camera (not and Indi Camera).  So the problem is with the Indi Camera Driver setup on the newer Rpi4-1.

From this   old discussion on this forum  I started looking at the files in /usr/lib/aarch64-linux-gnu on both systems.  Here is what I found:
on the working older Rpi4-8 with Kstars 3.5.1 I have:

ron@UbuAstro:/usr/lib/aarch64-linux-gnu$ ls -al libASI*
lrwxrwxrwx 1 root root      18 Jan  8 02:32 libASICamera2.so -> libASICamera2.so.1
lrwxrwxrwx 1 root root      23 Jan  8 02:32 libASICamera2.so.1 -> libASICamera2.so.1.16.3
-rw-r--r-- 1 root root 1887712 Jan  8 02:32 libASICamera2.so.1.16.3


So there are links for the ASI  camera driver (?) to existing files.

While on the newer Rpi4-1 (non working Kstars 3.5.3) I find:

ron@UbuAstroServer:/usr/lib/aarch64-linux-gnu$ ls -al libASI*
lrwxrwxrwx 1 root root      18 Apr 21 15:06 libASICamera2.so -> libASICamera2.so.1
lrwxrwxrwx 1 root root      21 Apr 21 15:06 libASICamera2.so.1 -> libASICamera2.so.1.17
-rw-r--r-- 1 root root 1887712 Apr 21 15:06 libASICamera2.so.1.16

there are also links, but the final files extension does not match the existing file.

I am assuming there is a similar issue with the Starlight Express camera (SX CCD) but I am not able to identify which files are associated with that camera.

Can someone either help me correct the issue with Kstars 3.5.3 or how to revert the newer Rpi4-1 to the earlier working Kstars 3.5.1 and its associated libraries.

thanks,

 
Last edit: 1 year 7 months ago by Ronald Scotti. Reason: corrections
1 year 7 months ago #70542

Please Log in or Create an account to join the conversation.

  • Posts: 312
  • Thank you received: 13
What I did was to simply copy the file named libASICamera2.so.1.16 to libASICamera2.so.1.17 (so I have two of the same files with different extensions) and then the previous link was valid and now my ZWO camera's work.

Now I just need someone to tell me how to do the same for the SX Lodestar camera.

thanks,
The following user(s) said Thank You: Spartacus
1 year 7 months ago #70543

Please Log in or Create an account to join the conversation.

  • Posts: 312
  • Thank you received: 13
The SX CCD issue is different, I don't get an error about its driver crashing, rather it just does not show up in the Indi Control Panel, even though it is selected in the profile. I am in the process of making sure all of the xml files are in their proper locations (/usr/share/indi and home/.indi).

I installed the sx_drivers, but there are xml files for the SX_CCD missing in those directories?
1 year 7 months ago #70553

Please Log in or Create an account to join the conversation.

issue is fixed in PPA.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Spartacus
1 year 7 months ago #70699

Please Log in or Create an account to join the conversation.

  • Posts: 312
  • Thank you received: 13
Jasem,
I just did an update and upgrade to Kstars 3.5.4 Beta (is this the latest stable?) on my Rpi 4 running Ubuntu 20.1 and the SX CCD still does not show up in the Indi control panel. The SX FilterWheel does and so do the Zwo cameras and all seems to be working, but there is no tab for the SX Lodestar. The SX camera works when directly connected to PHD2, but I cannot connect to it in EKOS.

 Updating in the PPA says indi-sx is already the newest version as well is Kstars-bleeding.

Any other suggestions.

thanks for all your efforts in this latest release.
Last edit: 1 year 7 months ago by Ronald Scotti.
1 year 7 months ago #70754

Please Log in or Create an account to join the conversation.

Time to create page: 0.586 seconds