×

INDI Library v1.9.4 Released (17 Jan 2022)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

Missing filter tag in FITS header

  • Posts: 52
  • Thank you received: 8
I have the same issue.

My setup is ZWO ASI1600MM with a ZWO EFW. I find that this happens when I've used a manual capture on my Luminance filter (in the first slot). Then when I create a sequence and start capturing data I found my images with Luminance filter has the missing FILTER fits header. I feel it has something to do with when a sequence starts but the filter wheel doesn't move the state of the current filter isn't set so it's not added to the FITS image. Also, given that the original poster is using ZWO EFW it might be something to do with that (as I have the same filter wheel and it is happening to me). I might have a look at the code over the weekend and see if I can find the issue and get a bug fix for it.

As I have created my own Python script using astropy to get around it I don't find this a major issue but I can report that it does happen.
RPI 4 B (4Gb) running Manjaro ARM
Kstars/Ekos
SkyWatcher Esprit 80ED
SkyWatcher EQ6-Pro
ZWO ASI1600MM Pro
ZWO ASI290MM-Mini
ZWO EFW
PrimaLuceLab Sesto Senso 2
Pegasus UPBv2
5 months 4 days ago #74662

Please Log in or Create an account to join the conversation.

  • Posts: 52
  • Thank you received: 8
If it is the EFW, I think the issue might be that the call to EFWGetPosition is returning -1 while it is still moving. This can then result in ASIWHEEL::QueryFilter() method to fail. I will try to get some debugging on this over the weekend and see if that is the problem
RPI 4 B (4Gb) running Manjaro ARM
Kstars/Ekos
SkyWatcher Esprit 80ED
SkyWatcher EQ6-Pro
ZWO ASI1600MM Pro
ZWO ASI290MM-Mini
ZWO EFW
PrimaLuceLab Sesto Senso 2
Pegasus UPBv2
5 months 4 days ago #74663

Please Log in or Create an account to join the conversation.

  • Posts: 210
  • Thank you received: 25
Hi,

it happens with my SX filterwheel and also the simulator filter wheel as well. When I test with the simulator as long as there has been no filter switch the tag is missing. But I also have some files (with the SX) where the tag is missing after the wheel has moved.

Paul
5 months 4 days ago #74664

Please Log in or Create an account to join the conversation.

This is not an INDI filter driver issue, but rather the camera driver isn't snooping correctly on the filter value. It's most likely an Ekos bug. If someone can reproduce it reliably, please let me know and I'll investigate it further.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
5 months 4 days ago #74665

Please Log in or Create an account to join the conversation.

  • Posts: 210
  • Thank you received: 25
Jasem,

what I notice:.

1. Can't set snoop device for filter in camera driver. (fill in the device name, use net, nothing happens) Using the Atik driver.

2. in config file Acitive Filter is empty (but no snoop entries in the Atik config file)

Tried purge and default for the config file, same thing.

Regards,

Paul DB
  <oneText name='ACTIVE_ROTATOR'>
      Rotator Simulator
  </oneText>
  <oneText name='ACTIVE_FOCUSER'>
      Pegasus FocusCube
  </oneText>
  <oneText name='ACTIVE_FILTER'>

  </oneText>
  <oneText name='ACTIVE_SKYQUALITY'>
      SQM

 
5 months 3 days ago #74694

Please Log in or Create an account to join the conversation.

In capture module, if you select the filter, does it set it in the driver? That could be the issue.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
5 months 3 days ago #74698

Please Log in or Create an account to join the conversation.

  • Posts: 210
  • Thank you received: 25
When switching filters (from capture) it looks ok: filter is in the fits header. But need to do more testing for that. Equipment is in "maintenance" mode so can't do it right now.

Regards,

Paul DB
5 months 3 days ago #74714

Please Log in or Create an account to join the conversation.

  • Posts: 52
  • Thank you received: 8
Jasem,

For me it always adds the FILTER header when I use the Capture module to do a preview.

This weekend I was able to recreate the issue 3 times in a row doing the following:
1. Take a preview image from the Capture Module with a filter (for me this is my Lum in slot 1).
2. Using the scheduler run a job that would use the same filter as just used in preview mode, submit the job.
3. Any of images that start in the sequence that have the same filter for the preview end up with NO 'FILTER' header in the FITS image. Once the filter changes all images end up with a FILTER header.

If the EFW was in a different filter slot than the first filter used in the sequence then all images get the FILTER header.

Note, this doesn't even need to used the Ekos Scheduler, it can also be just done via the Capture Sequence. The other week while I was doing my flats all the Luminance images had no FILTER header as they happened to be the first ones taken after doing a preview capture.

I hope this helps. I've also been looking into the code of both Ekos and INDI. Still can't work out where it is but hopefully the details I've provided might give you some idea where to look.
RPI 4 B (4Gb) running Manjaro ARM
Kstars/Ekos
SkyWatcher Esprit 80ED
SkyWatcher EQ6-Pro
ZWO ASI1600MM Pro
ZWO ASI290MM-Mini
ZWO EFW
PrimaLuceLab Sesto Senso 2
Pegasus UPBv2
5 months 2 days ago #74732

Please Log in or Create an account to join the conversation.

  • Posts: 210
  • Thank you received: 25
Did some tests yesterday, but can't see any logic. Usually (also in preview) the filter is missing as long as the FW hasn't moved. After selecting a new filter it usually is set in the FITS file, but not always.
It must be in EKOS, when I run the same config from CCDCIEL no problem, and the filter is always in the fits header.

Rgrds,

Paul DB
5 months 1 day ago #74777

Please Log in or Create an account to join the conversation.

  • Posts: 779
  • Thank you received: 101
I tend to agree.
I am normally using the capture module only, and before running a sequence manually start an auto focus run. So the sequence starts without having to move the filter, and on quick look they all have the 'FILTER' entry.
I did spot some missing ones in flatfield images, but don't really have a statistics on that, as I don't store the raw flats for longer periods....
So some race condition in EKOS that depends on history of actions seems a plausible explanation...
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
5 months 1 day ago #74778

Please Log in or Create an account to join the conversation.

So what I found is this: If the default filter wheel is not set, the camera driver is not set to the new filter wheel. In capture module, as soon as you select the filter wheel from the dropdown, it is set a default filter wheel and then this is reflected in the camera --> options --> filter snoop. Is this the issue?

I added a fix that I am testing now so that filter wheel info is also checked whenever a capture happens to synchronize it.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
5 months 1 day ago #74779

Please Log in or Create an account to join the conversation.

  • Posts: 210
  • Thank you received: 25
That seemed to be the problem (at least for me) After I clicked on the filterwheel drop down box in the capture menu, the snoop device became visible in the camera xml file. After that filters seem to be set in Fits file all the time.

Thks.

Paul DB
5 months 1 day ago #74781

Please Log in or Create an account to join the conversation.

Time to create page: 0.914 seconds