×

INDI Library v2.0.6 is Released (02 Feb 2024)

Bi-monthly release with minor bug fixes and improvements

Missing button icons in EKOS under Ubuntu 15.10

  • Posts: 58
  • Thank you received: 6
I'm using Kubuntu and also missing some button icons. Jasem you can see them missing in those moravian screenshots i send you.
The following user(s) said Thank You: Stefan Nonneman
7 years 11 months ago #7360

Please Log in or Create an account to join the conversation.

  • Posts: 45
  • Thank you received: 6
I am testing rp3 ubuntu-mate 15.10 and same problem for me.
export QT_QPA_PLATFORMTHEME=kde
kstars
didn't work for me.
7 years 11 months ago #7448

Please Log in or Create an account to join the conversation.

  • Posts: 90
  • Thank you received: 12
I followed the steps here to install qt5ct:
fixmynix.com/change-qt5-application-style-with-qt5ct/
(latest version is qt5ct-0.23.tar.bz2)
build the package and configure once in qt5ct

and then run kstars at terminal with: QT_QPA_PLATFORMTHEME=qt5ct kstars

and the icons pop up right
I'm using ubuntu server 16.04 with vnc
The following user(s) said Thank You: Jasem Mutlaq
7 years 9 months ago #8185

Please Log in or Create an account to join the conversation.

  • Posts: 117
  • Thank you received: 5
I have now upgraded my OS to Ubuntu Mate 16.04 on RPi2.
Most of the buttons now have icons visible. Here and there an icon is missing.
Huge improvement, Great!!!!
stefan
7 years 9 months ago #8241

Please Log in or Create an account to join the conversation.

  • Posts: 486
  • Thank you received: 87
Hi, I am running Xubuntu 16.04 and had the same problem.
After digging the forum nothing worked.

Installing this library "libqt5libqgtk2" solved the problem.

sudo apt-get install libqt5libqgtk2

Regards
The following user(s) said Thank You: Jasem Mutlaq, max
7 years 9 months ago #8243

Please Log in or Create an account to join the conversation.

  • Posts: 117
  • Thank you received: 5
I checked again and without any other manipulation all icons are no present on the buttons.
Also the new feature allowing to create profiles before launching and connecting the indi-server to devices works very well.

In order to repeat, I just upgraded to Ubuntu-Mate 16.04 and installed kstars-bleedingedge and it is all OK.

Stefan
7 years 9 months ago #8274

Please Log in or Create an account to join the conversation.

  • Posts: 486
  • Thank you received: 87
I have just made a clean install of Ubuntu Mate 16.04 64Bit and kstars-bleeding on a laptop and icons did not appear.
Made a sudo apt-get install oxygen-icon-theme and also solved the problem.
7 years 8 months ago #8728

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 6

Be careful with this. I tried this yesterday because he reclaimed on dependencies and it completely broke my system (xubuntu). Conflicts between qt5 versions can happen.
The following user(s) said Thank You: nMAC
7 years 7 months ago #9324

Please Log in or Create an account to join the conversation.

  • Posts: 486
  • Thank you received: 87
Yes that may happen if you have more than one version installed, I had no problems either with the RPi or the 2 PC's I have installed.
It didn't ask me for dependencies, maybe because I had them already installed.

Anyway thanks for the warning, I should mention, first try the last post:

sudo apt-get install oxygen-icon-theme

that fixed the problem too and it's probably safer.
The following user(s) said Thank You: Derek
Last edit: 7 years 7 months ago by nMAC.
7 years 7 months ago #9327

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 2
Same issue in my Debian buster. I fixed it by installing the meta package "breeze".
5 years 4 months ago #30099

Please Log in or Create an account to join the conversation.

  • Posts: 278
  • Thank you received: 17
sudo apt-get install oxygen-icon-theme

gave me icons on ubuntu 16.04. Maybe a dependency on this should be added to the kstars package?
4 years 5 months ago #43534

Please Log in or Create an account to join the conversation.

KStars uses breeze-icon-theme
The following user(s) said Thank You: Þórir Már Jónsson
4 years 5 months ago #43546

Please Log in or Create an account to join the conversation.

Time to create page: 1.289 seconds