×

INDI Library v1.9.4 Released (17 Jan 2022)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

Re:Re:Re:KStars window thrashes entire system

  • Posts: 162
  • Thank you received: 20
Recently I've noticed some rather annoying behavior with my setup (4GB Pi 4, StellarMate OS 1.5.8 ). The system will appear to freeze, but not quite. It just gets really, really, really super-slow to respond. For example, I might hover my cursor over the application icons in  the menu bar to switch to the system file manager, but the highlight doesn't appear. But if I leave it there for 30-40 seconds, the UI responds. Likewise I can click, and half a  minute later the selected application minimizes or comes to the foreground as appropriate.

I am running VNC over the built-in WiFi hotspot. The program "top" in a terminal window shows load averages around 0.6, nothing maxing out the CPU, though KStars frequently jumps to the top.

The weird thing is that I can often provoke this behavior at will -- all I have to do is bring up the KStars window. If I leave it minimized, the system just hums along. I noticed it particularly after I turned on the HiPS All Sky Overlay once, but it still seems to occur once I eventually managed to turn it off (at 40 seconds per click!). I have had slowdown problems previously but I only saw this start to happen after I turned on the "independent window" setting for Ekos, so that I could, in fact, minimize the KStars window and just use Ekos.

Is this a known issue? Are there other workarounds besides "minimize KStars the moment you bring up Ekos and don't touch it again?" I haven't tried resizing the KStars window, nor stopping the KStars clock (I'm not sure how that interacts with Ekos's notion of what time it is, which is kinda important for telescope control!)

I'm running profiles with PHD guiding almost exclusively. 

TIA,

rw
Last edit: 7 months 13 hours ago by Rick Wayne. Reason: Got rid of annoying smiley BBS auto-inserted in place of 8)
7 months 13 hours ago #72643

Please Log in or Create an account to join the conversation.

  • Posts: 1021
  • Thank you received: 298
That's interesting. Do you have the possibility to open a ssh session to your raspberry in parallel, to execute "top" there and watch the cpu and memory occupation?

You may also want to enable limited resource mode in the Ekos options, and eventually install zram-tools in case it is a memory shortage issue.

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
7 months 9 hours ago #72647

Please Log in or Create an account to join the conversation.

  • Posts: 1021
  • Thank you received: 298
Also check the frequency at which KStars will update the simulation, by the way.

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
7 months 9 hours ago #72648

Please Log in or Create an account to join the conversation.

  • Posts: 162
  • Thank you received: 20
I believe the simulation is running at the default of one second == one second -- I'll have to try changing that. Does anyone know if it affect's Ekos's operation to just pause the simulation entirely? If not, heck, I'll just do that.

Pretty sure it's not running running out of memory, as "top"reports a significant fraction of it free.

I was going to say "but I'm already running 'top' on the Pi", when I realized that the import of your ssh suggestion was to do so in a manner independent of VNC. Which is also worth trying.
Last edit: 7 months 9 hours ago by Rick Wayne.
7 months 9 hours ago #72649

Please Log in or Create an account to join the conversation.

  • Posts: 162
  • Thank you received: 20
Updated to add: Well, as you might have imagined, Ekos's clock does seem to run independently. Pausing the KStars sim on my Mac does not prevent the hour angle from updating, at least.
7 months 8 hours ago #72651

Please Log in or Create an account to join the conversation.

  • Posts: 1021
  • Thank you received: 298
The Scheduler depends on KStars' clock. However, your mount does not care about it and most probably uses the system time. Theoretically if you use Ekos in "manual" mode (vs scheduled) you should be able to leave the simulation paused. But it is easy to get confused, and it is probably not your problem here.

Also try to Center and Track your view in the star chart. This will limit the amount of graphics updates, and also limit the bandwidth used by vnc.

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
7 months 8 hours ago #72654

Please Log in or Create an account to join the conversation.

  • Posts: 162
  • Thank you received: 20
Just wanted to finish this off with a couple of quick notes. As Jasem said in another thread, Ekos uses the system time when a profile is started, not the KStars simulation time.

I got a fast USB SSD and set up to boot off that. No difference to my issue.

However, ensuring that the color overlays were off in KStars, selecting the "independent window" open for Ekos, and minimizing the KStars window seems to work around it.

Even with the color overlays turned off, if I do a "find" in KStars, though, the whole system slows to a crawl. What's weird is that using the "find" option in the mount control dialog, which brings up the same search box, apparently works just fine.

So I've got a functional workaround.
The following user(s) said Thank You: Eric
6 months 3 weeks ago #73057

Please Log in or Create an account to join the conversation.

  • Posts: 1021
  • Thank you received: 298
Specifically, Ekos resets the simulation clock to the current system time when it starts a profile. It may not be helpful for you, but did you try pausing the simulation again afterwards? This would help to locate the issue.

The find window is unfortunately notoriously slow, and becomes really sluggish as catalogs are added. This part is being worked on.

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
6 months 3 weeks ago #73079

Please Log in or Create an account to join the conversation.

  • Posts: 162
  • Thank you received: 20
I just leave it off all the time. Pretty sure it was still off when I brought up the window.
6 months 3 weeks ago #73116

Please Log in or Create an account to join the conversation.

Time to create page: 0.244 seconds