×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Image counter issues causing images to be lost

  • Posts: 385
  • Thank you received: 27
Eric,

The counter getting stuck is still a problem and seems to be the result of a number of "random" issues. I have not really tracked it down to any particular cause but it has become less frequent.
I am also convinced, with no proof, that the sequence starting at 000 instead if 001 is another side effect of an underlying issue.

Paul
Losmandy G11 with Gemini 2 controller
QSI 583/683 monochrome cameras with filter wheel
Starlight Xpress Lodestar X2 guide camera
Microtouch Focuser controlled using Arduino UNO emulating Feathertouch controller
Raspberry Pi 2GB with Raspberry Pi OS 64bit Bullseye
Last edit: 10 months 1 week ago by Paul.
10 months 1 week ago #79606

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 0
Thanks for the update Paul,

On my side , numbering starts at 001

Regards
Eric
10 months 1 week ago #79609

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 0
Hi all
i just got the issue last night and checked more in detail the log files

in my last night cession i was imaging M101 for 150 pictures of 30 sec exposure
it runs fine, from files 1 to 71 and after four more files with index number equal to 71 and stuck to 71 and then EKOS/KSTAR crashed.

see extract enclosed

line 10 first file with index 71 ("FITS" file saved to "/media/astroberry/SKY_KEY/M_101/Light/Red/M_101_Light_Red_30_secs_2022-01-21T02-27-22_071.fits") is saved (this is the first index 71, so the correct one)
the next one is line 978        ("FITS" file saved to "/media/astroberry/SKY_KEY/M_101/Light/Red/M_101_Light_Red_30_secs_2022-01-21T02-28-29_071.fits")

and the times difference shows that there is close to 1 minute 7 sec of difference (instead of 30sec)
so i check between those two lines using guiding rate of 2 sec images (to get around 30sec after first index 71 image )

and i found that line  : [2022-01-21T02:28:02.000 CET WARN ][                       default] - QProcessPrivate::createPipe: Cannot create pipe 0xc5e370c: Too many open files

seem that this is the source of the crash issue. 

any idea of the origin of this message from which process it is coming from  ?

thanks for your help there

Regards
Eric


 

File Attachment:

File Name: 20220121lo...ract.txt
File Size:113 KB
10 months 1 week ago #79729
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 385
  • Thank you received: 27
Eric,

Your problem sounds like a memory leak, but that is a different issue as it has caused the program to abort.
The problem I have seen is where it keeps imaging but it overwrites the same file because the number stops incrementing.
I have to admit I have not had it occur for a few weeks, but then again until the last few days it has been too cloudy to do any imaging.

Paul
Losmandy G11 with Gemini 2 controller
QSI 583/683 monochrome cameras with filter wheel
Starlight Xpress Lodestar X2 guide camera
Microtouch Focuser controlled using Arduino UNO emulating Feathertouch controller
Raspberry Pi 2GB with Raspberry Pi OS 64bit Bullseye
10 months 1 week ago #79763

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 0
Paul

yes slightly different problem, will open another discussion on mine. 8-)

Eric
10 months 5 days ago #79876

Please Log in or Create an account to join the conversation.

Time to create page: 0.684 seconds