×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

SX CCD not working?

1 year 4 months ago
drmikevt
Junior Boarder
Junior Boarder
Posts: 25
More
Topic Author
SX CCD not working? #33619
I'm on a Mac (10.13.6) using Kstars 3.0.0. Using the internal INDI server, I select 'SX CCD' as my camera, but then no tab appears in the connection window. There is no way to connect to my SX-46.

Likewise, if I try to use INDI server, the SX CCD 'light' stays yellow, but the SX wheel and SX AO are green.

If anyone can help me gain control of my camera (SX-46) through Ekos, I'd greatly appreciate it.

Thanks
Mike

Please Log in or Create an account to join the conversation.

1 year 4 months ago
knro
Administrator
Administrator
Posts: 8000
Karma: 51
SX CCD not working? #33634
What's the VID:PID of this camera? These are the cameras USB vendor & product ID.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 4 months ago
drmikevt
Junior Boarder
Junior Boarder
Posts: 25
More
Topic Author
SX CCD not working? #33636
James

Thank you!, but the issue is not camera dependent. If I set up a new Equipment Profile in Ekos, and choose to use the internal INDI server, and choose 'SX CCD' as my camera - then, when I open the INDI server control panel (where I can connect/disconnect to devices) there is no tab for SX CCD. I have tabs for all my other equipment (Paramount, SX AO, Gemini) - but no way to connect to my camera or Lodestar guider. The SX CCD INDI 'driver' (not sure of the right term) seems just plain broken.

I will get the info for the camera (SX-46) as you requested, but surely the Lodestar is already a known camera and I can not connect to that either.

Thanks for your help - I really want this to work (Using Ekos to allow me to use both the SX AO and TSX while remaining on the Mac).
Mike

Please Log in or Create an account to join the conversation.

1 year 4 months ago
drmikevt
Junior Boarder
Junior Boarder
Posts: 25
More
Topic Author
SX CCD not working? #33648
My apologies - of course you are correct and it is a camera recognition issue.

Here is what I see with the SX-46 plugged into the USB port of the computer. The SX-46 hub is connected to the SX-AO, SX filter wheel and Ultrastar:
USB 2.0 Bus:

Host Controller Driver: AppleUSBEHCIPCI
PCI Device ID: 0x1c26
PCI Revision ID: 0x0005
PCI Vendor ID: 0x8086

Hub:

Product ID: 0x2513
Vendor ID: 0x0424 (SMSC)
Version: b.b3
Speed: Up to 480 Mb/sec
Location ID: 0xfd100000 / 1
Current Available (mA): 500
Current Required (mA): 2
Extra Operating Current (mA): 0
Built-In: Yes

USB2.0 Hub:

Product ID: 0x6572
Vendor ID: 0x04b4 (Cypress Semiconductor)
Version: 32.99
Speed: Up to 480 Mb/sec
Location ID: 0xfd120000 / 3
Current Available (mA): 500
Current Required (mA): 100
Extra Operating Current (mA): 0

SxFilterWh:

Product ID: 0x0920
Vendor ID: 0x1278
Version: 0.01
Speed: Up to 12 Mb/sec
Manufacturer: SxFilterWh
Location ID: 0xfd124000 / 6
Current Available (mA): 500
Current Required (mA): 300
Extra Operating Current (mA): 0

ECHO2:

Product ID: 0x0525
Vendor ID: 0x1278
Version: 0.00
Speed: Up to 480 Mb/sec
Manufacturer: Starlight Xpress
Location ID: 0xfd122000 / 5
Current Available (mA): 500
Current Required (mA): 300
Extra Operating Current (mA): 0

ECHO2:

Product ID: 0x0604
Vendor ID: 0x1278
Version: 0.00
Speed: Up to 480 Mb/sec
Manufacturer: Starlight Xpress
Location ID: 0xfd121000 / 4
Current Available (mA): 500
Current Required (mA): 300
Extra Operating Current (mA): 0

IR Receiver:

Product ID: 0x8242
Vendor ID: 0x05ac (Apple Inc.)
Version: 0.16
Speed: Up to 1.5 Mb/sec
Manufacturer: Apple Computer, Inc.
Location ID: 0xfd110000 / 2
Current Available (mA): 500
Current Required (mA): 100
Extra Operating Current (mA): 0
Built-In: Yes

Please Log in or Create an account to join the conversation.

1 year 4 months ago
drmikevt
Junior Boarder
Junior Boarder
Posts: 25
More
Topic Author
SX CCD not working? #33652
Ok, got it right this time - attached is a document direct from SX.

Please let me know if/when I can t ry using the SX-46 with Ekos.

Thanks very much
Mike

This browser does not support PDFs. Please download the PDF to view it: Download PDF

Attachments:

Please Log in or Create an account to join the conversation.

1 year 4 months ago
knro
Administrator
Administrator
Posts: 8000
Karma: 51
SX CCD not working? #33656
Thanks, I just added the new PIDs. Will have to wait until KStars 3.1.0 MacOS version is released hopefully soon.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 4 months ago
drmikevt
Junior Boarder
Junior Boarder
Posts: 25
More
Topic Author
SX CCD not working? #33657
It seems like maybe this is more of a 3.0.1 type change, but okay - thanks very much for the attention to this issue.

A week? A month? More or less?

Mike

Please Log in or Create an account to join the conversation.

Time to create page: 0.205 seconds