×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

Focus routine not working

  • Posts: 37
  • Thank you received: 3
Hello,

It's been a while since I used my autofocuser w EKOS but last 2 nights I did & something strange happens.

I'm using 3.5.2 and my focuser is a DeepSkyDad AF3.

When I select my main imaging camera and run auto-focus, the image is captured & analysed and then the focuser draws out, calculates the focus quality & then draws back in etc.  I can see the polynomial its being plotted, but then it just doesn't find the minimum and loops back to the initial starting focus position & starts again even where there is a clear curve.

Has anyone else experienced something like this?  If so, any tips please (it may be that I'm not using the right settings although I leave it to what it defaults to - but I know the focuser module seem to be more sophisticated w more optionality than the last time I regularly used it - is there a tutorial of best practices somewhere?)

Thank you.
1 month 3 weeks ago #74989

Please Log in or Create an account to join the conversation.

  • Posts: 65
  • Thank you received: 4
I'm not an expert, but there were a lot of improvements in the autofocus process with version 3.5.4. Prior to this version, I had a lot of trouble with polynomial focusing (same as your experience) and had to use linear to make it work. Under 3.5.4 I have not had any problems with autofocus and it is very fast.

Ron
Mounts: Sky-Watcher EQ6-R Pro, Meade LX85, Celestron NexStar Evolution Alt/Az
OTAs: Celestron 8" Edge HD w/Celestron Focus Motor, Meade 80mm APO Triplet Refractor w/ZWO EAF
Cameras: ASI533MC Pro, ASI183MC Pro, ASI224MC, ASI120MC-S, ZWO ASI290MM
Raspberry Pi 4 with Stellarmate OS, MacBook Pro
The following user(s) said Thank You: Vin
1 month 3 weeks ago #74991

Please Log in or Create an account to join the conversation.

  • Posts: 37
  • Thank you received: 3

Replied by Vin on topic Focus routine not working

Thanks @Ron Clanton that is encouraging to hear.  I will download 3.5.4 (hopefully it will crash less than 3.5.2 has done the last two nights too).  As you'd expected, no clear nights for a week now so will report back once I've had a chance to test it again!

Cheers
1 month 3 weeks ago #74999

Please Log in or Create an account to join the conversation.

  • Posts: 37
  • Thank you received: 3

Replied by Vin on topic Focus routine not working

It works on 3.5.4 hurray - and the multi-star guiding is also pretty cool to see.  KStars has been crashing a lot as well though so clearly there's another issue coming through?  Ah well.
1 month 2 weeks ago #75253

Please Log in or Create an account to join the conversation.

Time to create page: 0.437 seconds