×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Baader Steeldrive II won‘t connect

  • Posts: 83
  • Thank you received: 35
Could this be an access rights issue ?
nvm i see it's a read timeout, weird.
Maybe debug level logging shows something ?
Last edit: 1 year 1 month ago by Hans. Reason: re-reading
1 year 1 month ago #77131

Please Log in or Create an account to join the conversation.

  • Posts: 58
  • Thank you received: 2

The SteelDrive 1 driver you suggested to try gave me:
2021-11-09T13:10:38: [INFO] Error retrieving data from SteelDrive, please ensure SteelDrive controller is powered and the port is correct.
2021-11-09T13:10:38: [ERROR] getHWVersion error: Timeout error.

What's really makes my head scratch: It works out of the box with TheSky.
What am I doing wrong?
--
macOS Ventura - 10micron GM1000HPS - ZWO ASI Camera - Baader Steeldrive II
Celestron 11" EdgeHD, TS-Optics Doublet SD-Apo 80 mm, Lunt 80THA/B1800FTPT

www.astrobin.com/users/Poison/?sub=uploaded
Last edit: 1 year 1 month ago by Oliver.
1 year 1 month ago #77404

Please Log in or Create an account to join the conversation.

  • Posts: 58
  • Thank you received: 2
I still need help as I'm really lost with this.
When I try to connect with Ekos (KStars 3.5.7 stable) I can hear clearly a short "tick" or "click" from the focuser but then the connection timed out.The focuser will connect without problems with TheSky X and X2 driver (also hear that "tick" before it will connect:
rti-zone.org/software_x2focuser_plugins.php#steeldriveII

Then I installed Astroimager with INDIGO to test the connection.
Focuser won't connect on first try but will on second attempt and runs without any issues, also hear the tick/click sound before it will connect.

My equipment:
MacBook Pro M1 Max 32GB Ram
macOS Monterey 12.2.1
KStars 3.5.7

I tested with following connectors (all have an FTDI 232 chip)
Synchwire OTG USB Typ C Adapter, Thunderbolt 3 to USB
FITFORD USB 3 Hub

After having no success with Ekos I installed FTDI VCP Driver 1.4.7 Beta.
No success with Ekos but with TheSky X.

Any help would be appreciated.
--
macOS Ventura - 10micron GM1000HPS - ZWO ASI Camera - Baader Steeldrive II
Celestron 11" EdgeHD, TS-Optics Doublet SD-Apo 80 mm, Lunt 80THA/B1800FTPT

www.astrobin.com/users/Poison/?sub=uploaded
9 months 3 days ago #81157

Please Log in or Create an account to join the conversation.

  • Posts: 58
  • Thank you received: 2
Here is the log. As I mentioned before the device will connect but time out.
cu.usbserial-3 = FTDI Driver
cu.usbserial-A907KE80 = macOS Driver

INFO    191.490656 sec    : Session log file /Users/oliverforster/.indi/logs/2022-03-10/indi_steeldrive2_focus/indi_steeldrive2_focus_12:28:29.log
INFO    201.037250 sec    : Scan complete. Found 3 port(s).
DEBUG    215.775934 sec    : Connecting to /dev/cu.usbserial-3 @ 57600
DEBUG    215.806306 sec    : Port FD 4
DEBUG    215.806347 sec    : Connection successful, attempting handshake...
DEBUG    215.808286 sec    : CMD <GET VERSION>
ERROR    222.985217 sec    : Serial read error: Timeout error.
DEBUG    222.985459 sec    : Handshake failed.
INFO    237.060988 sec    : Scan complete. Found 3 port(s).
DEBUG    243.912767 sec    : Connecting to /dev/cu.usbserial-A907KE80 @ 57600
DEBUG    243.950647 sec    : Port FD 4
DEBUG    243.950798 sec    : Connection successful, attempting handshake...
DEBUG    243.953440 sec    : CMD <GET VERSION>
ERROR    251.126075 sec    : Serial read error: Timeout error.
DEBUG    251.126507 sec    : Handshake failed.

Unfortunately I won't get any logs out of TheSky, as it connects without any issues on Mac or Parallels. 
However, Baader Steel track II works also onIDGIGO without any issues here's the log:

13:46:09.145 INDIGO Bus: property definition
13:46:09.145 'SteelDriveII (focuser)'.'DEVICE_PORT' TEXT rw Ok 2.0 0  { // Serial port
13:46:09.145   'PORT' = '/dev/cu.usbserial-A907KE80' // Device name or URL
13:46:09.145 }
13:46:09.151 INDIGO Bus: property definition
13:46:09.151 'SteelDriveII (focuser)'.'DEVICE_PORTS' SWITCH rw Ok 2.0 0 OneOfMany { // Serial ports
13:46:09.151   'REFRESH' = Off // Refresh
13:46:09.151   '/dev/cu.usbserial-A907KE80' = Off // /dev/cu.usbserial-A907KE80
13:46:09.151   '/dev/cu.usbserial-3' = Off // /dev/cu.usbserial-3
13:46:09.151 }
13:46:09.160 INDIGO Bus: property definition
13:46:09.160 'SteelDriveII (focuser)'.'CONNECTION' SWITCH rw Ok 2.0 0 OneOfMany { // Connection status
13:46:09.160   'CONNECTED' = Off // Connected
13:46:09.160   'DISCONNECTED' = On // Disconnected

Please, help.
--
macOS Ventura - 10micron GM1000HPS - ZWO ASI Camera - Baader Steeldrive II
Celestron 11" EdgeHD, TS-Optics Doublet SD-Apo 80 mm, Lunt 80THA/B1800FTPT

www.astrobin.com/users/Poison/?sub=uploaded
Last edit: 8 months 4 weeks ago by Oliver. Reason: Forum don't like Safari it seems
8 months 4 weeks ago #81290

Please Log in or Create an account to join the conversation.

  • Posts: 58
  • Thank you received: 2
Jasem, is it possible that there is in fact no Baader Steeldrive II driver for EKOS available?
On the devices site there’s only Baader Steeldrive but not Steeldrive II: www.indilib.org/individuals/devices/focu...ader-steeldrive.html

And Baader also saying it’s only compatible with INDIGO and TheSkyX.
Is there anything I could do to help to bring this driver to EKOS?
www.baader-planetarium.com/en/blog/steel...-theskyx-and-indigo/
--
macOS Ventura - 10micron GM1000HPS - ZWO ASI Camera - Baader Steeldrive II
Celestron 11" EdgeHD, TS-Optics Doublet SD-Apo 80 mm, Lunt 80THA/B1800FTPT

www.astrobin.com/users/Poison/?sub=uploaded
1 month 3 days ago #87877

Please Log in or Create an account to join the conversation.

  • Posts: 83
  • Thank you received: 35
While I have no Mac and no Baader Steeldrive focuser either I'll try to help.
In the INDI log you posted I see a baud speed of 57600 . Is that also the port speed in TheSkyX and INDIGO ?

Another approach is to try to access the Steeldrive serial port via another program like Screen or Minicom pbxbook.com/other/mac-tty.html in a console. You have to 'talk' the protocol to see anything assuming it is ASCII based. This may help diagnose the issue.
The following user(s) said Thank You: Oliver
1 month 3 days ago #87880

Please Log in or Create an account to join the conversation.

is there a published command set for SteelDrive II? If yes, then perhaps the current driver can be modified to communicate with it.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 month 3 days ago #87881

Please Log in or Create an account to join the conversation.

  • Posts: 83
  • Thank you received: 35
I think I found the spec, Chapter 3 of www.baader-planetarium.com/en/downloads/...al_documentation.pdf
Also worth noting: baudrate 19200
The following user(s) said Thank You: Oliver
1 month 3 days ago #87882

Please Log in or Create an account to join the conversation.

Actually, I just checked and I developed SteelDrive II INDI driver back in 2019. Baud rate is 19200 by default. From Oliver logs, it appears he was trying to connect at 57600 which will not work.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 month 3 days ago #87883

Please Log in or Create an account to join the conversation.

  • Posts: 58
  • Thank you received: 2
Thank you very much Jasem.

I've tried all Baud rates available with no success.
However, it works out of the box with TheSkyX and INDOGO AstroImager. :-(

@Hans: I've noticed that there is a new version of the FTDI VCP Drivers for macOS. I will try and report tomorrow.
--
macOS Ventura - 10micron GM1000HPS - ZWO ASI Camera - Baader Steeldrive II
Celestron 11" EdgeHD, TS-Optics Doublet SD-Apo 80 mm, Lunt 80THA/B1800FTPT

www.astrobin.com/users/Poison/?sub=uploaded
1 month 3 days ago #87884

Please Log in or Create an account to join the conversation.

  • Posts: 58
  • Thank you received: 2
Nah, no success at all :-(
Updated to Ventura, KSTARS 3.6.1stable and my Steeldrive won't connect with EKOS.
No problems with AstroImager and TheSkyX. Both rely on /dev/cu.usbserial-A907KE80.

I was saving the settings of Baader Steel drive II and got this:
[2022-11-07T17:05:05.766 CET DEBG ][           org.kde.kstars.indi] - Baader SteelDriveII : "[DEBUG] Auto search is disabled because /dev/cu.usbserial-A907KE80 is not a system port. "
[2022-11-07T17:05:16.463 CET INFO ][           org.kde.kstars.indi] - Baader SteelDriveII :  "[INFO] Saving device configuration... "
[2022-11-07T17:05:16.464 CET INFO ][           org.kde.kstars.indi] - Baader SteelDriveII :  "[INFO] Device configuration saved. "
[2022-11-07T17:05:16.465 CET DEBG ][           org.kde.kstars.indi] - Baader SteelDriveII : "[DEBUG] Configuration successfully saved. "

Here's the log:
[2022-11-07T17:06:41.674 CET DEBG ][           org.kde.kstars.indi] - INDI Server:  ""
[2022-11-07T17:06:41.675 CET DEBG ][           org.kde.kstars.indi] - Baader SteelDriveII : "[DEBUG] Toggle Debug Level -- Driver Debug "
[2022-11-07T17:06:41.890 CET INFO ][           org.kde.kstars.ekos] - "Baader SteelDriveII" is connected and ready.
[2022-11-07T17:06:41.898 CET INFO ][           org.kde.kstars.ekos] - "LX200 10micron" is connected and ready.
[2022-11-07T17:06:41.902 CET INFO ][           org.kde.kstars.ekos] - "ZWO CCD ASI178MM" is connected and ready.
[2022-11-07T17:06:41.906 CET INFO ][           org.kde.kstars.ekos] - "ZWO CCD ASI294MC Pro" is connected and ready.
[2022-11-07T17:06:51.346 CET INFO ][           org.kde.kstars.ekos] - "Failed to connect to \nBaader SteelDriveII\nLX200 10micron\nZWO CCD ASI178MM\nZWO CCD ASI294MC Pro\nPlease ensure each device is connected and powered on."
[2022-11-07T17:06:55.921 CET DEBG ][           org.kde.kstars.indi] - Baader SteelDriveII : "[DEBUG] Connecting to /dev/cu.usbserial-A907KE80 @ 19200 "
[2022-11-07T17:06:55.933 CET DEBG ][           org.kde.kstars.indi] - INDI Server:  "2022-11-07T16:06:55: Driver indi_steeldrive2_focus: Handshake lines currently set to 6"
[2022-11-07T17:06:55.934 CET DEBG ][           org.kde.kstars.indi] - INDI Server:  ""
[2022-11-07T17:06:55.934 CET DEBG ][           org.kde.kstars.indi] - Baader SteelDriveII : "[DEBUG] Port FD 3 "
[2022-11-07T17:06:55.934 CET DEBG ][           org.kde.kstars.indi] - Baader SteelDriveII : "[DEBUG] Connection successful, attempting handshake... "
[2022-11-07T17:06:55.934 CET DEBG ][           org.kde.kstars.indi] - Baader SteelDriveII : "[DEBUG] CMD <GET VERSION> "
[2022-11-07T17:07:00.098 CET INFO ][           org.kde.kstars.indi] - Baader SteelDriveII :  "[ERROR] Serial read error: Timeout error. "
[2022-11-07T17:07:00.098 CET DEBG ][           org.kde.kstars.indi] - Baader SteelDriveII : "[DEBUG] Handshake failed. "
[2022-11-07T17:07:13.413 CET DEBG ][           org.kde.kstars.indi] - INDI: Stopping local drivers...
--
macOS Ventura - 10micron GM1000HPS - ZWO ASI Camera - Baader Steeldrive II
Celestron 11" EdgeHD, TS-Optics Doublet SD-Apo 80 mm, Lunt 80THA/B1800FTPT

www.astrobin.com/users/Poison/?sub=uploaded
1 month 2 days ago #87910

Please Log in or Create an account to join the conversation.

Does it work from Raspberry PI?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 month 2 days ago #87928

Please Log in or Create an account to join the conversation.

Time to create page: 0.194 seconds