×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Still trying to debug XAGYL connection

4 months 2 weeks ago
fewayne
Senior Boarder
Senior Boarder
Posts: 46
More
Topic Author
Still trying to debug XAGYL connection #38738
In the description for the XAGYL driver, the directions say to specify the serial port for the USB connection. Questions:
  1. How do I figure out what port the thing is connected to? (I'm running mostly on a Mac, but occasionally on a Pi with StellarMate OS)
  2. Where do I specify the port in Ekos? As nearly as I can see, I can't set anything until the device is already connected. That's got to be wrong, but...how?

Thanks!

rw

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago
maxer
Gold Boarder
Gold Boarder
Posts: 233
Karma: 1
More
Still trying to debug XAGYL connection #38743
Hi,

I don't know how to do that on a Mac but in linux you can do a dmesg in the console and note the last line, and then connect the Xagyl wheel and do a dmesg again and you should see a line saying "/dev/ttyUSB0" or maybe "/dev/ttyACM0" or similar, then you know..
You can also do a lsusb to find out what devices is connected to USBports..
Other way is to do a tail -f /var/log/syslog and then you can see the device get connected in realtime :)

Cs
/Markku

EQ8, Small scope SW200, Big scope SW300, Xagyl FW, Guidescope Celestron 80mm, SX LodestarX2, SXVR-H9.
RPi3, Ubuntu Mate, and many Arduinos..
The following user(s) said Thank You fewayne

Please Log in or Create an account to join the conversation.

3 months 4 weeks ago
fewayne
Senior Boarder
Senior Boarder
Posts: 46
More
Topic Author
Still trying to debug XAGYL connection #39343
Just wanted to report back that I eventually got it working, on my Mac at least. Thanks again for the help.

Please Log in or Create an account to join the conversation.

3 months 2 weeks ago
fewayne
Senior Boarder
Senior Boarder
Posts: 46
More
Topic Author
Still trying to debug XAGYL connection #39690
Now working on the Stellarmate-imaged Pi as well. A lot of it was just getting the ports sorted out; the Serial Port Assistant actually helped here, even though it shouldn't have (i.e. this is not USB-serial, just USB). But it found the wheel and named a device for it anyway. Good enough.

Please Log in or Create an account to join the conversation.

3 months 2 weeks ago
maxer
Gold Boarder
Gold Boarder
Posts: 233
Karma: 1
More
Still trying to debug XAGYL connection #39738
Sounds good, I also had the problem to find right device sometimes but most times they come up in correct order.

Cs,
/Markku

EQ8, Small scope SW200, Big scope SW300, Xagyl FW, Guidescope Celestron 80mm, SX LodestarX2, SXVR-H9.
RPi3, Ubuntu Mate, and many Arduinos..

Please Log in or Create an account to join the conversation.

Time to create page: 0.352 seconds