×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

New All Sky camera management software: indi-allsky

  • Posts: 3
  • Thank you received: 0
Thanks. I will try your suggestion.
5 months 2 weeks ago #83598

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 8
Aaron,
I appreciate all the hard work you have done to create this package! I just installed Indi AllSky on an Astroberry server running on a Raspberry PI 4. The installed seemed to go just fine. It was a clean install of Astroberry and Allsky. I started the service just as described in the install section of the readme file, no errors. Where things go off the rail is when I try to access the application with the Raspberry PI using raspberrypi.local/ I get the Astroberry log on page. what am I doing wrong??
5 months 2 weeks ago #83670

Please Log in or Create an account to join the conversation.

  • Posts: 2151
  • Thank you received: 205
Unable to install this tool on an Odroid C4 running Ubuntu 20.04LTS

heidenrod@heidenrod-obs:~/indi-allsky$ ./setup.sh
###############################################
### Welcome to the indi-allsky setup script ###
###############################################


Distribution: Ubuntu
Release: 20.04
Arch: aarch64

INDI_DRIVER_PATH: /usr/bin
INDISERVER_SERVICE_NAME: indiserver
ALLSKY_SERVICE_NAME: indi-allsky
GUNICORN_SERVICE_NAME: gunicorn-indi-allsky
ALLSKY_ETC: /etc/indi-allsky
HTDOCS_FOLDER: /var/www/html/allsky
DB_FOLDER: /var/lib/indi-allsky
DB_FILE: /var/lib/indi-allsky/indi-allsky.sqlite
INSTALL_INDI: true
HTTP_PORT: 80
HTTPS_PORT: 443

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
fcitx-frontend-qt5 : Depends: libqt5gui5 (>= 5.9.0~beta) but it is not going to be installed or
libqt5gui5-gles (>= 5.9.0~beta) but it is not going to be installed
fcitx5-module-quickphrase-editor : Depends: libqt5gui5 (>= 5.7.0) but it is not going to be installed or
libqt5gui5-gles (>= 5.7.0) but it is not going to be installed
libfcitx-qt5-1 : Depends: libqt5gui5 (>= 5.7.0) but it is not going to be installed or
libqt5gui5-gles (>= 5.7.0) but it is not going to be installed
libqt5svg5 : Depends: libqt5gui5 (>= 5.12.8+dfsg~) but it is not going to be installed or
libqt5gui5-gles (>= 5.12.8+dfsg~) but it is not going to be installed
libqt5widgets5 : Depends: libqt5gui5 (>= 5.12.5) but it is not going to be installed or
libqt5gui5-gles (>= 5.12.5) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


The script exited abnormally, please try to run again...
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO533MC / QHY5L-II-M (OAG)
Last edit: 5 months 2 weeks ago by Gonzothegreat.
5 months 2 weeks ago #83682

Please Log in or Create an account to join the conversation.

  • Posts: 2151
  • Thank you received: 205
looks like the following fixed it:
# apt remove fcitx-frontend-qt5 fcitx5-module-quickphrase-editor libfcitx-qt5-1 libqt5svg5 libqt5widgets5
I had to remove them first...
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO533MC / QHY5L-II-M (OAG)
5 months 2 weeks ago #83683

Please Log in or Create an account to join the conversation.

  • Posts: 2151
  • Thank you received: 205
I see that the tool uses Apache, it might be a good idea to also provide an Nginx version.
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO533MC / QHY5L-II-M (OAG)
5 months 2 weeks ago #83684

Please Log in or Create an account to join the conversation.

  • Posts: 2151
  • Thank you received: 205
Different issue:

elect an INDI driver: 20
**** Setting up indiserver service ****
**** Setting up indi-allsky service ****
**** Setting up gunicorn ****
**** Enabling services ****
Failed to connect to bus: Permission denied


The script exited abnormally, please try to run again...
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO533MC / QHY5L-II-M (OAG)
5 months 2 weeks ago #83686

Please Log in or Create an account to join the conversation.

  • Posts: 2151
  • Thank you received: 205
I ran the following to fix it:
export XDG_RUNTIME_DIR=/run/user/$(id -u)
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO533MC / QHY5L-II-M (OAG)
5 months 2 weeks ago #83687

Please Log in or Create an account to join the conversation.

  • Posts: 2151
  • Thank you received: 205
My SUPER old QHY5 works with this tool, excellent.
I will test it and report as I have seen quite a few things could do with improvements.

Good tool so far. Thanks for creating it.
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO533MC / QHY5L-II-M (OAG)
5 months 2 weeks ago #83688

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 8
Anybody got ideas?? To my earlier post

I appreciate all the hard work you have done to create this package! I just installed Indi AllSky on an Astroberry server running on a Raspberry PI 4. The installed seemed to go just fine. It was a clean install of Astroberry and Allsky. I started the service just as described in the install section of the readme file, no errors. Where things go off the rail is when I try to access the application with the Raspberry PI using raspberrypi.local/ I get the Astroberry log on page. what am I doing wrong??
Last edit: 5 months 1 week ago by Bruce Morrell.
5 months 1 week ago #83766

Please Log in or Create an account to join the conversation.

  • Posts: 346
  • Thank you received: 69
Not sure, but if you install on astroberry then all-sky relocates its services to another port. Accessing it requires putting a colon then the port number after the host name.

Think it is documented somewhere...
__
I blog my progress: www.coochey.net
5 months 1 week ago #83767

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 8
Yes I saw that and tried port 80, 81 and 82 no luck....
5 months 1 week ago #83770

Please Log in or Create an account to join the conversation.

  • Posts: 346
  • Thank you received: 69
raspberrypi.local:444

Failing that, discover the actual IP of the Astroberry and use that instead of raspberrypi.local

The .local address relies on something called multicastDNS or mDNS to work, and not all systems support it.

You can always use netstat to discover what ports are listening on your system, it will be one of those.
__
I blog my progress: www.coochey.net
5 months 1 week ago #83775

Please Log in or Create an account to join the conversation.

Time to create page: 1.133 seconds