×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Indi Support for Bullseye 64 bit RPI4

  • Posts: 102
  • Thank you received: 21
@Val Chevalier:

1) see here www.indilib.org/forum/ekos/4569-download...r-on-os-x.html#34738

2) the astropi scripts should contain scripts to do that: github.com/avarakin/AstroPiMaker4
The following user(s) said Thank You: Val Chevalier
8 months 2 weeks ago #81614

Please Log in or Create an account to join the conversation.

  • Posts: 102
  • Thank you received: 21
@Val Chevalier:

1) see here www.indilib.org/forum/ekos/4569-download...r-on-os-x.html#34738

2) the astropi scripts should contain scripts to do that: github.com/avarakin/AstroPiMaker4
8 months 2 weeks ago #81616

Please Log in or Create an account to join the conversation.

  • Posts: 39
  • Thank you received: 2
Thanks, i will have a look on this in the next days, as i am pretty busy in this time
SW 150/750P (Newtownien) - SW ED72/420 on HEQ5 pro using EqMod
ASI071 pro - CC Baader MPCC III (for newtownien)
Guiding with 60mm refractor and QHY5 II mono
Kstars/Ekos on LENOVO Thinkcenter M71 - Linux Mint 21 & Stellarrmate Pi4 8GB
8 months 2 weeks ago #81634

Please Log in or Create an account to join the conversation.

  • Posts: 39
  • Thank you received: 2
As i just found out there is a 64bits version of SM OS, I decided to use that instead of compiling everything by myself. This is so much convenient. Anyway, it was not wasted time as I have learnt lots of thing.

Thanks anyway all people in this thread.
SW 150/750P (Newtownien) - SW ED72/420 on HEQ5 pro using EqMod
ASI071 pro - CC Baader MPCC III (for newtownien)
Guiding with 60mm refractor and QHY5 II mono
Kstars/Ekos on LENOVO Thinkcenter M71 - Linux Mint 21 & Stellarrmate Pi4 8GB
8 months 2 weeks ago #81696

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 4
Hi Nou

Hoping to update to Kstars 3.6.1.

Would this be correct:

pi@Richard-RPi:~ $ ls
astro-soft-build 'Build single Indi drivers' Documents Light PHD2 rpi-clone sdrangel.wiki USB
astro-soft-stable build-welle.io-Desktop-Debug Downloads Music Pictures rtl8812au SSD Videos

$ cd astro-soft-stable

$ git pull origin

??

This has worked so well I don't want to mess it up!

Thanks
R
1 month 4 weeks ago #87063

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 4
Oops - should have been

$ cd astro-soft-build

$ $ git pull origin

As per your post.

Tks

R
1 month 4 weeks ago #87064

Please Log in or Create an account to join the conversation.

  • Posts: 45
  • Thank you received: 4
All,

Just recently ran into an issue with ZWO Filter Wheel, INDI/EKOS and TheSkyX. Initially ZWO needed to update its X2 plugin for TSX as the one shipping was showing its age for sure. A beta X2 was released for testing. On my Raspberry Pi (Bullseye, RPI 4, 8GB), INDI/EKOS is not "clearing" the Filter Wheel (even when I do a complete disconnect). If I start or access the filter wheel before attempting to use it in TSX, TSX reports a connection error. If I just go right to TSX, the filter wheel is fine. If I do use EKOS first, I have to reboot to get the Filter Wheel release from INDI/EKOS. My reason for using INDI/EKOS right now is that the filter wheel calibrate is in INDI Control Panel. I've asked ZWO to add it to the X2 plugin.

Wondering if there is something internal to INDI/EKOS that is holding on to the EFW?

Appreciate any thoughts..

Jay S.
6 days 22 hours ago #88746

Please Log in or Create an account to join the conversation.

  • Posts: 203
  • Thank you received: 45
yes

$ cd astro-soft-build

$ $ git pull origin

is correct to get updated version of my script.
6 days 13 hours ago #88760

Please Log in or Create an account to join the conversation.

  • Posts: 203
  • Thank you received: 45
Run "ps aux | grep indi_asi" to check if there is any lingering process that can hold connection to ZWO. Because even if you end KStars it can still run in background.
6 days 12 hours ago #88761

Please Log in or Create an account to join the conversation.

  • Posts: 45
  • Thank you received: 4
Hi Nou.. Thanks.. Here are outputs from and LSUSB and PS AUX commands.. Not sure if this means there's something running? When I do a plain PS AUX (no parameters) I don't see any INDI specific processes. Wondering if there is a hardware reset command for the specific USB port?

Jay S.

pi@raspberrypi:~ $ lsusb
Bus 002 Device 002: ID 03c3:1604 ZWO ASI1600MM Pro
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 008: ID 045e:0039 Microsoft Corp. IntelliMouse Optical
Bus 001 Device 006: ID 05ac:0220 Apple, Inc. Aluminum Keyboard (ANSI)
Bus 001 Device 004: ID 05ac:1006 Apple, Inc. Hub in Aluminum Keyboard
Bus 001 Device 007: ID 03c3:224a ZWO ASI224MC
Bus 001 Device 005: ID 03c3:1f01 ZW0 ZWO EFW
Bus 001 Device 003: ID 04b4:6572 Cypress Semiconductor Corp. Unprogrammed CY7C65642 hub
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
pi@raspberrypi:~ $ ps aux | grep indi
pi 2380 0.0 0.0 5908 664 pts/0 S+ 11:17 0:00 grep --color=auto indi
pi@raspberrypi:~ $ ps aux | grep indi_asi
pi 2385 0.0 0.0 5908 664 pts/0 S+ 11:18 0:00 grep --color=auto indi_asi
6 days 6 hours ago #88768

Please Log in or Create an account to join the conversation.

  • Posts: 45
  • Thank you received: 4
Nou...

Found and tried this. Made no difference.. TSX still will not connect (only to EFW)..

Jay S.

pi@raspberrypi:~ $ usbreset ZWO EFW
Usage:
usbreset PPPP:VVVV - reset by product and vendor id
usbreset BBB/DDD - reset by bus and device number
usbreset "Product" - reset by product name

Devices:
Number 001/006 ID 05ac:0220 Apple Keyboard
Number 001/007 ID 03c3:224a ASI224MC
Number 001/002 ID 2109:3431 USB2.0 Hub
Number 002/002 ID 03c3:1604 ASI1600MM Pro
Number 001/004 ID 05ac:1006 Keyboard Hub
Number 001/008 ID 045e:0039 Microsoft 5-Button Mouse with IntelliEye(TM)
Number 001/003 ID 04b4:6572 USB2.0 Hub
Number 001/005 ID 03c3:1f01 ZWO EFW
pi@raspberrypi:~ $ usbreset 03c3:1f01
Resetting ZWO EFW ... ok
pi@raspberrypi:~ $
6 days 6 hours ago #88769

Please Log in or Create an account to join the conversation.

  • Posts: 203
  • Thank you received: 45
No idea then. Probably it gets into some state that TSX doesn't expect.
5 days 2 hours ago #88824

Please Log in or Create an account to join the conversation.

Time to create page: 1.151 seconds