×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Starlight Xpress Trius 825 Mono not detected

  • Posts: 96
  • Thank you received: 18
Hi All, I've installed indi server on my raspberry pi2 running a new install of Ubuntu Mate:

sudo apt-add-repository ppa:mutlaqja/ppa
sudo apt-get update
sudo apt-get install indi-full

I've also installed the Sx drivers as indicated in the Sx Device page using:

sudo apt-get install indi-sx

When I start the server using:

indiserver -vv indi_sx_ccd

and plugging the SX Trius 825 Mono it is not detected. Same issue when I use the Cloudmakers Indi server on Mac OS. Is this camera supported?

Thank you.
6 years 10 months ago #7150

Please Log in or Create an account to join the conversation.

  • Posts: 72
  • Thank you received: 21
Dear Gorgio

When I read your post it looks you connect the camera after you've launched the driver. In fact first connect the camera, check if it is view by Linux with lsusb command. Then stra indiserver with sx driver.
For port mapping you could check this tuto www.indilib.org/support/tutorials/157-pe...al-port-mapping.html

stars regards
Philippe Besson
Skywatcher HEQ5, Televue 101-IS, Takahashi FS-60CB
Focus Boss II with OptecInc TCF-S focuser and Starlight Instruments HSM20 handy stepper motor
Guiding camera ZWO ASI120MM
Filterwheel OptecInc IFW
Camera not set yet
Switzerland
6 years 10 months ago #7151

Please Log in or Create an account to join the conversation.

  • Posts: 712
  • Thank you received: 174
Hi Giorgio, this camera is not yet supported, but can be easily added to the driver. Can you check, what is VID/PID of this device? On linux you can use lsusb command and on OSX /Utilities/System Information. Thank you, Peter
Last edit: 6 years 10 months ago by Peter Polakovic.
6 years 10 months ago #7152

Please Log in or Create an account to join the conversation.


Port mapping is for Serial-USB devices, no need for SX cameras.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
6 years 10 months ago #7153

Please Log in or Create an account to join the conversation.

  • Posts: 96
  • Thank you received: 18
Hi Guys,

Thank you for your speedy feedbacks! Hey Polakovic, here is the full output of lsusb from the PI:

Bus 001 Device 006: ID 1278:0189 Starlight Xpress
Bus 001 Device 005: ID 04b4:6572 Cypress Semiconductor Corp.
Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Thank you!!
Giorgio
Last edit: 6 years 10 months ago by giorgio. Reason: typos
6 years 10 months ago #7156

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 4
Seems like issue solved.
Remember what Besson said - i have to plug everything in before I even power up my RPi2 otherwise strange things happen.
Can You let me know by the way if built-in Trius usb hub works with RPi2?
6 years 10 months ago #7157

Please Log in or Create an account to join the conversation.

  • Posts: 712
  • Thank you received: 174

Definitely not, this is a brand new camera and its VID:PID 1278:0189 is simply not recognised by the driver. I'm working on it... Peter
Last edit: 6 years 10 months ago by Peter Polakovic.
6 years 10 months ago #7166

Please Log in or Create an account to join the conversation.

  • Posts: 712
  • Thank you received: 174
Fixed in driver source. Change is also available in INDI Server for OSX 2.2.1 here:

download.cloudmakers.eu/INDI_Server_2.2.1.dmg
The following user(s) said Thank You: Jasem Mutlaq, giorgio
6 years 10 months ago #7167

Please Log in or Create an account to join the conversation.

  • Posts: 96
  • Thank you received: 18
Thanks a lot Peter!!
I confirm the camera is now detected in Indi Server for Mac OS 2.2.1. Fantastic feedback and impressive turnaround. You guys definitely rock!

I guess at some point the fix will also trickle down to the compiled version of the PI driver right?

Thanks again :)
6 years 10 months ago #7174

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 4
Is it included in recent indiserver rpi package? I can't get it to work.
6 years 9 months ago #7517

Please Log in or Create an account to join the conversation.

Raspberry PI packages are built on daily basis, so they should contain whatever changes made to SX driver.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
6 years 9 months ago #7521

Please Log in or Create an account to join the conversation.

  • Posts: 712
  • Thank you received: 174
Chris, it should be supported. Can you try to run sx_ccd_test? Peter
6 years 9 months ago #7522

Please Log in or Create an account to join the conversation.

Time to create page: 0.668 seconds