×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

[SOLVED] crash with the pegasus PPBA Genv2

  • Posts: 25
  • Thank you received: 2
Hi!

I am trying to make my pegasus functioning but it seems the driver keeps crashing, I am not really sure why, but when I start ekos and it tries to connect to the PPBA kstars just dies.

I was able to turn debugging on for the driver and this is what I getç
 ✘  ~  cat .indi/logs/2022-02-28/indi_pegasus_ppba/indi_pegasus_ppba_16:10:51.log 
INFO    130.758886 sec    : Session log file /home/matt/.indi/logs/2022-02-28/indi_pegasus_ppba/indi_pegasus_ppba_16:10:51.log
DEBUG    138.001118 sec    : Toggle Logging Level -- Driver Debug
DEBUG    146.667466 sec    : Connecting to /dev/serial/by-id/usb-Pegasus_Astro_PPBADV_Gen2A_PPBA671O4R-if00-port0 @ 9600
DEBUG    146.691271 sec    : Port FD 4
DEBUG    146.691300 sec    : Connection successful, attempting handshake...
DEBUG    146.691307 sec    : CMD <P#>
>EBUG    146.725863 sec    : RES <PPBA_OK
DEBUG    146.725891 sec    : Handshake failed.
DEBUG    148.224981 sec    : Connecting to /dev/serial/by-id/usb-Pegasus_Astro_PPBADV_Gen2A_PPBA671O4R-if00-port0 @ 9600
DEBUG    148.248330 sec    : Port FD 4
DEBUG    148.248381 sec    : Connection successful, attempting handshake...
DEBUG    148.248393 sec    : CMD <P#>
>EBUG    148.278172 sec    : RES <PPBA_OK
DEBUG    148.278213 sec    : Handshake failed.
DEBUG    148.751050 sec    : Connecting to /dev/serial/by-id/usb-Pegasus_Astro_PPBADV_Gen2A_PPBA671O4R-if00-port0 @ 9600
DEBUG    148.774322 sec    : Port FD 4
DEBUG    148.774373 sec    : Connection successful, attempting handshake...
DEBUG    148.774385 sec    : CMD <P#>
>EBUG    148.806155 sec    : RES <PPBA_OK
DEBUG    148.806196 sec    : Handshake failed.

I also tried to start kstars with gdb and while I wasn't able to discover much (as if I give a step it exists the app) I was able to see the following error:
SIGSEGV in strlen() hexcodehere /usr/lib/libc.so.6

anybody had the same issue? any idea on what could be wrong?
4 months 6 hours ago #80960

Please Log in or Create an account to join the conversation.

  • Posts: 25
  • Thank you received: 2
today, I am also seeing the following thing, but not sure if it is a real error or not

<code>No ISwitch 'CONNECTION_TCP' in Pegasus PPBA.CONNECTION_MODE</code>

Also, I compiled Kstars with debugging symbols and this is the stack I get
Thread 1 "kstars" received signal SIGSEGV, Segmentation fault.
0x00007ffff40724bd in __strlen_avx2 () from /usr/lib/libc.so.6
(gdb) bt
#0  0x00007ffff40724bd in __strlen_avx2 () at /usr/lib/libc.so.6
#1  0x000055555563fd59 in QString::fromUtf8(char const*, int) (str=0xda2d58f884ea5b1b <error: Cannot access memory at address 0xda2d58f884ea5b1b>, size=-1) at /usr/include/qt/QtCore/qstring.h:706
#2  0x0000555555640a8c in QDebug::operator<<(char const*) (this=0x7fffffffd1a0, t=0xda2d58f884ea5b1b <error: Cannot access memory at address 0xda2d58f884ea5b1b>) at /usr/include/qt/QtCore/qdebug.h:159
#3  0x0000555555a355cc in INDIListener::registerProperty(INDI::Property) (this=0x55555b769e00, prop=...) at /home/matt/data/indi/kstars/kstars/indi/indilistener.cpp:241
#4  0x0000555555a39c1b in QtPrivate::FunctorCall<QtPrivate::IndexesList<0>, QtPrivate::List<INDI::Property>, void, void (INDIListener::*)(INDI::Property)>::call(void (INDIListener::*)(INDI::Property), INDIListener*, void**) (f=
    (void (INDIListener::*)(INDIListener * const, INDI::Property)) 0x555555a354f2 <INDIListener::registerProperty(INDI::Property)>, o=0x55555b769e00, arg=0x7fff7005df48) at /usr/include/qt/QtCore/qobjectdefs_impl.h:152
#5  0x0000555555a3973a in QtPrivate::FunctionPointer<void (INDIListener::*)(INDI::Property)>::call<QtPrivate::List<INDI::Property>, void>(void (INDIListener::*)(INDI::Property), INDIListener*, void**) (f=
    (void (INDIListener::*)(INDIListener * const, INDI::Property)) 0x555555a354f2 <INDIListener::registerProperty(INDI::Property)>, o=0x55555b769e00, arg=0x7fff7005df48) at /usr/include/qt/QtCore/qobjectdefs_impl.h:185
#6  0x0000555555a38a57 in QtPrivate::QSlotObject<void (INDIListener::*)(INDI::Property), QtPrivate::List<INDI::Property>, void>::impl(int, QtPrivate::QSlotObjectBase*, QObject*, void**, bool*) (which=1, this_=0x5555598b5850, r=0x55555b769e00, a=0x7fff7005df48, ret=0x0)
    at /usr/include/qt/QtCore/qobjectdefs_impl.h:418
#7  0x00007ffff4cecdc6 in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#8  0x00007ffff573f1a6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#9  0x00007ffff4cc8b9a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#10 0x00007ffff4cc9699 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/libQt5Core.so.5
#11 0x00007ffff4d10bd8 in  () at /usr/lib/libQt5Core.so.5
#12 0x00007ffff3c27f13 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#13 0x00007ffff3c7e0d9 in  () at /usr/lib/libglib-2.0.so.0
#14 0x00007ffff3c25485 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#15 0x00007ffff4d14ada in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#16 0x00007ffff4cc0e6b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#17 0x00007ffff4ccc5c7 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#18 0x0000555555645956 in main(int, char**) (argc=1, argv=0x7fffffffdb28) at /home/matt/data/indi/kstars/kstars/main.cpp:382
Last edit: 3 months 3 weeks ago by Mattia.
3 months 3 weeks ago #80989

Please Log in or Create an account to join the conversation.

  • Posts: 25
  • Thank you received: 2
for anybody who will get this error in the future, this was coming straight from the kernel, it's not entirely clear why to me yet, but using the ArchLinux ARM kernel does something to FTDI devices that INDI does not like. I moved to `linux-rpi` and `linux-rpi-headers` and it started to work properly
3 months 3 weeks ago #81033

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 1
(Cross post, as my account was in the process of being set-up, I also created a new post here, that has appeared: indilib.org/forum/ekos/11882-ppba-error.html)

Hi,

I can't seem to create a new post, maybe it's because I'm a new user. Anyhow, I can't seem to maintain a connection to the PPBA, am using Arch Linux. Here's in the logs

2022-06-25T20:51:08: Driver indi_pegasus_ppba: restart #4
2022-06-25T20:51:08: Driver indi_pegasus_ppba: pid=1440 rfd=4 wfd=13 efd=14
2022-06-25T20:51:10: Driver indi_pegasus_ppba: /usr/include/c++/12.1.0/bits/stl_vector.h:1123: std::vector<_Tp, _Alloc>::reference std::vector<_Tp, _Alloc>::operator[](size_type) [with _Tp = std::__cxx11::basic_string<char>; _Alloc = std::allocator<std::__cxx11::basic_string<char> >; reference = std::__cxx11::basic_string<char>&; size_type = long unsigned int]: Assertion '__n < this->size()' failed.
2022-06-25T20:51:10: Driver indi_pegasus_ppba: stderr EOF
<delProperty device="Pegasus PPBA"Child process 1440 died
/>


Any ideas? Thanks!
Last edit: 2 days 14 hours ago by JC Idaho.
3 days 1 hour ago #83810

Please Log in or Create an account to join the conversation.

Time to create page: 0.797 seconds