Welcome, Guest
Username: Password: Remember me
14 Nov 2018
Glad to announce of release of INDI Library v1.7.5 on 2018-11-14. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...

TOPIC: INDI Server for Windows

INDI Server for Windows 2 years 2 months ago #10078

Looks like this camera just isn't going to cooperate....still no download. Thank you for trying.

--Jon

File Attachment:

File Name: INDIServerforWindows4.zip
File Size: 2 KB
Attachments:

Please Log in or Create an account to join the conversation.

INDI Server for Windows 2 years 2 months ago #10079

  • polakovic
  • polakovic's Avatar Topic Author
  • Away
  • Moderator
  • Moderator
  • Posts: 703
  • Karma: 14
  • Thank you received: 168
Jon, are you sure that you really use version 2.2.2 (try about button on the server)?

get_CCDTemperature() should be called only if CanSetCCDTemperature() returns true. If it does, it is really very serious driver bug (it is driver bug anyway, get_CCDTemperature() must be defined even if camera has no temperature sensor).

Peter

Please Log in or Create an account to join the conversation.

Last Edit: by polakovic.

INDI Server for Windows 2 years 2 months ago #10080

Let me do a clean uninstall re-install of it by manually removing files. Maybe the older version isn't being removed completely for some reason. I will report back soon....
About dialog is showing 2.0?
--Jon

Please Log in or Create an account to join the conversation.

INDI Server for Windows 2 years 2 months ago #10081

After manual clean, the same result; no download. The about dialog still shows 2.0 but the add/remove programs dialog shows 2.2.2. Maybe a good idea to append the version info into the log file initialization?
Would it be possible to pass in a 'dummy' temperature for these cases so get_CCDTemperature still returns something?

--Jon

Please Log in or Create an account to join the conversation.

INDI Server for Windows 2 years 2 months ago #10082

  • polakovic
  • polakovic's Avatar Topic Author
  • Away
  • Moderator
  • Moderator
  • Posts: 703
  • Karma: 14
  • Thank you received: 168
That's not good, you probably use old version, you should see 2.2.2 in about dialog...

Attachments:

Please Log in or Create an account to join the conversation.

INDI Server for Windows 2 years 2 months ago #10084

I don't know what it could be. I just downloaded it on a different pc and it also shows 2.0. The file name is INDI_Server_32_2.2.2.exe

I tried to download the 64 bit version on the other pc but the link didn't seem to be working....

--Jon

Please Log in or Create an account to join the conversation.

Last Edit: by jonkjon.

INDI Server for Windows 2 years 2 months ago #10086

The really strange part of this is that I never have installed this until 9/5/2016 which was version 2.2. So, I don't know where version 2.0 would have come from.

--Jon

Please Log in or Create an account to join the conversation.

INDI Server for Windows 2 years 2 months ago #10088

  • polakovic
  • polakovic's Avatar Topic Author
  • Away
  • Moderator
  • Moderator
  • Posts: 703
  • Karma: 14
  • Thank you received: 168
You right, my fault :( I tested 64 bit version only and 32 bit version was broken :(

Please, can you try to redownload it? Peter

Please Log in or Create an account to join the conversation.

INDI Server for Windows 2 years 2 months ago #10089

We have a winner!!! It is working now! THANK YOU!!

--Jon

Please Log in or Create an account to join the conversation.

INDI Server for Windows 2 years 2 months ago #10090

Jasem,
When using the INDI Server for Windows, EKOS (from the Linux VM) the CCD (Simulator or real camera) isn't allowing me to choose a type. (Light, Flat, etc.) The dropdown is disabled.

--Jon

Please Log in or Create an account to join the conversation.

Last Edit: by jonkjon.

INDI Server for Windows 2 years 2 months ago #10096

  • polakovic
  • polakovic's Avatar Topic Author
  • Away
  • Moderator
  • Moderator
  • Posts: 703
  • Karma: 14
  • Thank you received: 168

jonkjon wrote: We have a winner!!! It is working now! THANK YOU!!

--Jon


Great, thank you for your assistance, Peter

Please Log in or Create an account to join the conversation.

INDI Server for Windows 2 years 2 months ago #10231

I've had some time to play around with this the past couple of days and am seeing a few issues.

1. When connecting to the telescope simulator from EKOS, the site longitude gives an error "Property SiteLongitude The property value is out of range " the actual site longitude is -77:32:42 but EKOS uses 282:33:52. I can manually set the longitude in the control panel however. Even after manual correction, the scope crosshairs never move in kStars.

2. The scope simulator never moves when trying to track an object in kStars. i.e. Right click on target and select track and nothing happens.

--Jon

Please Log in or Create an account to join the conversation.

Time to create page: 0.316 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica