Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...

TOPIC: Astroberry Server

Astroberry Server 5 months 1 week ago #26318

Hi Kaczorek,
what do u thinking about update astroberry to indi library 1.7.0 ?

Adn if possible how make itTanks
Pasquito

Please Log in or Create an account to join the conversation.

Astroberry Server - Headless Mode? Kstars/Ekos/INDI autostart 5 months 1 week ago #26320

  • apos
  • apos's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 2
[SOLVED] Use Indi-Web-Manager ;-)

... but there are some problems with the service ... read the thread.


Hi there, hi Kaczorek,

I am wandering and didn't find anything about:
  1. Running astroberry "headless" - only start the indiserver with the given Ekos configuration
  2. In the gui -> Autostart KStars (no problem), but then autostart Ekos after KStars and Indi with a default profile

Cheers
Axel

P.S.: I am doing my first workshop for others about KStars and the astroberry-PI ;-) Thanks for your great work Kaczorek.

Please Log in or Create an account to join the conversation.

Last Edit: by apos.

Astroberry Server 2 months 4 weeks ago #28701

Kaczorek wrote: Due to increasing security constraints in majority of browsers this issue will persist. To address This ssl will be disabled by default in the new version. I would recommend using a VNC viewer to access Astroberry Server if you have problems with accessing it with a browser.


Firefox seemed to allow successful access to the site after adding an exception for the certificate error. I have my own private Certificate Authority and was able to generate a new certificate that works fine in all browsers. I believe the issue with your certificate is that the CA cert and Web Server cert share the exact same Common Name. This causes the Subject and Issuer fields of the Web Server cert to be the same which should only occur with self-signed root certificates (the CA cert). When a browser sees this, it tries to verify that the digital signature coincides with the Issuer's public key; in this case, it checks against the Web Server's public key instead of the CA's public key, causing it to fail.

I believe that simply adding something like an OU to the Common Name of the Web Server cert will fix this (requires generating new certificate of course).


P.S.
@admins: Speaking of certificates, where is the one for indilib.org???


Attachments:

Please Log in or Create an account to join the conversation.

Astroberry Server 2 months 3 weeks ago #28888

> Mr. Catchlek

I installed astoroberry on RaspberryPi 3 as OSX KSTARS remote connection (home), wireless remote (outdoor) use of VNC on iPad.

Very easy to use, it was a wonderful composition, but there were some problems below.

1. When connecting to OSX remotely, you can not connect to CCDciel of OSX.
(Astroberry.local 7624)
It was not possible to connect even if changing to wireless, wired, astroberry.local → 192.168.10.1.

2. The clock function is not working.
(This was solved by installing ntpdate.)

sudo apt install ntpdate
sudo service ntp stop
sudo ntpdate xxxxxx (ntp server)
sudo service ntp start

3. You can not use wlanconf-gui.
I am using the terminal wlanconf command.

The usage environment is
· Mac OSX 10.2.6
Application used
Kstars, CCDciel
Connect the above application to the INDI Web Manager. (CCDciel can not be connected)

· Raspberry P3
Install astroberry

Please Log in or Create an account to join the conversation.

Astroberry Server 2 months 1 day ago #29490

Thanks kakzorek for the astroberry project, it fullfill my needs.
I tried it just a few days but I find all goods.

Just Planetary Imager do not work with my ASi 174 camera, it seem to not recognize the camera.
I saw that is a 0.7 version but is not possible to download anymore from developer web site

I will try more to solve the problem
Anyone knows something about that?

There is plan to an updated astroberry release?

Cheers
Fabio

Please Log in or Create an account to join the conversation.

Astroberry Server 2 months 1 day ago #29507

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 462
  • Karma: 6
  • Thank you received: 181
Planetary Imager distributed with Astroberry Server has been compiled from source. At the time the latest Astroberry Server was released there were no binary versions available. Why don't you use oaCapture? It supports ASI cameras natively.

I'm planning to release the new version based on the latest Ubuntu Mate 18.04... however it's still not available for Raspberry Pi. It was supposed to be released in July... and I'm still waiting for Mate dev team. The new version will include major bug fixes and improvements as well as support form Raspberry 3B+
The following user(s) said Thank You: Ibirru11, martingo

Please Log in or Create an account to join the conversation.

Astroberry Server 2 months 18 hours ago #29524

Thanks
I will use oaCapture, it was only to give a chance to Planetary Imager.
There are so few capture software for Linux platform ...

I tried to compile myself (using Rpi 3 astroberry server) but without success.

You think is a good idea to apt-upgrade the system?

How about qdslrDashboard to manage all dslr camera? Do you think the Raspian Strech precompiled could run on ubuntu mate?


Just a last question about zram: I saw that you do not use zram-config package in Astroberry. How is it possible to change the amount of zram in Astroberry?
Cheers, Fabio

Please Log in or Create an account to join the conversation.

Last Edit: by Ibirru11. Reason: I forgot a last question

Astroberry Server 1 month 2 days ago #30263

Greetings and salutations, gang. Quick question because my forehead hurts from banging it against the wall trying to make this work...

I am attempting to connect my Raspberry Pi 3 to a Celestron Evolution 8 via astroberry. This new model does not have a working USB interface, and the comments I've seen say only WiFi is supported at this point anyway. So, I've tried two methods.

1. Edit wpa_supplicant.conf to connect to "Celestron-FE" (the SSID that the Celestron sets up) and then attempt a connection via Ekos and ip=1.2.3.4 (the default IP that Celestron's SkyQLink app recommends and which the indi-nexstarevo server creates) and port=2000 (again, default). This never connects. It's worth noting that wlan0 is assigned an IP of 1.2.3.5 by default when connecting to "Celestron-FE", not 1.2.3.4. I've changed it manually to 1.2.3.4 with no success.
2. Put the Celestron in "access mode" and have it connect to the astroberry SSID. I do this by going into the SkyQLink app on Windows and writing the following settings to the Celestron:
-- ssid = astroberry
-- password = astroberry
-- ip = 192.168.10.10 (arbitrary but static)
-- gateway = 192.168.10.255
-- netmask = 255.255.255.0
I can ping the Celestron from astroberry when done this way, so it appears to connect. However, when I go into Ekos and attempt a connection via ip=192.168.10.10 and port=2000, I still get no connection (a timeout occurs).

Has anyone got this to work? I've tried other port numbers. I've tried disabling the firewall entirely. I've rebooted all systems in order. I've ensured that the hand controller is "aligned" via a fake alignment on the sun (inside). I'm out of ideas here.

Please Log in or Create an account to join the conversation.

Astroberry Server 1 month 2 days ago #30319

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 462
  • Karma: 6
  • Thank you received: 181
I do not have any knowledge of Celestron Evolution 8 whatsoever so maybe somebody who uses it can help... BUT
First, 192.168.10.10 is a static IP assigned to astroberry access point so you CANNOT use it on any other device connecting to astroberry access point. Use for example 192.168.10.11 or anything within 192.168.10.x network.
Second, gateway = 192.168.10.255 is wrong for sure. The gateway for your mount is astroberry so you should use gateway = 192.168.10.10 instead. However it only applies to accessing the INternet from your mount through astroberry access point. If you don't need to access the Internet from your mount it does not make any difference. Anyway gateway = 192.168.10.255 is not what you can use because 192.168.10.255 is reserved as broadcast address for entire 192.168.10.x network. It comes from IP network specification not astroberry itself (it's the IP networking rule).
Try this out and let us know how it works. Good luck!

Please Log in or Create an account to join the conversation.

Astroberry Server 1 month 2 days ago #30323

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 462
  • Karma: 6
  • Thank you received: 181
Anybody using Astroberry Server. I have promised an update to the distro some time ago. Long time ago actually... My assumption was to release the new version based on Ubuntu Mate 18.04 instead Ubuntu Mate 16.04. The reason being Ubuntu Mates 16.04 is going to loose it's support in March 2019.
Unfortunately Ubuntu Mate team has not released the version 18.04 yet - even though it was planned to be released in July 2018. This holds me from the major update. I do not want to use a custom build of Ubuntu Mate 18.04 for compatibility issues which might arise when the official 18.04 release is available. I hope you all can wait a bit longer to get the new version of Astroberry Server. Especially that the new version will be based on LTS (long term support) distro, which will be supported until 2021. I can assure it will be released as soon as official distro from Ubuntu Mate is available. In the meantime take a look how an imaging session looks like with the current version of Astroberry Server (1.0.4).

The following user(s) said Thank You: lattosimbaste, jerry, Ibirru11

Please Log in or Create an account to join the conversation.

Last Edit: by Kaczorek.

Astroberry Server 2 weeks 2 days ago #30959

Kaczorek wrote:

HelgeMK wrote: Still not clear to me how I can access my network "wirelessly" (Ethernet works fine). I set up the wifi connection under the menu "network connection", but then how can I access/activate? When I click on the https://atozsofts.com/blog/funny-wifi-names/Wifi network icon at the panel, the option wlan-configuration comes up, I enter the password, then supposed to type the network name - but cannot activate the field, can only enter the password.


That's a great news that astroberry piface driver works well with Piface Digital 2!
Regarding wireless connection to Astroberry Server. As stated in the readme file Astroberry Server is also a Virtual Access Point (VAP) allowing to access the system without external wireless network. This means that Astroberry Server creates new wireless network (access point / hot spot) which you can connect to with your PC or mobile device. Just search for a wireless network named "astroberry" on your PC. Connect to it and then open your browser and go to astroberry.local or 192.168.10.1.
What wlan configuration does is connecting your Astroberry Server to your home wireless network so you can access the Internet from the raspberry (for updates, online astrometry etc.). It scans for available wireless networks so you can select your home network you want to connect to. If there's no networks on the list and you are sure that the list shouldn't be empty you can configure your home network connection from terminal by running "sudo wlanconf".


thank you this work for me.

Please Log in or Create an account to join the conversation.

Astroberry Server 1 week 2 days ago #31245

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 462
  • Karma: 6
  • Thank you received: 181
Astroberry Server version 1.1.0 is now available! Raspberry Pi 3B+ support and many updates in a single file!

Visit the project page to download the system image or download the image file directly



Additions and updates:
- NEW Raspberry Pi 3 B+ support added
- Operating System updated
- Welcome page updated to allow for encrypted and unencrypted connection
- INDI Webmanager updated and new icon added to sliding panel
- Planetary Imager updated
- CCDciel software added
- HNSKY software added
- Lin-guider software added
- SER Player software added
- Astroberry DIY drivers added
- Operating System tweaks applied
- Nginx configuration improved[/li]

Fixes:
- Connection not private bug fixed
- Sliding panel not loading bug fixed
- System boot partition too small bug fixed

NOTE: You need to reflash your microSD card to upgrade the system. To preserve your configuration backup your /home/astroberry directory before upgrading the system
Attachments:
The following user(s) said Thank You: knro, HelgeMK, TomAstro, jerry, Ibirru11

Please Log in or Create an account to join the conversation.

Last Edit: by Kaczorek.
Time to create page: 0.352 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica