Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...
  • Page:
  • 1
  • 2

TOPIC: INDI and kstars running on Asus Tinker Board

INDI and kstars running on Asus Tinker Board 1 year 2 months ago #17998

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 77
  • Thank you received: 13
ok, Ill go through my process:

1. The first thing i tried was your image NAFABox.img. That all worked ok except for BT and I still cant get BT to work.

2. I then flashed the ELARSystem image, downloaded the NAFA confi zip from git and installed it via ./go/sh went through the whole install process fine. I could VNC to the tinkerboard. After a restart, the VNC would not work, so i tried to reconfigure it with the desktop scripts that were create and the scripts would not run, see images below. Doing this on the NAFABox install (point 1 above) the scripts ran ok and I could reconfigure my hotspot. Other than the hotspot issue with this install method, everything else worked, i could connect to the mount and joystick via BT, my CCD worked etc.

3. In both installations what it did notice was that when my mount connected, it would automatically start to slew at about 64X slew rate, so i had to manually Abort the process. Could not work out why.

Anyways, thank you all for your help.

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Baader modified Canon 550D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt BT Moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

INDI and kstars running on Asus Tinker Board 1 year 2 months ago #17999

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 77
  • Thank you received: 13
Hi Sebriviere, only BT did not work for me on the NAFABox.img and i still have not resolved this.

To change the language, i looked at my rpi3 ubuntu mate install to help me navigate through the French version on NAFABox. I noticed that English was installed on the NAFABox image. So i did this and was able to change the language. Again, all manually.

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Baader modified Canon 550D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt BT Moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

INDI and kstars running on Asus Tinker Board 1 year 2 months ago #18001

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 77
  • Thank you received: 13
Hi kecsap,
Ill check this as soon as i can and post the output of lsusb.

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Baader modified Canon 550D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt BT Moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

INDI and kstars running on Asus Tinker Board 1 year 2 months ago #18002

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 77
  • Thank you received: 13
Hi all, i will try this method over the weekend, refer to steps 3 and 8:

ubuntu-mate.community/t/mate-samba-wifi-...ver-altogether/10244

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Baader modified Canon 550D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt BT Moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

INDI and kstars running on Asus Tinker Board 1 year 2 months ago #18003

  • patdut
  • patdut's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 311
  • Karma: 1
  • Thank you received: 37
Hello Petarm
Thanks to your efforts. I guess the install issues come essentially from 2 sources: first, language which condition some install options; second, the original image Armbian or ELAR that might not have the same kernel nor same initial Desktop. I will try in next days to install a full english version using ELAR and Armbian image. Might be the reason of the BT dysfunctionning too. I am now testing the last compiled Armbian version which use the 4.12 kernel. I hope BT will work. If all looks good this could be in the next image. I plan to build 2 images one in french the other in english.
The following user(s) said Thank You: petarm

Please Log in or Create an account to join the conversation.

INDI and kstars running on Asus Tinker Board 1 year 2 months ago #18004

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 77
  • Thank you received: 13
His patdut.

So I tried all those things in my posted with no luck. I'll wait for your new image and try again. Its very cold here and clear. Perfect for imaging. Have a good weekend.

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Baader modified Canon 550D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt BT Moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

INDI and kstars running on Asus Tinker Board 1 year 2 months ago #18006

Thanks Petarm for your tenacity.
You're lucky with cold clear skies, french brittany is stormy right now.
hopefully means clouds will clear faster.

Please Log in or Create an account to join the conversation.

INDI and kstars running on Asus Tinker Board 1 year 2 months ago #18079

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 77
  • Thank you received: 13
hi patdut,
i noticed that some changes have been pushed to NAFABox to GIT. Should i try again?
regards

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Baader modified Canon 550D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt BT Moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

INDI and kstars running on Asus Tinker Board 1 year 2 months ago #18080

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 77
  • Thank you received: 13
No worries, unfortunately for my sanity, i dont give up.
So the next thing i tried was creating a staticIP to try to RDP to it (which is how i view my desktop on my rpi3). Again no luck.
My laptop could see the hotspot and connect to it, but i could not RDP to the tinker board (even though i went through the exact same process to create the static IP on my rpi3, which runs ubuntu mate 16.04).
regards

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Baader modified Canon 550D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt BT Moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

SOLVED: INDI and kstars running on Asus Tinker Board 1 year 2 months ago #18083

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 77
  • Thank you received: 13
Hi all, thanks for your help. So i finally cracked the bugger. So this is the process I went through.

1. Download the ELARSystem image and install it as usual.
2. From GIT download NAFAbox and go through the process of installing all the astro software and the wifi hot spot.
3. The issue i was having all along was that x11vnc was not booting on startup. So to fix this i did the following:
open a terminal:
sudo x11vnc -storepasswd <<enter your new passowrd>> /etc/x11vnc.pass

Create a Service Unit file for x11vnc by creating the following file:

sudo nano /lib/systemd/system/x11vnc.service

and add the following to the new file and save and exit

[Unit]
Description=Start x11vnc at startup.
After=multi-user.target
[Service]
Type=simple
ExecStart=/usr/bin/x11vnc -auth guess -forever -loop -noxdamage -repeat -rfbauth /etc/x11vnc.pass -rfbport 5900 -shared
[Install]
WantedBy=multi-user.target


Start the new service via Terminal

sudo systemctl enable x11vnc.service
sudo systemctl daemon-reload

Then restart the tinkerboard and you should be able to VNC into the tinkerbox.

regards

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Baader modified Canon 550D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt BT Moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

INDI and kstars running on Asus Tinker Board 1 year 2 months ago #18085

  • patdut
  • patdut's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 311
  • Karma: 1
  • Thank you received: 37
Hello petarm,
Yes I have updated the scripts in the github.Glad to know that you succeed installing all the app with them upon an ELAR system image.
I have done it two days ago but I give up with it because I can't change easily the owner name and home by script to customize it as f NAFABox. But if you don't mind about customizing user the scripts work too.
For the x11vnc, I choose to put a start script in the .config/autostart folder. I guess that for some reason the home structure differ lightly from xfce and lxde desktops and maybe that can be an explanation. At first I had created a service to run x11vnc at boot but get back to a simplest and more controllable solution.
There is a new image available. There is now a shortcut on the desktop that help to change language from English to French.
Regards

Please Log in or Create an account to join the conversation.

Last Edit: by patdut.

INDI and kstars running on Asus Tinker Board 5 months 1 week ago #25931

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 77
  • Thank you received: 13
Hi Patrick, how are you going? I have a quick question about bluetooth on the Asus tinkerboard.

I have been using a BT moonlite focuser and BT EQMOD adatper on my tinkerboard and now all of a sudden i cannot connect or see any bluetooth devices. Bluetooth seems to be working on the tinkerboard, but i cant see or bind too any external bluetooth devices. Are you having a similar issue?

I have abandoned bluetooth now completely as it is so unreliable. USB cable connection is far better. I'm just curious if you have come across a similar issue.

I noticed this occurred about 2 weeks ago after i did a sudo apt-get update and upgrade to the tinkerboard OS (my install is exactly as yours on GIT). I even reinstalled everything as per GIT, but no bluetooth again.

regards

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Baader modified Canon 550D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt BT Moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )
  • Page:
  • 1
  • 2
Time to create page: 0.244 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica