KSTARS setting to wrong time after GPSD update

  • Posts: 22
  • Thank you received: 1

KSTARS setting to wrong time after GPSD update was created by SparkyHT

Well after a Sunday afternoon of research and testing, I found a way to set the system time on my OFFLINE RPI3 with GPSD at boot using CHRONY. It's reliable and sets the system time within a minute and a half of the OS loading. After launching KSTARS and going to EKOS and connecting to my equipment, I go to the GPSD tab to SYNC the device (i.e. my AP driver) to the current location and time by clicking "Update". On the EKOS side of things the UTC time and GPS location is correct, my AP mount sets to the proper time and the UTC offset is set to -5 which is correct for my area as we are still in DST for one more week. Here's the problem: KSTARS goes from the time set by the system and in EKOS set by the GPS, to one hour ahead! The geographic information in KSTARS is set to my city, the UTC offset is -6, and the DST rules are set for US. KSTARS is changing the time as though I am not observing DST, regardless of the geographic settings. I have a screenshot below of what I'm seeeing. Is this a bug?

1 year 1 month ago #20532
Attachments:

Please Log in or Create an account to join the conversation.

Replied by knro on topic KSTARS setting to wrong time after GPSD update

Oh it seems we both arrived to the same conclusion! I removed NTP and replaced it with Chrony and also got reliable results! For someone new to Linux, you have great skills for this I must say! The KStars problem I believe are fixed in the current GIT version, we will release a KStars version hopefully later today or tomorrow, just we have last-minute fixes for MacOS. Thank you for your great work and patience.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: SparkyHT
1 year 1 month ago #20537

Please Log in or Create an account to join the conversation.

Time to create page: 0.230 seconds