Connecting to QHY5-II on indi failed

Replied by knro on topic Connecting to QHY5-II on indi failed

I don't believe the QHY5-II is supported by the INDI driver. There has been many discussion on QHY support in INDI before if you search the forum, currently no one is working on that unless someone steps in. Also, QHY needs to really work on a creating a proper API for the CCDs, not the hackfest that is currently going on.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
4 years 7 months ago #1427

Please Log in or Create an account to join the conversation.

  • Posts: 170
  • Karma: 4
  • Thank you received: 39

Replied by lupinix on topic Connecting to QHY5-II on indi failed

There is an unofficial driver for QHY5-II, but I don't know if it works well. bitbucket.org/peppertarts/indi-qhy5ii
4 years 7 months ago #1430

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1

Replied by Soncebos on topic Connecting to QHY5-II on indi failed

Sad to hear the qhy_ccd is not supporting the alccd5L-II camera.
Maybe there will be a official driver later on.
I will try the unofficial driver and report here.
Wish me luck
CS Jens
4 years 7 months ago #1431

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1

Replied by Soncebos on topic Connecting to QHY5-II on indi failed

I did try co compile the unofficial driver mentioned by lupinix.
No luck with that. Packet "lfxload" is not known an i get errors that
libindi is not found. I will try to contact the author.
If that is not working I am stuck. Either have to wait for an official driver,
take another guiding cam or use lin_guider beside of indiserver on
my RPI.
CS Jens
4 years 7 months ago #1435

Please Log in or Create an account to join the conversation.

Replied by knro on topic Connecting to QHY5-II on indi failed

There is no lfxload package, it's a typo. I just compiled it fine, try this:
sudo apt-get install -y libindi-dev fxload libcfitsio3-dev libopencv-dev libnova-dev
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
4 years 7 months ago #1437

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1

Replied by Soncebos on topic Connecting to QHY5-II on indi failed

Yes you are right.
I left the library out and was able to compile the driver on the RPI.
First the camera did not respond. I did notice the red light at the back of the
camera was off. But with a qhy_ccd_test it came on. No idea why that is.
Then i could connect through EKOS with indiserver indi_qhy5ii_ccd.
I can capture and transfer pictures but that is still rather slow.
It will take about 15 sec. to take and transfer 1 picture. That should be to
slow for autoguiding.
Maybe the driver supports ROI somehow to reduce the traffic.
CS Jens
Last edit: 4 years 7 months ago by Soncebos. Reason: spelling
4 years 7 months ago #1438

Please Log in or Create an account to join the conversation.

  • Posts: 1448
  • Karma: 5
  • Thank you received: 117

Replied by Gonzothegreat on topic Connecting to QHY5-II on indi failed

I had the QHY5L-II, couldn't get it to work under Linux correctly, and there is no INDI driver for it. Ended up selling it.
Kstars Mac osx
Odroid C1 running indiserver (kept up-to-date with apt-get update/upgrade)
HEQ5 pro / QHY5 / Atik 314L+
4 years 7 months ago #1449

Please Log in or Create an account to join the conversation.

Replied by knro on topic Connecting to QHY5-II on indi failed

Gonzothegreat wrote: I had the QHY5L-II, couldn't get it to work under Linux correctly, and there is no INDI driver for it. Ended up selling it.


I think other QHY Linux users should follow suit. That should send a message to QHY.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
4 years 7 months ago #1452

Please Log in or Create an account to join the conversation.

  • Posts: 1448
  • Karma: 5
  • Thank you received: 117

Replied by Gonzothegreat on topic Connecting to QHY5-II on indi failed

Don't get me wrong, this little camera is great under Windows. Pictures are good if you use darks.
I do know there is some sort of alpha driver for it for Linux, tried it but too many bugs for my liking to be able to use it everyday.

I'm going for an Atik 314L+
Kstars Mac osx
Odroid C1 running indiserver (kept up-to-date with apt-get update/upgrade)
HEQ5 pro / QHY5 / Atik 314L+
4 years 7 months ago #1455

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1

Replied by Soncebos on topic Connecting to QHY5-II on indi failed

Hello Folks,
I am off for holidays in Kroatia for two weeks now.
Right after that with a cloudless night I will try the whole setup
Including the driver for my QHY5L-II- c.
If somebody is interested in the results I will report here.
CS Jens
4 years 7 months ago #1456

Please Log in or Create an account to join the conversation.

  • Posts: 170
  • Karma: 4
  • Thank you received: 39

Replied by lupinix on topic Connecting to QHY5-II on indi failed

Soncebos wrote: Yes you are right.
I left the library out and was able to compile the driver on the RPI.
First the camera did not respond. I did notice the red light at the back of the
camera was off. But with a qhy_ccd_test it came on. No idea why that is.

Then the firmware is not loaded… Maybe an issue with the udev rules?

Soncebos wrote: Then i could connect through EKOS with indiserver indi_qhy5ii_ccd.
I can capture and transfer pictures but that is still rather slow.
It will take about 15 sec. to take and transfer 1 picture. That should be to
slow for autoguiding.
Maybe the driver supports ROI somehow to reduce the traffic.

RPi can be tricky… We have two QHY5-based CCDs (not QHY5-II), both work fine on "normal" computers, but one doesn't work with RPi… (produces difficult pictures) They only differ in the USB PID. I'm looking for a more powerful alternative now, maybe Banana Pi or Cubietruck (need Gbit LAN because we control our stuff entirely over LAN from the office), I hope the second QHY5 works then too :D

Christian
Last edit: 4 years 7 months ago by lupinix. Reason: Fixed typo
4 years 7 months ago #1458

Please Log in or Create an account to join the conversation.

  • Posts: 710
  • Karma: 14
  • Thank you received: 173

Replied by polakovic on topic Connecting to QHY5-II on indi failed

I suspect, that qhy_ccd_test is the executable from our "official" INDI driver. It doesn't support QHY5-II but will detect it and will upload the firmware.

The "unofficial" driver for QHY5-II doesn't upload the firmware, it uses udev rules and fxload instead. I can't test it but it should work. If it doesn't something is wrong with 85-qhyccd.rules file, maybe some conflict with our 99-qhyccd.rules.

Peter
Last edit: 4 years 7 months ago by polakovic.
4 years 7 months ago #1460

Please Log in or Create an account to join the conversation.

Time to create page: 0.784 seconds