Welcome, Guest
Username: Password: Remember me
14 Nov 2018
Glad to announce of release of INDI Library v1.7.5 on 2018-11-14. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...
  • Page:
  • 1

TOPIC: bug(s) in KStars HIPS overlay

bug(s) in KStars HIPS overlay 1 week 1 day ago #32286

I realize this is an INDI forum, and I'm posting about KStars. Please refer me someplace else if appropriate.

The HIPS all-sky imagery overlay is a wonderful feature for framing targets. I've been experimenting with allocation of disk and memory for this feature, and find a repeatable bug.

Under View->HIPS All Sky Overlay -> HIPS Settings -> Cache, when I select other values than the default (Disk=1000, Memory=300) the HIPS display is corrupted. I can still see the image overlay but it's "smeared out" into horizontal banding that looks a lot like old-fashioned electronic static.

When I reset using the "Restore Defaults" button and restart KStars, everything goes back to normal.

This is on an Intel i3 box with 8 GB RAM running ubuntu 18.04.

Screenshots attached below to illustrate the problem.

Thanks!
Scott

Please Log in or Create an account to join the conversation.

Last Edit: by airscott.

bug(s) in KStars HIPS overlay 1 week 1 day ago #32298

If you zoom in and out and pan around a little when you observe the artifacts, do they go away as the HIPS overlay downloads/loads new files?

Please Log in or Create an account to join the conversation.

bug(s) in KStars HIPS overlay 1 week 1 day ago #32300

Once the HIPS overlay becomes corrupted, it stays messed up, even after restarting KStars, no matter how much I scroll and zoom. The only cure seems to be going into the cache options and restoring the default Disk=1000 memory=300, then retsarting KStars.

Oddly, I just tried it on my MacBook pro (16 GB RAM) and I get lovely high-res renders with higher cache settings. No sign of the corruption I see in ubuntu.

I'm fine with just leaving the cache alone, but it does look like a real bug.

Please Log in or Create an account to join the conversation.

bug(s) in KStars HIPS overlay 1 week 20 hours ago #32304

Ok then I don't know. I mainly use the Mac version so that's why I don't see the problem.

Please Log in or Create an account to join the conversation.

bug(s) in KStars HIPS overlay 1 week 13 hours ago #32314

I've seen similar corruptions regularly, too. They vary when you zoom in and out. I do not remember whether I had changed the cache settings at some point.
At the moment it seems to work, but i had reset my configuration due to a file corruption.
I'll check if I can reproduce that errors when changing cache size.
Does the cache algorithm somehow include cache size in locating where the cached data is? A 'flush HiPS cache' button might be nice.

Please Log in or Create an account to join the conversation.

openSUSE Tumbleweed KStars 3.0.0git INDI 1.7.5git
GPDX+SynScan, ASI1600+EFW+ASI290 mini
  • Page:
  • 1
Time to create page: 0.805 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica