×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Celestron Motorised Focuser - Is it supported in EKOS yet

  • Posts: 554
  • Thank you received: 138
I've posted new code that seems to handle the focuser correctly with the StarSense HC.
The following user(s) said Thank You: Casey Finn
3 years 7 months ago #37446

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 5
Have you/anyone been able to completely control the focuser yet? I just got one and am trying to get it working. I got to step 7 last night and it seems to have quit responding to commands/calibration. I read in this thread to use the windows software to determine the min and max then stellarmate will read that info and update itself. Is that a working option? Also, are you able to power the focuser through the usb cable of the stellarmate/pi device? Thanks

EDIT

After running the calibration software from Celestron and connecting the correct power supply I got the following message when indi booted up:
2019-04-09T00:21:20: [INFO] Device configuration applied.
2019-04-09T00:21:20: [INFO] Loading device configuration...
2019-04-09T00:21:20: [INFO] Celestron SCT focuser paramaters updated, focuser ready for use.
2019-04-09T00:21:20: [INFO] Focus Limits: Maximum (30518) Minimum (1606) steps.
2019-04-09T00:21:20: [INFO] Celestron SCT is online.
2019-04-09T00:21:20: [INFO] Celestron SCT Focuser is online. Getting focus parameters...
2019-04-09T00:21:20: [INFO] Firmware Version 7.15.8240

Focus control works just fine inside Ekos-Kstars. Much louder than a Pegasus but feels solid as a rock
Takahashi Fc100 & 8" RASA
MyT
Asi294MC & Asi183MC
Borg 50mm + Asi224
Pegasus FocusCube & Celestron Focuser
Stellarmate
Kstars, Ekos, TSX & Pixinsight
One VERY patient wife of 20 years now!
Last edit: 3 years 7 months ago by Casey Finn. Reason: Solved
3 years 7 months ago #37499

Please Log in or Create an account to join the conversation.

  • Posts: 554
  • Thank you received: 138
Good to hear that you got it working.
I've been powering a focuser through the USB port but on a hub, not directly from a Pi but using USB only may be a bit marginal and using a separate 12V supply may help.

An alternative, if you have a Celestron mount, is to connect the Aux cable and power it from the mount, using the Celestron GPS telescope driver to control the focuser.
3 years 7 months ago #37509

Please Log in or Create an account to join the conversation.

  • Posts: 835
  • Thank you received: 96
Thinking of getting a Celestron RASA 11, but am concerned that EKOS is not quite ready for the Celestron Electronic focuser.
How is the development coming along on this?

Thanks!!

Peter

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD and William Optics Star71
ASI 1600MM Pro, ASI 462MC
Moonlight Litecrawler (C11) and Motorfocus (WOStar71)
LodeStar X2 and ZWO OAG
Nextdome, AAG Cloudwatcher
MacMini
3 years 7 months ago #38524

Please Log in or Create an account to join the conversation.

  • Posts: 30
  • Thank you received: 1
Peter,

thats incorrect. EKOS can perfectly hande the new Celestron focuser, either via the Celestron_GPS or better with the stand-alone driver indi_celestron_sct_focus.

Stefan
Current gear:
- AVX
- E8HD + ASI294MC
- Celestron 150x30 + ASI224 for guiding
- Celestron Focuser for harp stars

SW:
- Linux NUC + Ubuntu + INDI nightly on the server
- Linux Ubuntu + KSTARS nightly on the client (via CAT5 wire)
3 years 7 months ago #38537

Please Log in or Create an account to join the conversation.

  • Posts: 835
  • Thank you received: 96
Fantastic! Thank's for setting me straight!

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD and William Optics Star71
ASI 1600MM Pro, ASI 462MC
Moonlight Litecrawler (C11) and Motorfocus (WOStar71)
LodeStar X2 and ZWO OAG
Nextdome, AAG Cloudwatcher
MacMini
3 years 7 months ago #38540

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 1
Hey Jasem,
Just wondering where you got to with this? I am looking into buying a focuser for my Edge HD1100 and the Celestron one mentioned here seems like a good fit, but only if I can get it to work with StellarMate. This would be on my CEM120 mount, so the control for the focuser would be going to the Stellarmate directly rather than through the mount (in the same manner mentioned by Scanner001).

thanks
3 years 6 months ago #39357

Please Log in or Create an account to join the conversation.

You can use it as a standalone focuser so that would work.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
3 years 6 months ago #39359

Please Log in or Create an account to join the conversation.

  • Posts: 28
  • Thank you received: 1
Anybody else having issues getting this to run properly through the HC? When I try to use the focuser via Celestron GPS, it doesn't seem to be reporting its position - it stays at 0. Of course, auto focusing doesn't work at all that way. Using a direct USB connection together with the Celestron SCT driver, everything works as expect. I would prefer just having one cable run to the mount though...

Here's what the log says:
[2019-08-03T12:03:52.002 CEST DEBG ][     org.kde.kstars.ekos.focus] - Setting focus ticks to  24300
[2019-08-03T12:03:52.005 CEST INFO ][           org.kde.kstars.indi] - Celestron GPS :  "[INFO] Focus direct move 24300 "
[2019-08-03T12:03:52.006 CEST DEBG ][           org.kde.kstars.indi] - Celestron GPS : "[DEBUG] Focus move 24300 "
[2019-08-03T12:03:52.006 CEST DEBG ][           org.kde.kstars.indi] - Celestron GPS : "[DEBUG] CMD <50 04 12 02 00 5E EC 00> "
[2019-08-03T12:03:52.034 CEST DEBG ][           org.kde.kstars.indi] - Celestron GPS : "[DEBUG] RES <23> "
[2019-08-03T12:03:52.035 CEST INFO ][           org.kde.kstars.indi] - Celestron GPS :  "[INFO] Focuser is moving to position 24300 "
[2019-08-03T12:03:52.614 CEST DEBG ][           org.kde.kstars.indi] - Celestron GPS : "[DEBUG] CMD <e> "
[2019-08-03T12:03:52.706 CEST DEBG ][           org.kde.kstars.indi] - Celestron GPS : "[DEBUG] RES <80000000,00000000#> "
[2019-08-03T12:03:53.688 CEST DEBG ][           org.kde.kstars.indi] - Celestron GPS : "[DEBUG] CMD <e> "
[2019-08-03T12:03:53.749 CEST DEBG ][           org.kde.kstars.indi] - Celestron GPS : "[DEBUG] RES <80000000,00000000#> "
[2019-08-03T12:03:54.750 CEST DEBG ][           org.kde.kstars.indi] - Celestron GPS : "[DEBUG] CMD <e> "
[2019-08-03T12:03:54.812 CEST DEBG ][           org.kde.kstars.indi] - Celestron GPS : "[DEBUG] RES <80000000,00000000#> "

Shouldn't there also be a command requesting the focuser's position?
3 years 4 months ago #41617

Please Log in or Create an account to join the conversation.

  • Posts: 28
  • Thank you received: 1
Okay, problem identified. When Celestron GPS starts up with my Evolution mount, it says "WARNING: Mount firmware does not support getting pier side". However, the Celestron GPS driver exits ReadScopeStatus when it doesn't have a pier side (line 781) - and that's happening before requesting the focuser position.

I'll set up a PR for a fix.
3 years 4 months ago #41618

Please Log in or Create an account to join the conversation.

  • Posts: 554
  • Thank you received: 138
I need the full log, not a fragment lasting a couple of seconds.

The Celestron focuser needs to be calibrated, this can be done using the standalone INDI focuser driver.

Read your second message, see what you mean. Are you going to fix it?
Last edit: 3 years 4 months ago by Chris Rowland.
3 years 4 months ago #41620

Please Log in or Create an account to join the conversation.

  • Posts: 28
  • Thank you received: 1
Already done. I've added you to the PR.
The following user(s) said Thank You: Jasem Mutlaq
3 years 4 months ago #41621

Please Log in or Create an account to join the conversation.

Time to create page: 1.408 seconds