Kstars/Ekos for Windows PC connection issues

  • Posts: 8
  • Thank you received: 0

Kstars/Ekos for Windows PC connection issues was created by lemmu

I*m having Stellarmate running on PI. Connected via Ethernet to my PC. Viewing with TighVNC Viewer. Works fine. Installed Ekos to my Win 7 PC, I can't get connected.
Here what I tried.; Profile wizard I choose "attached remote computer" Typing Host's IP address as exactly same as I'm using to connect Stellarmate.
Just won't connect. What I'm doing wrongly? Any ideas? I'd like to run Ekos on my PC as well ...
Thanks for looking,
1 week 6 days ago #34653

Please Log in or Create an account to join the conversation.

  • Posts: 441
  • Karma: 1
  • Thank you received: 69

Replied by Ihoujin on topic Kstars/Ekos for Windows PC connection issues

INDI Drivers must first be running on the Stellarmate. Try using the INDI Web Manager.
www.indilib.org/support/tutorials/162-indi-web-manager.html
INDI/KStars on Raspberry Pi 3B+
Lubuntu 16.04
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG @280mm Guide Scope
PHD2
Adafruit Motor Hat shield
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
1 week 6 days ago #34654

Please Log in or Create an account to join the conversation.

Replied by knro on topic Kstars/Ekos for Windows PC connection issues

Make sure to check "INDI Web Manager" in the profile.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 week 6 days ago #34673

Please Log in or Create an account to join the conversation.

  • Posts: 200
  • Karma: 4
  • Thank you received: 47

Replied by stash on topic Kstars/Ekos for Windows PC connection issues

If you can ping the PI from Win 7 then check Windows 7 firewall isn't blocking the ports being used. Easiest way to check is to switch off Windows Firewall (temp measure of course) and try again.

If you cant ping then the Win 7 machine is not on the same network as the PI.

Plus of course you should make sure the PI is up and running BEFORE connecting the Win7 PC - and by up and running check that the Indiserver if running on rhe PI as suggested above.
RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????
1 week 5 days ago #34687

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0

Replied by lemmu on topic Kstars/Ekos for Windows PC connection issues

Well, INDI server is connected according Web Manager "Server is Online" Still no good. "Failed to start profile on remote INDI Web Manager" What that mean?
1 week 5 days ago #34692

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0

Replied by lemmu on topic Kstars/Ekos for Windows PC connection issues

FLE standardaeg INFO ][ org.kde.kstars.ekos] - "Failed to connect to remote INDI server."
[2019-02-13T19:11:15.258 FLE standardaeg DEBG ][ org.kde.kstars.ekos] - Resetting Ekos Manager...
[2019-02-13T19:11:15.274 FLE standardaeg WARN ][ default] - QSqlDatabasePrivate::removeDatabase: connection 'filter_db' is still in use, all queries will cease to work.
[2019-02-13T19:11:15.286 FLE standardaeg WARN ][ default] - QSqlDatabasePrivate::addDatabase: duplicate connection name 'filter_db', old connection removed.
[2019-02-13T19:12:18.457 FLE standardaeg DEBG ][ org.kde.kstars.ekos] - Resetting Ekos Manager...
[2019-02-13T19:12:18.474 FLE standardaeg WARN ][ default] - QSqlDatabasePrivate::removeDatabase: connection 'filter_db' is still in use, all queries will cease to work.
[2019-02-13T19:12:18.487 FLE standardaeg WARN ][ default] - QSqlDatabasePrivate::addDatabase: duplicate connection name 'filter_db', old connection removed.
[2019-02-13T19:12:18.502 FLE standardaeg INFO ][ org.kde.kstars.ekos] - "Establishing communication with remote INDI Web Manager..."

This is from my log file. I still can't connected from pc to PI .( Via Tight VNC Viewer work everything fine) Yet the PI's web manger stating that server is is online. What it means "old connection" or "filter db"??? Jasem? Anyone?
6 days 18 hours ago #34975

Please Log in or Create an account to join the conversation.

Time to create page: 0.423 seconds