×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Meridian flip issue with the scheduler

8 months 2 weeks ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 430
Karma: 3
More
Meridian flip issue with the scheduler #37071
I have used the stable build since March 7 and have not had that issue. As you may recall, I had an issue with the previous nightly build where the schedule was trying to align after the flip but never took an image. At the time, nobody else had that problem either.
Now, the only issue I have found with the scheduler is that the ‘Save’ button doesn’t work. It truncates the schedule, but one can overcome this by selecting ‘Save As’ everytime changes to the .esl file are made.

I wonder whether these unique and different problems nobody else seems to have are installation related?

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
The following user(s) said Thank You wvreeven

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1114
Karma: 6
More
Topic Author
Meridian flip issue with the scheduler #37075
Yes there definitely seem to be some "local" problems occasionally. I'll try to recreate the INDI xml files and the userdb.sqlite files (basically start from scratch) and see if that helps. If not I'll reinstall the software and drivers and all but I'd like to avoid that if possible.


Clear skies, Wouter

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1114
Karma: 6
More
Topic Author
Meridian flip issue with the scheduler #37076
Jo just told me offline how to reinstall the stable software: add the nightly repo and update all. Then remove the nightly repo again and let apt reinstall the stable software. I am on it as we speak. Thanks Jo!

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
The following user(s) said Thank You El Corazon

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1114
Karma: 6
More
Topic Author
Meridian flip issue with the scheduler #37088
OK, I reinstalled the software as described above and enabled "remember job progress". Now everything is back to normal and the meridian flip on NGC 2420 just went 100% OK. I suspect it was a glitch in the Matrix. Once more thanks for your great advise, Jo!

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
The following user(s) said Thank You El Corazon

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1114
Karma: 6
More
Topic Author
Meridian flip issue with the scheduler #37091
Aaaaand it failed again on the next target. Despite remember job progress having been checked it traced back a few steps (so not completely to the top of the list but nearly) and started there again. Plus it didn’t plate solve after the meridian flip. I’ll inspect the logs tomorrow. Now off to sleep.

For now I will only schedule jobs to start after the target has crossed the meridian. In a way this is better because light pollution is much worse to the east. But is does involve a lot more planning on my behalf :(

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 408
Karma: 5
More
Meridian flip issue with the scheduler #37102
Could you please post the log file of last night and both scheduler file and capture sequence file?

The behaviour should not be dependent whether remember job is set or not. So it seems like you have stepped into a bug. I would like to reproduce it so that I could try to fix it.

Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro + ASI 294mc pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10
The following user(s) said Thank You El Corazon

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago 8 months 2 weeks ago by wvreeven.
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1114
Karma: 6
More
Topic Author
Meridian flip issue with the scheduler #37106
Sure, thanks very much for offering to help, Wolfgang!

EDIT: Sorry, I attached the wrong logs. Please see the log_19-45-21.txt.tgz file for the correct logs of last night. It should contain two meridian flips. One successful for NGC 2420 around 21:00 and then one unsuccessful for NGC 2841 around 22:40.

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
Attachments:

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago 8 months 2 weeks ago by knro.
knro
Administrator
Administrator
Posts: 7421
Karma: 51
Meridian flip issue with the scheduler #37107
I've had a weird issue just now as well. Not using scheduler. But I started a test sequence and the capture said "Meridian Flip" but the mount wasn't flipping. I check in the mount tab and meridian flip was checked, so I unchecked and aborted the sequence. When I restarted the sequence, it's always stuck in "meridian flip" state. I believe when the mount module "Meridian Flip" is unchecked, this should probably reset the meridian flip status in capture module (if it was idle at least). The only way to get rid of the "meridian flip" status is by restarting KStars.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You wvreeven, sterne-jaeger

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1114
Karma: 6
More
Topic Author
Meridian flip issue with the scheduler #37108
OK so I am not the only one. In a way that's a relief since now at least I know it is not me. Let's see if we can find out the cause for this and, at least as important, a fix!


Wouter

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago 8 months 2 weeks ago by El Corazon.
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 430
Karma: 3
More
Meridian flip issue with the scheduler #37110
Yes, there is a number of these idiosyncracies that seem to be specific to one user and not others.

I would be very interested in finding out whether anyone else has noticed the 'Save' issue in the scheduler that I described above. Basically, what happens is that I can set up a sequence in the scheduler and save it 'Save As' just fine. But if I make any changes to it and then just 'Save' (middle button), then the saved .esl file will be truncated after about a dozen lines. It won't show the target anymore, the fields come up blank, all that shows is whether the twilight, asap and altitude boxes are checked, but no target or capture sequence specified. When you now want to reload that schedule, it comes up blank, so all the entries have been lost.
To ascertain that error, you just open the .esl file with a text editor after having executed a 'Save' command.

Intriguingly, I have not experienced all the other problems that have been described with the March 7 stable installation. Especially not those Meridian flip issues Jasem and Wouter are describing. So what I am wondering is whether those are caused by residual installation files from a previous install that have not been entirely purged or been overwritten. Because most of us would not have the same install history, we may all have ended up with a different complement of residual files that now introduce these seemingly random errors.

The programmers have to weigh in whether that is a plausible explanation.

Clear skies, or perhaps we should change that to 'successful Meridian flips'?

Jo

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1114
Karma: 6
More
Topic Author
Meridian flip issue with the scheduler #37113
My next course of action: purge all KStars and INDI config files (well, store them in a safe place first) and recreate them. New profile, new config of KStars, new download of UCAC stars, etc. See if that helps.

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1114
Karma: 6
More
Topic Author
Meridian flip issue with the scheduler #37118
All configuration files were backed up and I created a new profile. I discovered two strange things though:
- In KStars under Data -> download New Data it is shown that all previously downloaded additional data catalogs are installed, including Tycho2 and USNO, but this is not the case. It seems I have overlooked a config file. Can someone tell me where that info is stored?
- When trying to set the Park Position, the EQMod driver crashed. Everytime I started KStars and then Ekos and then INDI, the EQMod driver would crash. It turned out that the ParkData.xml file was corrupt and when I restored the one from the back up, the driver didn't crash anymore.

Moreover, I just (re?) discovered this config setting:



and I don't remember if it was ticked or not. Anyway, I am good to go for tonight and I will report tomorrow if all is back to normal now or not.


Happy meridian flipping!

Wouter

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.356 seconds