×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Pegasus Astro UPB focuser error

1 year 3 months ago
G_Gagnon
Expert Boarder
Expert Boarder
Posts: 104
Karma: 2
More
Topic Author
Pegasus Astro UPB focuser error #37496
I get a "Focuser failed to move to new requested position." error message when issuing a focus command (either in or out) on the Pegasus Astro UPB focuser, even though the focuser moves to a different position. I don't know if the UPB reports a focus position before the focuser gets to the requested position, or if the problem is caused by something else but the log file is attached as a reference.

Any help in solving this issue would be appreciated.

Thanks.
Attachments:

Please Log in or Create an account to join the conversation.

2 months 1 week ago
Lead_weight
Platinum Boarder
Platinum Boarder
Posts: 410
Karma: 4
More
Pegasus Astro UPB focuser error #53008
I started getting this error tonight too, but only in one direction. Did you ever solve this? I'm wondering if the clutch is slipping?

-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/

Please Log in or Create an account to join the conversation.

2 months 1 week ago
knro
Administrator
Administrator
Posts: 8093
Karma: 51
Pegasus Astro UPB focuser error #53013
I think it might be related to extra spaces in the response. I submitted a possible fix, can you test? Wait for nightly packages or if you're using stellarmate, then run this and test:
update_indi_core

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

2 months 1 week ago
Lead_weight
Platinum Boarder
Platinum Boarder
Posts: 410
Karma: 4
More
Pegasus Astro UPB focuser error #53017
Jasem, I am running a Stellarmate using the Dashboard SM Web Manager and imaging from KStars/EKOS on my Mac. Do I need to be running EKOS on the StellarMate to try this, or will it work in my configuration?

-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/

Please Log in or Create an account to join the conversation.

2 months 1 week ago
knro
Administrator
Administrator
Posts: 8093
Karma: 51
Pegasus Astro UPB focuser error #53018
It will work on your configuration, just run update_indi_core on StellarMate and then test on your Mac.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

2 months 1 week ago
Lead_weight
Platinum Boarder
Platinum Boarder
Posts: 410
Karma: 4
More
Pegasus Astro UPB focuser error #53020
Jasem, I'm afraid that the update broke the driver. It starts and crashes, then starts again, and crashes again until it no longer shows up. No devices attached to its USB ports load either. Logs attached. I tried both the Stellarmate KStars and KStars on the Mac remotely.

File Attachment:

File Name: 2020-04-29.zip
File Size:2,721 KB

-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
Attachments:

Please Log in or Create an account to join the conversation.

2 months 1 week ago
knro
Administrator
Administrator
Posts: 8093
Karma: 51
Pegasus Astro UPB focuser error #53022
the logs shows no crashes at all?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

2 months 1 week ago
Lead_weight
Platinum Boarder
Platinum Boarder
Posts: 410
Karma: 4
More
Pegasus Astro UPB focuser error #53023
See if it looks like it's in this file.

Let me carefully describe what happened here.

I ran the update. Rebooted the Stellarmate, and started the INDI web manager. On first try the equipment connected (Mount, Pegasus UPB) Both my Cameras and Mbox did not connect (they are plugged into the USB ports of the UPB). I gave a few commands to move the focuser, but apparently (as seen in another thread) you have to quickly issue focus commands for the error to appear, similar to what is happening during an automatic focus routine.

I noticed my cameras were not connected, so I power cycled the UPB through the INDI control panel and this is where I started seeing the crashes. I rebooted all devices and disconnected from power. Reconnected everything and still see this problem with the driver loading and crashing now.

Eventually I decided to run the updates of Stellarmate. None of the Stellarmate package updaters would run (I was on Stellarmate 1.5.1). So I just now flashed to 1.5.2, and have things up and running again. I will attempt updating the INDI Core again. To see if maybe it was an issue with 1.5.1 or just the driver update that caused the problem.

File Attachment:

File Name: log_07-02-45.txt.zip
File Size:22 KB

-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
Attachments:

Please Log in or Create an account to join the conversation.

2 months 1 week ago 2 months 1 week ago by Lead_weight.
Lead_weight
Platinum Boarder
Platinum Boarder
Posts: 410
Karma: 4
More
Pegasus Astro UPB focuser error #53025
Jasem,

Here's an update now running Stellarmate 1.5.2, with the INDI Core updated per your instructions above.

ZWO Cameras do not load/activate now. My MBOX is plugged into the Pegasus UPBv2 along with my two ZWO Cameras. The MBOX loads, but the cameras do not.

I put in a bunch of focus commands moving the focuser in and out rapidly, and it appears to work without any errors. But something is wrong with the cameras not loading now. Also, the INDI Control panel button no longer works in EKOS. It only appears after you connect the devices. But you can't open it again after closing it from EKOS.

New log attached.

File Attachment:

File Name: log_09-05-59.txt.zip
File Size:15 KB

-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
Attachments:

Please Log in or Create an account to join the conversation.

2 months 1 week ago
Lead_weight
Platinum Boarder
Platinum Boarder
Posts: 410
Karma: 4
More
Pegasus Astro UPB focuser error #53026
It appears nothing plugged into the USB ports are being recognized by INDI. I think this is related to the driver changes issued by Paul in this other thread.

indilib.org/forum/development/6873-probl...sal-power-box-2.html

-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/

Please Log in or Create an account to join the conversation.

2 months 1 week ago
Lead_weight
Platinum Boarder
Platinum Boarder
Posts: 410
Karma: 4
More
Pegasus Astro UPB focuser error #53027
One other addition. I left the MBOX plugged into the Pegasus UPB. The driver for MBOX loads, but it refuses to connect on any of the available USB ports.

Attached log. Just to note. Reverting to a clean 1.5.2 restores all cameras, drivers USB ports to operational point. With the only issue being the FOCUS problem with UPB. So other updates in the INDI Core library are causing the cameras, pegaus USB ports, and possibly the MBOX issues I'm seeing.

File Attachment:

File Name: log_09-31-13.txt.zip
File Size:9 KB

-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
Attachments:

Please Log in or Create an account to join the conversation.

2 months 1 week ago
knro
Administrator
Administrator
Posts: 8093
Karma: 51
Pegasus Astro UPB focuser error #53028
So the name was corrected to Pegasus UPB and you need to write this in the drivers list instead.. does it work then?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

Time to create page: 0.237 seconds