×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

New Raspberry pi 4 anounced

  • Posts: 1275
  • Thank you received: 221
A version of Ubuntu Server 18.04.2 is now available for the Raspberry Pi 4. It does not have a desktop, but one can be installed.
jamesachambers.com/raspberry-pi-ubuntu-s...-installation-guide/
INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
PHD2
Waveshare Stepper Motor Board - DIY Focuser
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
The following user(s) said Thank You: AstroNerd
3 years 2 months ago #41208

Please Log in or Create an account to join the conversation.

  • Posts: 377
  • Thank you received: 27

Replied by Paul on topic Re:New Raspberry pi 4 anounced

I don't know if it is me, but that Facebook link did not work. Do you need a Facebook login to use it?

Paul
Losmandy G11 with Gemini 2 controller
QSI 583/683 monochrome camera with filter wheel
Starlight Xpress Lodestar X2 guide camera
Microtouch Focuser controlled using Arduino UNO emulating Feathertouch controller
Raspberry Pi 2GB with Raspberry Pi OS 64bit Buster
Last edit: 3 years 2 months ago by Paul.
3 years 2 months ago #41214

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 3
Yes I imagine so
3 years 2 months ago #41215

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 2
As the ubuntu flavor for the rpi4 is not ready yet I took a shot at compiling kstars/ekos/indilib from source for the rpi4 raspbian OS. It seems that I got it working, at least for my set up.



So this is an 7zip image of my sdcard. It was made with win32DiskImager. You will need a 32GB formated as FAT32.



drive.google.com/a/thinkwise.mx/file/d/1...zg/view?usp=drivesdk




The setup I got working is:
- Skywatcher AZ-GTI wireless mount
- ASI Cameras (294MC Pro and 120MM-s)
- also tried Sony A7iii
- sky safari service



All my test were indoors, is pouring rain and clouds here in Mexico City, so I could not try guiding and the actual plate solve (I tried with a demo image and worked - from the command line). Don't forget to change timezone.



I don't know if other devices will work, but I compiled all the 3rd party drivers that were on the indilib github.



Services to act as a wifi access point are installed:
SSID: ASIAIR_jir (I also have and ASIAIR and don't want to keep changing the setup in my AZ-GTI access point parameter).
pw: 12345678



It's not configured to join a wireless network, when I need to get online I just plugged a network cable. You will have to configure this if you want, but I am afraid you will loose the Access point functionality.



In the OS:
user: pi
pw: xsw21qaz

SSH is enabled, also VNC for remote desktop.



astrometry files: /home/pi/astrometry/data
I only installed the indexes for 14 to 140 arcminutes. The INDI index downloader is not working (it reports an access violation) so you will have to download by hand.



I haven't tested this extensively nor plan to support this build. So you are on your own.



Enjoy,

Jorge
The following user(s) said Thank You: Keld Henningsen
Last edit: 3 years 2 months ago by Jorge Restrepo.
3 years 2 months ago #41304

Please Log in or Create an account to join the conversation.

  • Posts: 86
  • Thank you received: 9
Thanks for sharing the disk image but the link isn't working.
3 years 2 months ago #41310

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 2
Sorry about it. I edited the post.
3 years 2 months ago #41312

Please Log in or Create an account to join the conversation.

  • Posts: 86
  • Thank you received: 9
I just tested it with my RPI4 and all my devices connected the first try! And for someone who's still new to RPi's, that's saying something. Slewed, solved, guided and captured the Eastern Veil without any snags. Thanks for sharing. Forgive me since I'm still new to RPi's but how do I connect to my personal wifi? I've looked all over the internet and I can't seem to figure out how you created the wifi access point. I'm sure you did it from the command line but how can I create and connect to wifi access points via GUI?
The following user(s) said Thank You: David Tate
3 years 2 months ago #41319

Please Log in or Create an account to join the conversation.

  • Posts: 329
  • Thank you received: 88

Replied by han on topic New Raspberry pi 4 anounced


In Raspian, there is on the top right (near the time indication) an clickable blue icon. Click on it , select your Wifi access point and enter the password.
3 years 2 months ago #41321

Please Log in or Create an account to join the conversation.

  • Posts: 302
  • Thank you received: 39

I hope there is another way, but the way I've been doing it (RP 3b), it to initially hook up a monitor and wireless mouse/keyboard. Then go setup the wifi requirements, make sure I'm attached to my network. Then disconnect everything and off it goes to my scope.
3 years 2 months ago #41322

Please Log in or Create an account to join the conversation.

  • Posts: 1067
  • Thank you received: 137

It does not work like that when a hotspot had been set up and activated, please read the rest of the thread... :)
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
3 years 2 months ago #41327

Please Log in or Create an account to join the conversation.

  • Posts: 1067
  • Thank you received: 137

Because with this raspbian set up that you have downloaded there is a hotspot set up, then setting it to use your own WiFi is more difficult than normal, you can have both but it requires some coding, really you Have to have either one or the other, so best to stop the hotspot and then set up your own WiFi, once you have done this then it does not need doing each time, it will auto connect to your home WiFi, when powered up, if it doesnt then set it up in the WiFi settings to auto connect when the network is available..
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
3 years 2 months ago #41328

Please Log in or Create an account to join the conversation.

  • Posts: 86
  • Thank you received: 9
The top right icon just tells me there's no wifi modules available. I've tried to change the wpa_supplicant file. It will at least recognize my network but it won't connect to it even if I tell it to connect. It's like the hotspot broadcast has it disable and is the priority. I don't know enough about raspbian to know how to change this. Regardless, I tested it with iEQ45 Pro, ASI183MM-Pro, ZWO EFW, ASI120MM-S and everything worked great. Imaged all night and worked just like on the StellarMate Pi but obviously quicker since it was a Pi4 with USB 3.0
3 years 2 months ago #41329

Please Log in or Create an account to join the conversation.

Time to create page: 1.048 seconds