×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

AstroPi3 Scripts revised

10 months 2 weeks ago
rlancaste
Supernova Explorer
Supernova Explorer
Posts: 2269
Karma: 22
More
Topic Author
AstroPi3 Scripts revised #45435
Ok my pull request just got merged. Please test it to see if this fixed the build problem
The following user(s) said Thank You ar2star2

Please Log in or Create an account to join the conversation.

10 months 2 weeks ago
Avocette
Expert Boarder
Expert Boarder
Posts: 151
More
AstroPi3 Scripts revised #45437

rlancaste wrote: Ok my pull request just got merged. Please test it to see if this fixed the build problem

Hi Rob,
Morning here so I reran your script on the Pi4. The Drivers for the cameras and GPSD have all returned. However there is another more serious problem now. Every time I try to launch Ekos with any equipment profile, KStars crashes. The Indiserver is left running, apparently, so waking up KStars brings up a message about closing down the Indiserver before starting up Ekos, but everything just crashes when you do this.

Currently running KStars/Ekos/Indi on a Raspberry Pi 4B 2GByte under Raspbian thanks to Astroberry
Sky-Watcher ED80 Pro with 0.85x FR/Corrector with Canon DSLR on AZ-EQ5 GT mount
Other Sky-Watcher scopes - SkyMax 150 Pro Maksutov Cassegrain and Explorer 150p Newtonian

Please Log in or Create an account to join the conversation.

10 months 2 weeks ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 37
More
AstroPi3 Scripts revised #45438
Rob,
Same here.
Re-ran the script and all the cameras display in the drop down menu and can be selected, but trying to start Ekos results in a crash and Indiserver is left still running in the background. Restarting KStars allows you to set up Ekos again, but when trying to start Ekos there is a warning about Indiserver running and it asks if you wish to close, as soon as you try to close the Indiserver it crashes KStars again.

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80

Please Log in or Create an account to join the conversation.

10 months 2 weeks ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 37
More
AstroPi3 Scripts revised #45439
Rob,
Success I’ve just ran the script on a fresh install of Raspbian Buster and it’s all working fine, all cameras, mounts, focuses, filter wheels are there & no crashing on starting Ekos.

Well done, many thanks

Alan

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80

Please Log in or Create an account to join the conversation.

10 months 2 weeks ago 10 months 2 weeks ago by Avocette.
Avocette
Expert Boarder
Expert Boarder
Posts: 151
More
AstroPi3 Scripts revised #45442
New installation is working better, thanks, certainly in the main elements that are easy to test indoors in foul weather!
I have had a better chance to look more carefully at some hiccups that have confused me in the past (in the dark).
I will post some issues I have identified under the appropriate headings.

Currently running KStars/Ekos/Indi on a Raspberry Pi 4B 2GByte under Raspbian thanks to Astroberry
Sky-Watcher ED80 Pro with 0.85x FR/Corrector with Canon DSLR on AZ-EQ5 GT mount
Other Sky-Watcher scopes - SkyMax 150 Pro Maksutov Cassegrain and Explorer 150p Newtonian

Please Log in or Create an account to join the conversation.

10 months 2 weeks ago
mpfjr
Senior Boarder
Senior Boarder
Posts: 71
More
AstroPi3 Scripts revised #45465
Had an error in the terminal that I saw that I wanted to make sure you knew about. Didn't seem to bother anything but hey, an error is an error.

Raspbian for pi4

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~ Checking items that will require your input while running the script, so you don't get asked so many questions later. Note that some installations later (VNC, samba in particular) may still require your input later on, this is out of my control.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

ls: cannot access '/etc/NetworkManager/system-connections/': No such file or directory

Please Log in or Create an account to join the conversation.

10 months 2 weeks ago
rlancaste
Supernova Explorer
Supernova Explorer
Posts: 2269
Karma: 22
More
Topic Author
AstroPi3 Scripts revised #45466
Thanks! That one is just fine though. That file shouldn't exist yet if this is a fresh raspbian system. The check for that particular folder will only be needed later if you run the script again and the file does exist.

Please Log in or Create an account to join the conversation.

10 months 2 weeks ago
rlancaste
Supernova Explorer
Supernova Explorer
Posts: 2269
Karma: 22
More
Topic Author
AstroPi3 Scripts revised #45472
Ok I revised it so that the error message should not appear anymore if the folder doesn't exist.

Please Log in or Create an account to join the conversation.

10 months 2 weeks ago
mpfjr
Senior Boarder
Senior Boarder
Posts: 71
More
AstroPi3 Scripts revised #45477
Just curious and I know I could literally install this and look for myself .. but was curious if you happen to have ASTAP support installed and configured with this script? I don't see it in the notes.

Is that something you might be interested in adding if you haven't already?

Thanks!

Please Log in or Create an account to join the conversation.

10 months 2 weeks ago
rlancaste
Supernova Explorer
Supernova Explorer
Posts: 2269
Karma: 22
More
Topic Author
AstroPi3 Scripts revised #45483
Not yet but that is easy enough to add
The following user(s) said Thank You mpfjr

Please Log in or Create an account to join the conversation.

10 months 2 weeks ago
sjako
Fresh Boarder
Fresh Boarder
Posts: 2
More
AstroPi3 Scripts revised #45561
Hi,
I ran the Raspbian script on my new Pi4 and it worked fine. I can connect to all my devices and control them properly.
Only issue I detected is that the "Skywatcher Synscan Legacy" driver for my mount is not visible via INDI Web Manager and can't be connected remotely.
Local on the PI4 it is visible and working.
Any idea?
Thx for the great work - clear skies :-)

Please Log in or Create an account to join the conversation.

10 months 2 weeks ago
rlancaste
Supernova Explorer
Supernova Explorer
Posts: 2269
Karma: 22
More
Topic Author
AstroPi3 Scripts revised #45577
That could have something to do with the fact that you might still be using KStars 3.3.6 on your client machine, I'm not sure. In a couple of days, you should have 3.3.7 and then maybe it will be fixed.

Please Log in or Create an account to join the conversation.

Time to create page: 0.722 seconds