×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Ubuntu MATE now works on Raspberry Pi4

10 months 3 days ago
avarakin
Expert Boarder
Expert Boarder
Posts: 101
More
Ubuntu MATE now works on Raspberry Pi4 #45845

starhopper wrote: I had some trouble

1. the complete process stopps because sbig-indi (I need it) cannot be found? I commented it out.
2. chromium-browser installation lags several minutes. I commented it out.

After the installation process a nice pink fox was visible via VNC :-)

It take long time until the built-in wireless adapter was visible in the system.


Thomas,
I did not use this script for real work yet, I only tested the build under the simulator.
Yes, there are some issues with indi drivers in the PPA, although there was no problem with sbig driver at the time when I was building my Pi4.
I guess 19.10 is not fully cooked yet.
I did not notice slowness with wifi, although I mostly connected to it using ethernet. How long does it take for you?
My Pi4 is 2GB version, I guess I was lucky that I did not go with 4GB version.

Here is my older script (see Pi4 section) which I used for building my current production system. Even though this build is very hacky, it is rock solid and I never had problems with it for couple of months:
github.com/avarakin/astropi
The script is a little messy because it started with Mate 16.04, then moved to 18.04 and finally to Pi4, so I am not sure all is working there, but it is very simple so it should be easy to troubleshoot.
Feel free to try and let me know if you run into issues.


Alex

Please Log in or Create an account to join the conversation.

10 months 3 days ago
avarakin
Expert Boarder
Expert Boarder
Posts: 101
More
Ubuntu MATE now works on Raspberry Pi4 #45846

El Corazon wrote: The unexplained KStars crashes are a far bigger problem. This is NOT a KStars problem, though, since the same KStars versions work fine on my Zotac mini PC with the same version of Ubuntu MATE, so it must be Pi4 related.


El,
I am running Kstars on Pi4, which is based on 18.04 and I did not have any crashes.
Here is the process I used for building my 18.04 system (see Pi4 section):
github.com/avarakin/astropi

Alex

Please Log in or Create an account to join the conversation.

10 months 3 days ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 835
Karma: 3
More
Topic Author
Ubuntu MATE now works on Raspberry Pi4 #45847
Got it!
I used the same server image and just built up the system from there by adding Gnome and MATE desktop environment and other components I wanted.

Crashes may be dependent upon the peripherals that are connected. With my Nikon D3300, I would get these random crashes. When I use my ASI1600MC-Pro instead, so far it looks a lot more stable.
There are still a few idiosyncracies, though: For instance, I cannot Polar align if I choose the mount to go towards the East. Then everything crashes at the solver stage. I need to restart and slew to the West ONLY. Then there is no crash and the solve completes fine.
That could also be mount specific, though, have only tested on iOptron SmartEQPro+ so far.

Anyway, why are you trying to use Ubuntu 19, if 18 gives you full RAM and USB functionality?

Jo

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

10 months 3 days ago
avarakin
Expert Boarder
Expert Boarder
Posts: 101
More
Ubuntu MATE now works on Raspberry Pi4 #45848

El Corazon wrote: Got it!
I used the same server image and just built up the system from there by adding Gnome and MATE desktop environment and other components I wanted.

Crashes may be dependent upon the peripherals that are connected. With my Nikon D3300, I would get these random crashes. When I use my ASI1600MC-Pro instead, so far it looks a lot more stable.
There are still a few idiosyncracies, though: For instance, I cannot Polar align if I choose the mount to go towards the East. Then everything crashes at the solver stage. I need to restart and slew to the West ONLY. Then there is no crash and the solve completes fine.
That could also be mount specific, though, have only tested on iOptron SmartEQPro+ so far.

Anyway, why are you trying to use Ubuntu 19, if 18 gives you full RAM and USB functionality?

Jo


Just for reference - my equipment is ZWO 174 guider, SBIG ST8300 CCD, OnStep mount.
Never had problems with polar alignment, although I dont use it much given that I use permanent setup most of the time.

I don't like 18 because it is a big hack - Raspbian firmware transplanted into Ubuntu.

Alex

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago 9 months 3 weeks ago by calberts.
calberts
Expert Boarder
Expert Boarder
Posts: 106
More
Ubuntu MATE now works on Raspberry Pi4 #46183
Hi

This all above is als about ubuntu 18.04 but what about ubuntu.com/download/raspberry-pi 19.10 its fully supported RP4 . Did some already try Kstars/Indi on this version?
and what desktop do you advise?.

I also understood that the 32bt is more stable


Chris

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago
avarakin
Expert Boarder
Expert Boarder
Posts: 101
More
Ubuntu MATE now works on Raspberry Pi4 #46184

calberts wrote: Hi

This all above is als about ubuntu 18.04 but what about ubuntu.com/download/raspberry-pi 19.10 its fully supported RP4 . Did some already try Kstars/Indi on this version?
and what desktop do you advise?.


Chris,
The script, which I shared above github.com/avarakin/AstroPiMaker4 is based on the distro you are referring to.
My script installs both Mate and Plasma Desktop. I switch between them once in a while, they both work fine, it is just a matter of preference.

Alex

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago
calberts
Expert Boarder
Expert Boarder
Posts: 106
More
Ubuntu MATE now works on Raspberry Pi4 #46185
Alex

Thanks, so its based on the 19.10, cool i will check your script, i am folling you now Gith..

Chris

Please Log in or Create an account to join the conversation.

9 months 2 weeks ago
khobar
Expert Boarder
Expert Boarder
Posts: 117
More
Ubuntu MATE now works on Raspberry Pi4 #46441
Have you had any further luck with the internal wifi? I ask because I have the same problem - the internal wifi cannot even see my home network using Stellarmate OS. However, Astroberry on the same Pi4 has no trouble seeing and connecting without using a dongle.

Please Log in or Create an account to join the conversation.

9 months 2 weeks ago 9 months 2 weeks ago by El Corazon.
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 835
Karma: 3
More
Topic Author
Ubuntu MATE now works on Raspberry Pi4 #46442
Not definitively yet.

I have added auto wlan0 to /etc/interfaces. That now let’s me see my networks.

It still doesn’t connect automatically to the internal WiFi, though.

I have not gone through this possible solution yet:

weworkweplay.com/play/automatically-conn...i-to-a-wifi-network/

If you try it out, please let us know if it works.

Cheers

Jo

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

9 months 2 weeks ago 9 months 2 weeks ago by AtM.
AtM
Senior Boarder
Senior Boarder
Posts: 63
Karma: 1
More
Ubuntu MATE now works on Raspberry Pi4 #46454
Remove the netplan stuff, it is in the way when you just want to use ifupdown and /dev/network/interfaces to control your networking.

I did it like I described here (in section 2): http://atm.udjat.nl/stepper/Remote%20Control%20-%20EN.pdf

Edit:
Just found out that hostapd re-initializes the wlan interface, so it has no longer an address.
In the user .profile file I now added at the end:
sudo ifconfig wlan0 192.168.3.1
sudo service hostapd restart

Please Log in or Create an account to join the conversation.

5 months 3 weeks ago
avarakin
Expert Boarder
Expert Boarder
Posts: 101
More
Ubuntu MATE now works on Raspberry Pi4 #51060

avarakin wrote: Pi4 is now officially supported by Ubuntu, although it does not come with UI.
I developed a script which installs all imaging software I use plus KDE by default or mate as on option.
The script and instructions are available here:
github.com/avarakin/AstroPiMaker4


I had to rebuild my imaging Pi4 about a month ago and I used the latest Ubuntu Server 19.10 images.
I updated my scripts on
github.com/avarakin/AstroPiMaker4
as part of this rebuild.
The issues I observed in the past are solved now and after several imaging sessions, I can conclude that the system is very fast, stable and reliable.
Feel free to use and/or fork and let me know if you see any issues.

Looks like the good old Ubuntu Mate distribution is still lacking support for RPi4. I don't think I will ever go there again - much safer and faster getting the images directly from Ubuntu, given that all groundwork of building the system from Ubuntu Server image is now completed.

BTW, Mate is getting really long in the tooth and I am switching to Gnome 3 on my computers.
It is running surprisingly well on RPi4.
"Dash to Panel" and "System Monitor" Gnome extensions are making Gnome work very similar to Mate.
They are included as part of my script.

Alex

Please Log in or Create an account to join the conversation.

5 months 3 weeks ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 835
Karma: 3
More
Topic Author
Ubuntu MATE now works on Raspberry Pi4 #51061
I am not sure whether there is really anything substantially different between the official Ubuntu MATE support now and the prior install from the server and sequential updates. I suspect the outcome is pretty much the same.
I did it the old fashioned way, starting from the server and sequentially building up the system and my system is also quite stable now. No reason for me to switch that I can see.
But I am looking forward to hearing the experience others might have.

Of course, by now the official Ubuntu system is 20.04.....

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

Time to create page: 1.027 seconds