×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

Pi4, USB3, and Wireless 2.4Ghz interference

  • Posts: 1067
  • Thank you received: 136

Right click on the network icon, and then choose settings, in there you choose the hotspot, and settings again, then on one of the tabs you will see the option to have either 2.4, 5ghz or auto, change it there.... :)
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
The following user(s) said Thank You: Matteo Gaetan
10 months 3 weeks ago #65701

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 4
That worked, thank you!
10 months 3 weeks ago #65872

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
RF interference is affected only by distance.  The farther away you can place your USB2 devices from the USB3 ports, the better.

I have a GPS dongle that is USB2.  The RFI affects GPS reception.  I had to put the dongle 6 feet away from the PI on a powered hub.  I played with surrounding the PI4 with foil to test other ways to reduce the noise.  Most of the interference is generated at the connector itself.

The powered hub is required else my GPS dongle doesn't get enough power from USB to be able to generate consistent data.


 
8 months 3 weeks ago #68489

Please Log in or Create an account to join the conversation.

  • Posts: 22
  • Thank you received: 1
Just to confirm the issue: I have no GPS reception (NEO 6M Board connected to the Rapi GPIO) as soon as I plugin the ASI120 into USB3! What a bummer! Not only did it take me forever to pinpoint this issue, it is als frustrating because I rely on the GPS for position and time when I am out in the field... I will try to tinker with it a little bit (placement of antenna etc.), but I am not hopeful
6 months 4 days ago #71766

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 3
One thing that helped me when I was troubleshooting the 2.4Ghz and USB3.0 issue was making sure I had the correct country code set in my netwrok/wifi settings. Wifi channels and signal strength differ from country to country. When I was pinning my astroberry to only run in 5Ghz hotspot mode and only connect to my 5Ghz home wifi SSID, I could not reliably connect after reboots. I read in another forum about the country code setting.

Run raspi-config and go to "Localisation Options" then "Change Wi-fi Country". Set it your country.

Mine has be very stable since I made this change. HTH
6 months 4 days ago #71772

Please Log in or Create an account to join the conversation.

Time to create page: 0.459 seconds