×
INDI Library v1.8.4 Released

Minor bugfix release with some highlights:

Ekos resetting focuser position to zero?

2 weeks 3 days ago
mlarsson
Platinum Boarder
Platinum Boarder
Posts: 348
Karma: 1
More
Topic Author
Ekos resetting focuser position to zero? #50674
Hi!

I've experienced twice now that Ekos, when running the scheduler, resets my focuser position to zero. I have a MyfocuserPro, home built, and it was focused nicely to about position 11800. Then I start the scheduler and suddenly, when scheduler begins focusing, it is at 0 (zero) - but it didn't move, so resetting in some way. Anyone knows what is happening here? Log file attached. (I hope it is the correct log file)

Magnus


C8, Losmandy G11, Canon 1000D astromodified.
Attachments:

Please Log in or Create an account to join the conversation.

2 weeks 2 days ago
knro
Administrator
Administrator
Posts: 7733
Karma: 51
Ekos resetting focuser position to zero? #50694
Indeed the log shows that the focus position is set to zero from the driver side. Is this repeatable? i.e. run scheduler and position will always reset to zero?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

2 weeks 2 days ago
mlarsson
Platinum Boarder
Platinum Boarder
Posts: 348
Karma: 1
More
Topic Author
Ekos resetting focuser position to zero? #50695
Hi!

I can not systematically reproduce it, but it has happened twice lately - unattended runs of the scheduler. Last night, I ran the scheduler sveral times, while attending it, and could not repeat...

Magnus


C8, Losmandy G11, Canon 1000D astromodified.

Please Log in or Create an account to join the conversation.

2 weeks 2 days ago
TallFurryMan
Platinum Boarder
Platinum Boarder
Posts: 798
Karma: 13
More
Ekos resetting focuser position to zero? #50696
I have also seen this, very rarely. It might relate to #1099?

-Eric

HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access

Please Log in or Create an account to join the conversation.

2 weeks 2 days ago
Ihoujin
Platinum Boarder
Platinum Boarder
Posts: 806
Karma: 3
More
Ekos resetting focuser position to zero? #50707
I've also struggled with recovering from unexpected crashes where the focus position is the default 0 on restart. It would be nice to be able to set some arbitrary value so it can perform inward and outward movements without physically resetting the focuser.

INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
PHD2
Adafruit Motor Hat shield
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
The following user(s) said Thank You Herrhausen

Please Log in or Create an account to join the conversation.

1 week 3 days ago
mlarsson
Platinum Boarder
Platinum Boarder
Posts: 348
Karma: 1
More
Topic Author
Ekos resetting focuser position to zero? #50927
Hi!

One thing I have noticed recently, is that when I start Ekos, the steps value in the Focus module where I can set the steps I want it to go to, is zero. THe position is OK, but the box to the right of it is zero. I wonder if this is related to the issue here. Why is it not set to present position by default?

Magnus


C8, Losmandy G11, Canon 1000D astromodified.
The following user(s) said Thank You Herrhausen

Please Log in or Create an account to join the conversation.

6 days 11 hours ago
mlarsson
Platinum Boarder
Platinum Boarder
Posts: 348
Karma: 1
More
Topic Author
Ekos resetting focuser position to zero? #51049
Hi!

I had another one of these tonight. Started Scheduler with focus position around 11400, scheduler sleeing for some 45 mins, and then starts - with zeroing the focuser position, resulting in all jobs aborted since focus can not be reached with the filter I was using, and that would be somewhere around -300... and that does not work.

This is really intermittent. I've been using the schedular extensively the last few days with nothing like this happening. Today I updated the Stellarmate, but that should not matter since it has been there for a while.

Here's the log.

Magnus


C8, Losmandy G11, Canon 1000D astromodified.
Attachments:

Please Log in or Create an account to join the conversation.

5 days 22 hours ago
knro
Administrator
Administrator
Posts: 7733
Karma: 51
Ekos resetting focuser position to zero? #51086
The stable INDI is not yet updated on SM. You can use the latest by using these commands:
update_indi_core

After that is, you can run this:
update_indi_drivers

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

Time to create page: 0.593 seconds