×
INDI Library v1.8.4 Released

Minor bugfix release with some highlights:

weatherradio lastupdate field blank when no windspeed [SOLVED]

1 week 1 day ago 6 days 17 hours ago by procras. Reason: Solved
procras
Senior Boarder
Senior Boarder
Posts: 55
More
Topic Author
weatherradio lastupdate field blank when no windspeed [SOLVED] #50968
From my other post the lastupdate field contains only -- and not the proper date and time.

The root of the problem is that I don not have a wind speed device.

The function in chart.js that updates #lastupdate throws an error due to there being no windspeed.

<code>
Uncaught TypeError: Cannot read property 'toFixed' of null
at Object.success (charts.js:263)
at c (jquery.min.js:2)
at Object.fireWith [as resolveWith] (jquery.min.js:2)
at l (jquery.min.js:2)
at XMLHttpRequest.<anonymous> (jquery.min.js:2)
(anonymous) @ charts.js:263
c @ jquery.min.js:2
fireWith @ jquery.min.js:2
l @ jquery.min.js:2
(anonymous) @ jquery.min.js:2
load (async)
send @ jquery.min.js:2
ajax @ jquery.min.js:2
k.<computed> @ jquery.min.js:2
updateSeries @ charts.js:240
init @ charts.js:232
onload @ weatherradio.html:19
</code>

This is triggered by
<code>
windSpeed.updateSeries([{name: "Wind Speed", data: [currentWindSpeed]}]);
</code>

Moving call to update lastupdated prior to this means it gets updated fine.

Tweaking required if the probes/sensors do not match up with the webpage.
The following user(s) said Thank You sterne-jaeger

Please Log in or Create an account to join the conversation.

1 week 1 day ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 475
Karma: 6
More
weatherradio lastupdate field blank when no windspeed [SOLVED] #50971
Aaaah, thanks! I didn't check that for the web page. The INDI driver meanwhile should be flexible about which devices are connected.

- Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro + ASI 294mc pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

1 week 1 day ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 475
Karma: 6
More
weatherradio lastupdate field blank when no windspeed [SOLVED] #50974
OK, I found the problem. If you want to get the latest version, I am working currently on Version 1.0 .

Btw: the page should update every 5 minutes (I wasn't aware of it anymore :-)). There was another bug that broke this.

- Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro + ASI 294mc pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

1 week 20 hours ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 475
Karma: 6
More
weatherradio lastupdate field blank when no windspeed [SOLVED] #50999
Version 1.0 is pushed. New to this version is the option to calibrate weather parameters through the INDI client.

- Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro + ASI 294mc pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10
The following user(s) said Thank You procras

Please Log in or Create an account to join the conversation.

1 week 11 hours ago
procras
Senior Boarder
Senior Boarder
Posts: 55
More
Topic Author
weatherradio lastupdate field blank when no windspeed [SOLVED] #51014
Thanks Wolfgang for fixing this.

Those changes to charts.js have fixed the problem with lastupdate when there is no windspeed.

Also it updates every 5 minutes on its own.
The time shown is the last time the data was updated which is before the current time as there is no sync between
the python scripts executing in cron and the webpage update, not a problem.

I will open another topic regarding a question I have on the cron scripts in Readme-WeatherRadio.md

Adrian

Please Log in or Create an account to join the conversation.

Time to create page: 0.182 seconds