INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

New Internal Solver for Mac, Windows, and Linux -- Testing/ Experiments needed

  • Posts: 312
  • Thank you received: 13
This is more comment than question, but I think this is the right group to bring this to. I installed Kstars release 3.5.0 on my Win 10 (64 bit) Laptop, 2 days ago. Last night was the first time I used it to actually run Kstars/Ekos, as previously I was running everything on the Rpi 4 (4 Gb memory at the scope) and just using the Laptop as a connection point. The release on the Rpi is an earlier one, but working fine in all points (except as I have said elsewhere it would loose connection to the server after working great for several hours). I ran the solver last night (after loading the index files needed for the FOV of my main, guide and finder scopes) and ran into several failed solves (that had seemed to work during PA when using the Rpi). I am finding that during PA, I need to turn off "use position" in the solver options to get the solver to work well. I PA first with my E-finder scope (ZWO ASI120MC on an Orion 9x50 finder) as that has a large FOV. Then PA with the main imaging camera (ZWO ASI533MC on the SCT 9.25, currently at F6.3). I noticed that after solving with the E-finder EKOS reported that the focal length of the scope (from the solve) differed from what I had entered (I entered 186 mm and it found 176 mm FL). I could only get it to reliably solve if I went and changed the focal length of the Efinder scope in the main configuration setting. Just want to let you know there is some sensitivity there in terms of the pixel scale.

The solves, when working, were extremely fast.

Initially, I attempted to use the astrometry on the Rpi as I knew that was working, even though I was running Kstars on the laptop. So I added Astrometry app, to the Server configuration. But I could not get that to work. As soon as I would start a solve (I selected the 'remote' button in EKOS Align and made location entry changes in the astrometry tab) it would fail and the Astrometry button would change color to 'disabled.' This may be a mute point (or something to be addressed later) as I will probably continue to use the solver on the laptop (it was so fast). But then I question the need/use of the Astrometry APP in the EKOS configuration. Isn't Astrometry always loaded if it is being used on the machine you are running Kstars on? I assumed the purpose of having it in the Server configuration was to use Astrometry on that local machine. I was assuming that since I am saving the images on the Rpi (to a large USB memory stick) that the solve might be faster as the data was there. But I guess the image data gets loaded up to Kstars wherever over ethernet (as I am connected to the Rpi) it is fast enough not to notice any lag.

The changes and updates to this release are amazing, while the capability of this program can be overwhelming, I hope the documentation can keep up!

Thanks for all the hard work and effort going in this.
1 year 7 months ago #63683

Please Log in or Create an account to join the conversation.

  • Posts: 2722
  • Thank you received: 760
So at this point, using the remote solver using the INDI driver astrometry solving with the PI is more of a legacy method of doing things. By far the best way to plate solve is to solve on whichever laptop is running KStars, and usually that computer tends to be the faster one. The "remote" method using the INDI Astrometry driver primarily existed because in the past, it was not easy to install astrometry.net on Windows or Mac and get it all set up to work really well with programs like KStars. Basically it provided an easier way to get it all set up. But now that I made StellarSolver, it isn't really needed anymore since you can now solve internally in KStars. We didn't want to completely get rid of the remote method in this release because a number of people already have their system all set up to use "remote" solving, but if you are using that method, I would definitely recommend transitioning if you can.

For the stuff you mentioned in the first paragraph, those are things with KStars, not really the solver, so we will need to look into these kinds of things to make the performance in KStars a little better. We did a whole lot of work integrating it into KStars, and it probably isn't all perfected yet, but its close.

We will have to work on the documentation, yes, I know I have had a lot of other work in my job etc, and it took quite a lot of work to finish StellarSolver and get it all integrated and working. I just haven't had time to look at documentation. You are right though.
1 year 7 months ago #63686

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 0
So what solving method do you suggest for me? My rpi4 at the scope running astroberry with kstars 3.4.x does it all currently with only an external computer (or iPad) necessary to setup the schedule and polar align. The Indi platesolve works well in this scenario. I assumed the updated solver would also behave well in this use case, but from the last post it sounds like a laptop/ external computer is recommended. - or did I miss something?
1 year 7 months ago #63708

Please Log in or Create an account to join the conversation.

  • Posts: 312
  • Thank you received: 13
I can only relate my experience as I am not involved in any of the development. I went to a laptop to run Kstars, because I felt I was over burdening the Rpi4. But the plate solving was not the problem, it was later on in the imaging sessions that I had problems with server disconnects. Tonight, I ran Kstars from the laptop and things went well (solves were very fast), but later on while guiding (with Phd2 running on the Rpi) and imaging from the Laptop, the whole system got very sluggish, and I don't know the cause of this yet (have to look at the logs and see if they tell me something). Eventually, the response got so bad, on the laptop (several seconds to respond to a mouse click) that I just stopped everything and restarted. But then clouds moved in and I just ended the session. I think you have to find out what works best for your setup and stay with that. The Rpi seems capable to handle all the task individually, but at sometime later it just seems to run out of gas.

At this point it has become a very complicated system that has wonderful capabilities (like Polar alignment assist, plate solving, guiding, etc), but there is a price to pay in system performance, especially as we try to move to smaller computers (like the RPi) at the equipment. But my experience tonight says even that may not be the limitation.

1 year 7 months ago #63709

Please Log in or Create an account to join the conversation.

  • Posts: 1117
  • Thank you received: 182
I use a Pi4 with 8 Gb and have no such problems with it except fir the occasional loss of WiFi connection.
I think I have overcome that by using an external WiFi dongle.

I am also using an external SSD for image saving, astrometry files and a Swap partition.

And I am running Ubuntu 20.04, not Raspbian OS. Looks to me the Pi has a lot of power to spare with that configuration.

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
1 year 7 months ago #63710

Please Log in or Create an account to join the conversation.

  • Posts: 2722
  • Thank you received: 760

So if you are running everything on the Pi, that is perfectly fine with the new solver and with KStars 3.5.0. StellarSolver is running very very well on a Pi right now. It sounds like you are using the external computer or iPad to access the Pi with VNC or something similar to access KStars on the Pi, that use case works just fine. You don't need to add the Astrometry driver in INDI to your profile if you are doing it this way because KStars can just solve the image directly using StellarSolver.

The use case that was being discussed earlier was using an external computer such as a Mac or a PC to run KStars and connect remotely to the PI to get the devices, and then NOT having Astrometry running on the laptop and sending the images to the PI to solve using the INDI astrometry driver. That doesn't sound like what you described.
1 year 7 months ago #63711

Please Log in or Create an account to join the conversation.

  • Posts: 2722
  • Thank you received: 760

we are always working to improve the system and performance. If you find out something that is slowing it down, please let us know.
1 year 7 months ago #63712

Please Log in or Create an account to join the conversation.

  • Posts: 312
  • Thank you received: 13
Since you asked. It does appear that my problem of Kstars (running on a Win 10 64 bit laptop) slowing down seems to be related to using the internal guider. When I run Phd2 on the Rpi (which is just running the server connection to the equipment) there is some lag, but not much on the laptop screen. Both last night and tonight I tried running the internal solver and both time, while it was running, Kstars slowed down. I can see the lag in the countdown timer of images, they skip about 3-5 seconds between display. that seems to how long I have to wait for a button to be clicked with the mouse (and naturally by then I have clicked several other buttons). It does not appear that the laptop slowed down, when I leave Kstars, other windows respond as usual, it is just Kstars slowing down due to what ever is going on in the internal guide routine. I am using a sub-window for the guider, so it only updates a small star window on the screen.

The other issue that seems related to this is that I end up with several Fits Viewer windows open and closing them with the lag becomes a problem.

I realize that this may have nothing to do with the solver, for which this thread was about, but since you asked about it I responded here. I may start another thread as I collect more information about this issue.

I did have a couple of failures tonight with the solver, StellaSolver running on the laptop. The failures are all when I use the main scope with the main imaging camera (SCT9.25F6.3 and a ZWOASI533), the FOV is only about 26 arcmin square and sometimes it works and sometimes it doesn't. The failures are mostly around the pole as I polar align first using the Efinder (which has a 70 x 90 arcmin FOV) and once I get that close I do it again using the main scope and the main camera. It may just be a matter of changing some parameters, as I have downloaded all of the required and suggested indices. Solving elsewhere in the sky with the main scope does seem to work, so it may just be and issue around the pole.

thanks again for all the effort .
1 year 7 months ago #63782

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 2

I am a complete novice at astronomy but I am pretty computer literate and have contributed to the Celestron INDI Driver.

I am having scant success with Plate Solving, I have been using the CCD simulator to try to work out how to use it but have only had a couple of successful solves from hundreds to tries.

I am using a Mac and I have loaded all the indexes.

Hopefully someone can see from the screenshot my fatal mistake.

Ken K
Rpi4b 4gb on Scope
Celestron Nexstar 6SE
DIY Moonlite focuser
Raspberry Pi HQ camera
1 year 7 months ago #63817

Please Log in or Create an account to join the conversation.

  • Posts: 1242
  • Thank you received: 216
The align module takes information about your equipment from the camera driver and mount driver for focal length configurations. Focal lengths can be set in the Mount Tab, you must click Save Telescope Info. You should make sure to save the INDI Mount driver to preserve the settings. The align module uses this information to calculate the displayed field of view, which guides the solver to use appropriate indexes.
First make sure your equipment is properly specified and the correct camera and optics combination selected in the align module. Then make sure you have installed the necessary indexes found in the align module's options.

I would also suggest starting a new topic for troubleshooting such issues after searching the forum for answers; as this topic is for discussions on development, not tutorials. Thanks.
INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
Waveshare Stepper Motor Board - DIY Focuser
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
The following user(s) said Thank You: Ken Kelso
1 year 7 months ago #63832

Please Log in or Create an account to join the conversation.

  • Posts: 2722
  • Thank you received: 760
I see a couple of things. First, If you aren’t sure why it failed, try turning on Alignment logging in the Ekos log options to get feedback. I did add a notice about this to the Kstars Solver failed message the other day, but it’s not in the Mac or the released Linux version yet. I would say that I see very few stars in your image as well. I would either increase the exposure time to get more stars or Increase the field of view (you did say you are using the simulator). You need to give plate solving something to work with. Also, when you said “all the indexes”, surely you don’t mean you downloaded every single index file?? That is a lot of data, many many gigabytes. And you really don’t need them all, just the ones for the field sizes you tend to use.
The following user(s) said Thank You: Ken Kelso
1 year 7 months ago #63835

Please Log in or Create an account to join the conversation.

  • Posts: 312
  • Thank you received: 13

What version of Kstars 3.5.0 with StellarSolver is running very will on Pi right now? I cannot get it installed on a Raspbian Buster (armv71) system. The "building Kstars from source" link on this page leads nowhere,

I have loaded the latest Astroberry server image (2.0.3), it comes with Kstars 3.4.3. I tried the procedure to update to Kstars-bleeding, but it says I already have the latest Kstars. Is there anyway currently to get Kstars 3.5.0 (with StellarSover) running on the 32 bit version of Raspbian?

1 year 7 months ago #64016

Please Log in or Create an account to join the conversation.

Time to create page: 1.182 seconds