×

INDI Library v1.8.9 Released (01 Mar 2021)

INDI monthly update. In addition to driver improvements, major code refactoring is in progress by @pawel-soja to modernize and improve INDI aging code.

New forum users, please go here first: indilib.org/forum/new-forum-users.html

PHD2 can't manage to connect the mount.

  • Posts: 11
  • Thank you received: 0
Hi all,

I try to use PHD2 alone to check perriodic errror of my mount, but PHD2 doen't detect the driver of the mount (indi_starboork_telescope);

The camera is well recognize and in the assistant I'm able to select it, but not the mount. I can just click on INDI button to open the INDI window and then connect the mount but when I close this window, I can't validate and select the driver.

Nevetheless when I try to connect my setup to KSATRS EKOS, it seems that everything is ok.

To use PHD2 alone I first start both drivers via the command, indiserver -p 2000 indi_starbook_telescope for the mount and indiserver -p 3000 indi_asi_ccd for the guide camera.

It seems also that's working well.

I continue to investigate but does anyone could help me please?
11 months 6 days ago #53243

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
I would like to add updates:

I can select and validate the driver in the Aux mount connection
1st picture attached

But not in Mount connection:
2nd picture attached

Will I be able to do my PEC analysis and later a mount guiding with this setup, camera connected and aux mount connected?
3rd picture attached
Last edit: 11 months 6 days ago by laurent.wolff.
11 months 6 days ago #53247
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
I have share a debug log from PHD2 in PHD2 forum.
And I have just get a message from Patrick Chevalley concerning connection issue.
Apparently some driver modifications are needed.
Is there a standard way to ask for this modification?

“The problem is this INDI driver do not implement the required pulse guide command.
It only report a TELESCOPE interface instead of TELESCOPE|GUIDER, and PHD2 never receive the properties TELESCOPE_TIMED_GUIDE_NS and TELESCOPE_TIMED_GUIDE_WE so it cannot accept to connect as guide mount.
This explain why it connect as AUX mount because in this case the mount guide command are not necessary, only reading the pointing coordinates.

You can ask the developer of the driver if it is possible to add this guiding command. Otherwise the only solution is to use a ST4 cable from the camera. “
11 months 3 days ago #53411

Please Log in or Create an account to join the conversation.

I submitted a feature request here: github.com/indilib/indi-3rdparty/issues/124
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
11 months 3 days ago #53418

Please Log in or Create an account to join the conversation.

Time to create page: 0.433 seconds