×

INDI Library v1.9.4 Released (17 Jan 2022)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

KStars crashes when disconnecting with gphoto_ccd driver

  • Posts: 169
  • Thank you received: 28
I have a KStars crash each time I disconnect my profile in EKOS.
I tried to find the problem running profiles with only one device.
I got the crash with a profile with the gphoto_ccd driver (the profile has also the Telescope Simulator).
I checked the INDI and KStars logs and I didn't see anything special.

I tried to run KStars inside the debugger, but the debugger also crashed (!!). I am not familiar with it so maybe I did something wrong.
I searched for debugger log files but I could not find any...

I remember that very recently someone reported a KStars crash when disconnecting the profile but I could not find the post.

Any help is appreciated

This is with the last Stellarmate stable 1.5.8. Just upgraded today (Brought the updated SM tool for software upgrade)
Celestron AVX
Celestron SCT 8” Edge HD, Primaluce ESATTO
TS Optics Photoline 80mm f/6 FPL53 Triplet-Apo, Primaluce SESTO SENSO 2
Celestron OAG, Lodestar X2 guide
Pegasus PowerBox Advanced
Stellarmate Gadget
AstroPhotography Tool (APT)
Nikon D90
Last edit: 8 months 2 weeks ago by Joaquin.
8 months 2 weeks ago #70975

Please Log in or Create an account to join the conversation.

Thank you for the report. I just tested on SM OS with 600D. Profile Telescope Simulator + Canon DSLR. I couldn't reproduce the crash.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
8 months 2 weeks ago #70976

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 7
I also have this issue! I'm running:
- StellarmateOS 1.5.8 with latest updates
- RPi 4b 4GB
- CEM70+ASI290+Nikon D7500

I tested all combinations, and I narrowed it down to the Nikon D7500. When clicking disconnect, Kstars crashes.

Also for me EKOS debugger crashes even if nothing is connected.
RPi 4b 4GB with latest Stellarmate OS
iOptron CEM70 + iOptron SkyGuider Pro
Nikon D7500 (stock)
TecnoSky AG70 f/5
APM Image Master 50mm f/4.1
ASI290MM-Mini
Berlebach Planet + Berlebach 312 Astro Tripod
Last edit: 8 months 2 weeks ago by Paolo.
8 months 2 weeks ago #70989

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 7
Weirdly, this doesn't happen on my x64 laptop running openSUSE tumbleweed and latest INDI+Kstars. The issue seems specific to StellarmateOS and/or RPi
RPi 4b 4GB with latest Stellarmate OS
iOptron CEM70 + iOptron SkyGuider Pro
Nikon D7500 (stock)
TecnoSky AG70 f/5
APM Image Master 50mm f/4.1
ASI290MM-Mini
Berlebach Planet + Berlebach 312 Astro Tripod
8 months 2 weeks ago #70992

Please Log in or Create an account to join the conversation.

I'll try to test with Nikon, Canon works OK.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
8 months 2 weeks ago #70994

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 7
Unfortunately, this is still broken :(
The weird thing is that with an x86-64 laptop (same software) it works just fine. So it must be something related to the RPi slowness, I guess
RPi 4b 4GB with latest Stellarmate OS
iOptron CEM70 + iOptron SkyGuider Pro
Nikon D7500 (stock)
TecnoSky AG70 f/5
APM Image Master 50mm f/4.1
ASI290MM-Mini
Berlebach Planet + Berlebach 312 Astro Tripod
8 months 2 weeks ago #71041

Please Log in or Create an account to join the conversation.

  • Posts: 169
  • Thank you received: 28
I just checked and gphoto_ccd still crashes KStars on disconnect with last stable and updated SM1.5.8.
Is there any fix? Maybe in nightly?.
Celestron AVX
Celestron SCT 8” Edge HD, Primaluce ESATTO
TS Optics Photoline 80mm f/6 FPL53 Triplet-Apo, Primaluce SESTO SENSO 2
Celestron OAG, Lodestar X2 guide
Pegasus PowerBox Advanced
Stellarmate Gadget
AstroPhotography Tool (APT)
Nikon D90
8 months 1 week ago #71218

Please Log in or Create an account to join the conversation.

  • Posts: 169
  • Thank you received: 28
I just checked and gphoto_ccd still crashes KStars on disconnect with last stable and updated SM1.5.8.
Is there any fix? Maybe in nightly?.
Celestron AVX
Celestron SCT 8” Edge HD, Primaluce ESATTO
TS Optics Photoline 80mm f/6 FPL53 Triplet-Apo, Primaluce SESTO SENSO 2
Celestron OAG, Lodestar X2 guide
Pegasus PowerBox Advanced
Stellarmate Gadget
AstroPhotography Tool (APT)
Nikon D90
8 months 1 week ago #71219

Please Log in or Create an account to join the conversation.

I'm working on this issue with Pawel Soja, please give us a few more days to get around to it.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Paolo
8 months 1 week ago #71229

Please Log in or Create an account to join the conversation.

  • Posts: 169
  • Thank you received: 28
Sure, just wanted to know. Do not want to put any pressure. We all have enough already. I can wait. Thanks
Celestron AVX
Celestron SCT 8” Edge HD, Primaluce ESATTO
TS Optics Photoline 80mm f/6 FPL53 Triplet-Apo, Primaluce SESTO SENSO 2
Celestron OAG, Lodestar X2 guide
Pegasus PowerBox Advanced
Stellarmate Gadget
AstroPhotography Tool (APT)
Nikon D90
8 months 1 week ago #71236

Please Log in or Create an account to join the conversation.

Time to create page: 0.811 seconds